Table of Contents

Chapter 1: Getting started .......................................................................................................................... 6
  Help......................................................................................................................................................... 6

Installation and activation .......................................................................................................................... 7
  Installation of Acrobat XI Pro and Acrobat Pro DC ................................................................................. 7
  System Requirements ............................................................................................................................. 7
  Installation of Tetra4D Converter ........................................................................................................... 7

Running Tetra4D Converter ........................................................................................................................ 8
  License activation.................................................................................................................................... 8

Chapter 2: Tetra4D Converter Overview .................................................................................................... 9
  Tetra4D Converter for Acrobat XI Pro .................................................................................................... 9
  Tetra4D Converter for Acrobat Pro DC ................................................................................................. 10
  Tetra4D Converter Tools Menu ............................................................................................................ 11
    Insert 3D............................................................................................................................................ 11
    Export 3D Data.................................................................................................................................. 11
    Optimize 3D Data.............................................................................................................................. 12
    Replace 3D Data................................................................................................................................ 12

Chapter 3: Converting 3D models ............................................................................................................. 13
  Overview ............................................................................................................................................... 13
    More Help topics .............................................................................................................................. 13
  Convert 3D files into PDFs .................................................................................................................... 13
    Related Sections.............................................................................................................................. 14
  Converting 3D files............................................................................................................................... 14
  Create a PDF template for 3D files ....................................................................................................... 14
  Convert a 3D file using PRC settings .................................................................................................... 15
    PRC B-rep (Solid).............................................................................................................................. 15
    PRC B-rep + Tessellation ................................................................................................................ 15
    PRC Tessellation (Faceted).............................................................................................................. 15
  Convert a 3D file using U3D settings .................................................................................................... 16
  About PRC and U3D conversion formats .............................................................................................. 16
    Benefits of PRC format..................................................................................................................... 16
    Benefits of U3D format...................................................................................................................... 16
Chapter 4: Tetra4D Converter Conversion Settings ................................................................. 17
Tetra4D Converter Conversion Presets ...................................................................................... 18
General Tab............................................................................................................................... 19
  Display ........................................................................................................................................ 19
  Default view ............................................................................................................................ 20
  Navigation ............................................................................................................................... 21
  Default Script ......................................................................................................................... 21
Document Tab............................................................................................................................ 21
More Help topics ....................................................................................................................... 22
Import Tab ................................................................................................................................... 22
  Format Specific Data to Import ............................................................................................. 23
Optimize Tab.............................................................................................................................. 25
  3D Format in PDF .................................................................................................................. 25
  Surface Triangulation ............................................................................................................ 25
  PRC ......................................................................................................................................... 26
  U3D ......................................................................................................................................... 26
  Customize a conversion preset for a 3D file type ............................................................... 27
    Convert large assemblies .................................................................................................... 28
  Format specific reading options ......................................................................................... 29
    STEP: Specific reading options ....................................................................................... 29
Chapter 5: Adding 3D models to PDFs .................................................................................... 32
Adding 3D Data ......................................................................................................................... 32
  Create new pages from 3D models ..................................................................................... 32
  Add a 3D model as a new page ........................................................................................... 32
Replacing 3D Data ..................................................................................................................... 32
  Replacing 3D in a PDF .......................................................................................................... 32
Managing 3D Data ..................................................................................................................... 33
  Move, delete, or resize the 3D canvas .................................................................................. 33
  3D properties ......................................................................................................................... 33
    Launch Settings Tab ......................................................................................................... 34
    3D Tab ............................................................................................................................... 34
    Resources Tab ..................................................................................................................... 36
3D Tool Options .................................................................................................................................................. 60
Auto Degrade Options ........................................................................................................................................ 61
Comment on 3D designs ................................................................................................................................. 61
  Add a 3D Comment to an object .................................................................................................................. 62
  Add comments from the Comment & Markup toolbar .................................................................................. 62
  Convert 3D measurements to comments .................................................................................................. 63
  Display comments for a 3D object ............................................................................................................. 63
Chapter 8: Exporting geometry from 3D models ................................................................................................. 64
  Export geometry ........................................................................................................................................ 64
  Format options for exporting geometry ..................................................................................................... 64
    IGES Settings ........................................................................................................................................ 64
    Parasolid Settings ............................................................................................................................... 65
    STEP Settings ...................................................................................................................................... 65
    VRML Settings ................................................................................................................................... 65
    STL Settings ......................................................................................................................................... 65
    U3D Settings ...................................................................................................................................... 66
    PRC Settings ...................................................................................................................................... 66
    X3D Settings .................................................................................................................................... 66
    3MF Settings .................................................................................................................................... 66
    JT Settings ......................................................................................................................................... 67
    ACIS Settings ................................................................................................................................... 67
Chapter 9: Adding functionality to 3D designs with JavaScript ........................................................................... 68
  3D JavaScript Overview ............................................................................................................................. 68
  Add a JavaScript to a PDF .......................................................................................................................... 68
Chapter 1: Getting started

Before you begin working with Tetra4D Converter™, please take a few moments to read an overview of the license activation process and the many resources available to you. You have access to instructional videos, plug-ins, templates, user communities, seminars, tutorials, RSS feeds, and much more.

Help

As part of your purchase, you are eligible for support of your installation of Tetra4D Converter via a maintenance contract. Your maintenance contract also gives you access to new versions of Tetra4D Converter as they are released. If you have questions about the status of your maintenance contract, give us a shout.

For help with this and any other general support need that you have, please submit a support request by going to http://www.tetra4d.com/support or by accessing your customer portal.

For support specific to Adobe Acrobat, please visit the Adobe Support website at: http://helpx.adobe.com/support.html.

To download samples and start experimenting with Tetra4D Converter right away, please visit: http://www.tetra4d.com/pdf-samples.

Also, please note that we have a YouTube channel. You can view various instructional videos on how to use Tetra4D Converter as well as some of our other products here: http://www.youtube.com/user/Tetra4D/videos.
Installation and activation

Installation of Acrobat XI Pro and Acrobat Pro DC

Tetra4D Converter has been developed as an Add-in for Adobe® Acrobat® Pro and supports versions XI and DC. As such, Acrobat XI Pro or Pro DC is required to be installed for Tetra4D Converter to function.

A free trial of Acrobat Pro DC can be downloaded at:

Please refer https://helpx.adobe.com/acrobat.html for detailed instructions and troubleshooting related to Acrobat Pro DC.

System Requirements

Please refer to the Tetra4D Converter installation guide by going to http://tetra4d.com/documentation or by accessing your customer portal.

Installation of Tetra4D Converter

Please refer to the Tetra4D Converter installation guide by going to http://tetra4d.com/documentation or by accessing your customer portal.
Running Tetra4D Converter

To run Tetra4D Converter, please go to your start menu and launch Acrobat Pro. When you first launch Acrobat Pro after installing Tetra4D Converter, you will see the following dialog box until your license has been activated.

Tetra4D Converter starts automatically in a trial mode, with a 28 days duration.

- Select the **Buy Now** button to go to the Tetra4D web store to purchase licenses of the Tetra4D Converter.
- Select the **Continue Trial** button to run in trial mode. The Tetra4D Converter will run in trial mode for 28 days after installation.
- You should receive a serial number in an email from tetra4d.com when you purchase the Tetra4D Converter. To activate your license, select the **I already have a serial number** button and enter your serial number in the activation window.

If you are unsure what your license status is or just need help in general, please submit a support request by going to [http://www.tetra4d.com/support](http://www.tetra4d.com/support) or by accessing your customer portal.

License activation

Please refer to the Tetra4D Converter installation guide by going to [http://tetra4d.com/documentation](http://tetra4d.com/documentation) or by accessing your customer portal.
Chapter 2: Tetra4D Converter Overview

Tetra4D Converter allows you to create rich PDFs from supported 3D and CAD file formats and from geospatially enabled PDFs. You can interact with 3D PDFs in several ways allowing you to rotate, move, and measure parts and distances.

Tetra4D Converter for Acrobat XI Pro
Tetra4D Converter Tools Menu

- Acrobat XI Pro

---

**Insert 3D**

This allows 3D CAD data to be converted and inserted into a PDF Document. When selected, you define the position and size of the 3D annotation frame, then select the 3D source file. The file is then imported and placed within your PDF document, after which you can manipulate the 3D image as you like.

For more information see “Chapter 3: Converting 3D Models”.

---

**Export 3D Data**

This allows you to export and save 3D Data from your PDF in another file format. Supported file formats for exporting include:

<table>
<thead>
<tr>
<th>File Format</th>
<th>File Extension</th>
<th>File Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACIS</td>
<td>.sat</td>
<td>.igs, .iges</td>
</tr>
<tr>
<td>IGES</td>
<td>.igs, .iges</td>
<td></td>
</tr>
<tr>
<td>JT</td>
<td>.jt</td>
<td></td>
</tr>
<tr>
<td>Parasolid</td>
<td>.x_t</td>
<td></td>
</tr>
<tr>
<td>PRC</td>
<td>.prc</td>
<td>.stp, .step</td>
</tr>
<tr>
<td>STEP</td>
<td>.step</td>
<td>.step</td>
</tr>
<tr>
<td>Stereo Lithography (STL)</td>
<td>.stl</td>
<td></td>
</tr>
<tr>
<td>U3D</td>
<td>.u3d</td>
<td></td>
</tr>
<tr>
<td>VRML</td>
<td>.vrml, .wrl</td>
<td></td>
</tr>
<tr>
<td>X3D</td>
<td>.x3d</td>
<td></td>
</tr>
<tr>
<td>3MF</td>
<td>.3mf</td>
<td></td>
</tr>
</tbody>
</table>
In addition, you have the opportunity to specify certain exported attributes. For example, for IGES, clicking on Settings in the Save File dialog box offers you the following choices:

![IGES Settings](image)

For more information about exporting, see “Chapter 8: Exporting Geometry from 3D models”. Please note that this functionality may change over time as file formats change and as Tetra4D Converter is enhanced to support additional formats. Please see “U3D and PRC Formats” for more information.

**Optimize 3D Data**

Allows the 3D Data to be further optimized for file size and performance.

For more information see “Optimizing 3D Data”. Please note that this functionality may not be available because of the format type. Please see “U3D and PRC Formats” for more information.

**Replace 3D Data**

Allows one 3D dataset to be easily replace with another.

For more information see “Replacing 3D Data”. Please note that this functionality may not be available because of the format type. Please see “U3D and PRC Formats” for more information.
Chapter 3: Converting 3D models

Overview
Adobe Acrobat Pro can consume and display data from a variety of different formats. When combined with Tetra4D Converter, you extend this functionality to support many types of 3D models. A list of all supported file formats appears in Acrobat’s Preferences dialog box (Select Edit -> Preferences -> Convert to PDF).

Adobe® Acrobat® Pro with Tetra4D Converter can use a variety of file formats, including many types of 3D models. A list of the supported file formats appears in the Preferences dialog box (select Convert To PDF under Categories). For more information about the specific file formats supported at this time, view our datasheet at http://www.tetra4d.com/tetra-4d-converter/.

You can import supported file formats directly into PDFs using the following methods:

- **Converting**: This option starts with existing 3D CAD files and creates PDFs from them. This action is accessible within Acrobat in a variety of ways.; using the File -> Create -> PDF From File, Right Click the CAD file-> Convert to 3D PDF, Select CAD file-> drag-and-drop into Acrobat.

- **Adding with the “Insert 3D” tool**: This option allows you to place a 3D model on an existing page in any PDF.

Either of these methods provides options for representing the 3D model and preserving the original structure of the model. For example, you can choose the level of detail, format, and compression.

If a 3D model is in a format that Acrobat doesn’t support, open the model in the application that it was created in and export it in a format supported by Tetra4D Converter.

More Help topics
See “Tetra4D Converter conversion settings” for more information

Convert 3D files into PDFs
You can convert 3D and CAD files in supported formats to PDFs that have one or more pages. The default preset works best for most types of conversion; however, you can change these settings or select a different preset before or during the conversion. To view and/or edit your default conversion settings before you convert a file, open the Acrobat Preferences dialog box. In Categories, select Convert To PDF, select a file format, and click Edit Settings. You can also change this right before your file converts in the Converter settings dialog box.

3D files are converted as either PRC or U3D data streams and then stored in the resulting PDF file. The file format of the 3D file determines which entities you can import to the PDF.

If your Windows computer uses an integrated video adapter, make sure that your video driver is relatively up to date to ensure that the 3D content renders correctly and as quickly as possible. You can usually obtain updated video driver software from the website of your video card or computer manufacturer.
Related Sections
“About PRC and U3D conversion formats”
“Customize a conversion preset for a 3D file type”

Converting 3D files

1. To create a simple PDF document based off of a single 3D file, within Acrobat choose File -> Create -> PDF From File... Select the 3D source file that you desire and click Open.

2. To create a PDF document based off of multiple 3D files, within Acrobat choose File -> Create -> Combine Files into a Single PDF. This will bring up a dialog box that allows you to either drag and drop your 3D files or add them using the Add Files dropdown menu. Each 3D file will be displayed on a separate page or a PDF Portfolio. Refer to Acrobat help for more information about PDF Portfolios.

3. In the Tetra4D Converter Conversion dialog box, select the preset or individual settings you want to use, and click OK.

   **Note**: From the desktop, you can also drag a 3D file into Acrobat XI Pro or Acrobat Pro DC (or onto the application icon) to create a single-page PDF file.

Create a PDF template for 3D files

To give 3D PDFs a consistent layout and structure, you can create a PDF template that contains a placeholder for a 3D model. Create the template in any application as long as it has the ability to be saved as a PDF file. After you create a template, select it in the Tetra4D Converter Conversion dialog whenever you convert a 3D file to PDF.

1. In an Office 2003 document, click the Save to PDF button on the PDF toolbar. In an Office 2007/2010 document or newer, click the Create PDF button on the Acrobat ribbon.

2. Open up the PDF in Acrobat XI Pro or Acrobat Pro DC.

3. In the Tetra4D Converter tool area, choose Add 3D.

4. Select any 3D CAD file. This step creates a placeholder for your 3D conversion.

To use this template when you convert a file, click the Document tab in the Tetra4D Converter Conversion dialog box. If the template name is not displayed in the Template PDF section, click Browse to find and select/open it.
Convert a 3D file using PRC settings

Use PRC settings to create a PDF that contains Product Manufacturing Information (PMI), polygon settings or tessellation, and geometry or b-rep (boundary representation). After you create the PDF, you can export geometry to standard file formats that most CAD, CAM, and CAE applications read.

Within Acrobat choose File -> Create -> PDF From File... Select the 3D CAD file, and click Open.

1. In the Tetra4D Converter Conversion dialog box, click the Import tab.
2. To import Product Manufacturing Information (PMI) with the 3D model, select 3D PMI & Views. You can import PMI from CATIA V5, I-DEAS, JT, NX (Unigraphics), Creo (Pro/ENGINEER), and SolidWorks files. This option is available only if the model contains PMI.
3. To replace the fonts used in PMI, click Fonts, select Always Substitute, specify the font, and click OK.
4. If you select Always Substitute, you remove any reference in the PDF to the font used for PMI. If you leave Always Substitute unselected, Acrobat substitutes any missing fonts. If the original fonts become available, they are used to display PMI.

PRC B-rep (Solid)
Retains only the geometry information of the 3D model. This option produces the smallest files, but polygons must be regenerated each time the file is opened.

See “Exporting geometry from 3D models” for more information

PRC B-rep + Tessellation
Retains the geometry of the 3D geometry and any saved polygon settings. If the 3D model doesn’t include polygon settings, they’re generated from the geometry during conversion.

PRC Tessellation (Faceted)
Retains the polygon settings of the 3D model or generates new polygons based on the geometry.

1. Select a level of detail. To set precise measurements, select either User Defined (for visualization) or Controlled Precision (for STL printing), and then click Advanced.
2. (Optional) To apply compression, select a PRC compression option. If you plan to export geometry, leave Compress B-rep to unselected, or set the value to 0.001 mm.

   **Note:** Compressed PDFs are smaller but take longer to open than uncompressed PDFs. To save time, compress only when you have to—after PDF conversion: Right-click the 3D model, and choose Optimize. This option is available only in PDFs that were converted using PRC settings.

When you secure a 3D PDF that contains geometry, avoid settings that restrict editing and printing the PDF. Otherwise, it disables the option to export geometry.
Convert a 3D file using U3D settings

1. Within Acrobat choose File -> Create -> PDF From File.... Select the 3D CAD file, and click Open.

2. In the Conversion dialog box, click the Optimize tab, and choose a U3D conversion setting from the 3D Format In PDF menu:

   **U3D ECMA 3**
   Ensures compatibility with Acrobat 8.1 and later and Adobe Reader® 8.1 and later.

   **U3D ECMA 1 (Reader 7.0 Compatible)**
   Ensures compatibility with Acrobat 7.0 and later and Reader 7.0 and later.

3. Select a level of detail. To set precise measurements, select either User Defined (for visualization) or Controlled Precision (for STL printing), and then click Advanced.

4. (Optional) For U3D ECMA 3 conversion, select Mesh Quality and specify a percentage.

5. Specify other options as needed and click OK.

About PRC and U3D conversion formats

When you create a PDF from a supported 3D file, the PDF stores 3D data as either PRC or U3D (Universal 3D) format, depending on the settings you choose. Whether PRC or U3D settings are available in the Tetra4D Converter Conversion dialog box depends on which 3D application created the file you’re converting.

PRC is a 3D format that lets you create different representations of a 3D model. For example, you can save only a visual representation that consists of polygons, or you can save the geometry that the model is based on. You can apply compression during conversion to decrease file size, or afterward in Acrobat Pro. By using PRC, you can create PDFs that are interoperable with Computer Aided Manufacturing (CAM) and Computer Aided Engineering (CAE) applications.

U3D is an open standard format adopted by ECMA International used primarily for visualization and publishing purposes. U3D settings are available for most CAD files created in digital content creation applications. These settings are also available for most CAD files created in mechanical engineering applications.

Benefits of PRC format

- Allows storage of large CAD files to PDFs that are a fraction of the original size.
- Supports post-conversion compression for faster loading.
- Can represent Product Manufacturing Information (PMI), also referred to as Geometric Dimensioning and Tolerancing (GD&T) or Functional Tolerancing and Annotation (FT&A).
- Can retain geometry for reuse in CAD, CAM, and CAE applications.

Benefits of U3D format

- Supports animations.
Chapter 4: Tetra4D Converter Conversion Settings

In the Conversion dialog box, you can specify settings for converting 3D models for PDFs on various tabs. Or, choose a preset from the menu.

**Note:** The Acrobat Conversion dialog box does not appear if the “Don’t display dialog during conversion” option at the bottom of this dialog box is selected.
Tetra4D Converter Conversion Presets

- **Default**: Provides optimum settings for the selected file format by balancing quality with PDF file size.
- **Custom**: Indicates that you’ve selected one or more individual settings. Click the plus sign (+) to save your selections at a custom preset.
- **Visualization/Small File**: Produces the smallest file size possible by applying compression, which may reduce image quality.
- **Visualization/High Quality**: Produces detailed, high-quality PDFs, but may increase file size.
- **Collaboration**: Produces high-quality, uncompressed PDFs.
- **Publishing**: Produces high-quality, compressed PDFs.
- **Data Exchange**: Preserves the exact geometry (or geometry compressed at 0.001 millimeter) for reuse with CAE and CAM applications.
- **U3D ECMA Standard Ed 1**: Specifies U3D 0.0 format and no compression.
- **Large File**: Specifies settings to use for converting large assemblies.
**General Tab**

These settings determine how the imported 3D model is presented in Acrobat Pro. Unlike the settings on the other tabs, General settings don’t affect the imported file itself.

![Tetra4D Converter Conversion Settings General Tab]

*Note: Some of these settings can be changed after you import a file by using the options on the 3D toolbar.*

**Display**

- **Default Background Color:** Identifies the color behind the 3D model. Click the color swatch to make changes.
- **Default Lighting:** Shows the lighting style to be used on the imported file.  
  *Note: For best performance when manipulating 3D models, select the Headlamp option.*
- **Default Rendering Style:** Shows the rendering style used for the imported model. Select a different style from the menu, if needed.
- **Default Animation Style:** For models created with animation, this setting determines how the animation runs in Acrobat.
Default view

- **Projection**: Defines the projection mode used in the default view of the PDF document.
  
  *Note: The default view is the one used to create the 3D annotation poster image.*
  
  The choices are:
  - Perspective,
  - Orthographic.

- **Orientation**: Defines the orientation used for the default view.
  
  *Note: The default view is the one used to create the 3D annotation poster image.*
  
  Several preset options are proposed:
  - Acrobat: This option is the default one. It corresponds to the acrobat orientation that has been used for the previous versions of Tetra4D Converter.
    - This preset orientation can’t be modified.
  - CAD software: These options define orientations that correspond to the default orientations of the CAD software.
    - These preset orientations can’t be modified.
  - Manage orientation: This option makes it possible to define other orientations and to save them.
    - When selecting “Manage orientation”, the following dialog is shown:

1. Define a new orientation name.
2. Select the vertical axis in the drop down list
   - The vertical axis is the axis from the CAD file that will be vertical in the PDF document
3. Define the Vertical Rotation value
   - The first rotation is done around the vertical axis of the 3D annotation
4. Define the Horizontal Rotation value
   - The second rotation is done around the horizontal axis of the 3D annotation
5. Click on the “+” icon to save the settings
Navigation

- **Add Default Views**: Select this setting to change the imported views. An orthographic projection (ortho) effectively removes a dimension, preserving the size ratio between objects but giving the 3D model a less realistic appearance. Orthographic projection is useful for viewing certain diagrams, such as 3D mathematical functions plotted on a graph. A perspective projection offers a more realistic scene in which objects in the distance appear smaller than objects of the same size in the foreground.

- **Show 3D Toolbar By Default**: Displays the 3D toolbar when the model is activated. When this option is not selected, you can right-click the 3D image to view the 3D toolbar.

- **Open Model Tree By Default**: Displays the Model Tree when the 3D PDF file is opened.

Default Script

Specifies the JavaScript file that runs if a 3D model is enabled. If the 3D model you’re importing doesn’t include embedded JavaScript, click Browse to specify the JavaScript file you want to run.

Document Tab

Use the Document settings to determine the layout of the page containing the 3D model, set up read/write permissions for the file, and encrypt the converted file.

- **Template PDF**: Specifies an existing PDF file in which to place the 3D model. Click Browse to select a PDF to use. Click clear to remove the template and set up the page using the Layout options.

- **Layout**: Select Page Setup to change the margins, page size, and page orientation (portrait or landscape) of the converted model.

- **Security**: Set an encryption level for the PDF, require a password to open it, and set editing and printing permissions.
More Help topics


Import Tab

These settings determine what entities and information from the file that is under process will be imported into the 3D PDF document.

![Tetra4D Converter Conversion Settings Import Tab](image)

*Note: In some cases, such as for 3DS file conversions, no import options are available.*
Format Specific Data to Import

Specify the types of information that you want to import into the 3D PDF document when reading the native 3D CAD model or standard 3D file. The available options reflect the file format of your 3D model.

Entities and information

- **Solids**: Specifies if solid objects are read.
- **Surfaces**: Specifies if surface objects are read.
- **Wireframe**: Specifies if wireframe entities are read.
- **3D PMI & Views**: Specifies if PMIs and views are read.
- **Attributes**: Specifies if meta-data linked to the objects (parts) are read.
- **Hidden objects**: Specifies if the hidden entities are read.
- **Construction & References**: Specifies if construction & reference entities like planes and axes are read.
- **Active filter**: Specifies what layers and filters are read.
- **3D/Drawing**: Specifies if read information are 3D or 2D.

Specifics...

Click Specific to have the access to some reading options or features that are available only with the file format currently under reading. The Specific option is proposed for the following CAD formats:

- Creo (Pro/ENGINEER),
- NX,
- STEP.

*Note: Refer to [STEP: Specific reading options](#) to have detailed explanations about STEP validation properties.*
Fonts...

Specifies how the PMIs are managed when the 3D PDF document is created:

- set up substitute fonts for the fonts in the original 3D file,
- Set up substitute color for the colors of the PMIs in the original 3D file,
- Set up a directory where to look for CAD proprietary fonts.

Assembly...

Click Assembly to define the directories to search parts that are not in the current folder. For large assemblies in which the master file refers to many parts and subassemblies, some parts can be in multiple directories.
Optimize Tab

Adjust the Optimize settings to select the file format to convert 3D data to and the corresponding compression.

![Tetra4D Converter Conversion Settings Optimize Tab](image)

3D Format in PDF

Choose between U3D and PRC conversion formats in the Format menu. The file format of your 3D model determines which settings are available.

Surface Triangulation

Level of Detail

Specify the level of detail used to display the 3D model. Higher settings produce more accurate results. Lower levels of detail are useful for quick visualization with reduced visual quality. Two additional settings allow you to set specific height and angle values:

- **User Defined**: Use to produce good quality model rendering for visualization and 3D printers
- **Controlled Precision**: Use to create more accurate meshes for export to 3D printers.

Level of detail can only be set when you import a model. If you import a model with User Defined tessellation, you must reimport the file to create the tessellation required for 3D printers.

When you select either User Defined or Controlled Precision, click Advanced to define the triangulation parameters.
Advanced

- **Chord Height Ratio**: Specifies the percentage of bounding box used to compute chord height. Set a value from 50 through 10,000.

- **Wireframe Chord Angle**: Specifies the maximum angle between two contiguous segments of wire edges for every face. The value must be from 10 through 40.

- **Maximum Chord Height**: Specifies the maximum distance, in millimeters, between surface and tessellation.

- **Minimal Triangle Angle**: Specifies the angle between two contiguous segments of wire edges for every face. The value must be between 10 and 30.

- **Binary File**: Creates a binary version of the STL output file, which is smaller than the standard ASCII STL file.

PRC

- **Compress B-rep To**: The amount (in millimeters) of lossy compression applied to geometry. For best results when exporting geometry, set the amount to 0.001 or leave this option unselected.

  *Note*: You can compress the geometry after you convert the 3D file to PDF by right-clicking the 3D model and choosing Optimize PDF.

- **Compress Tessellation**: Applies lossy compression to polygons.

U3D

- **Mesh Quality**: Controls the quality relative to the percentage of lossy compression applied to the image files. Higher percentages indicate less compression and better image quality. A setting of 100% applies no compression.

- **Geometry Center Model at Origin**: Translates the entire model so that the center of its bounding box is at the origin [0,0,0] of the XYZ coordinate system.
Customize a conversion preset for a 3D file type

You can create your own conversion presets for different types of 3D files, making it easy to reapply all the individual options you use most often for a specific type of 3D file.

Presets are tied to the 3D format. For example, if you create a preset for CATIA V5 files, that preset appears only when converting CATIA V5 files. You can create multiple presets for each 3D format. When you convert or capture a 3D file, the most recently used preset for that file type is selected.

1. Choose Edit > Preferences, and then choose “Convert to PDF” under Categories.
2. In the central panel of the Preferences, select the 3D file format to which the custom preset will apply, and then click Edit Settings.

*Note:* If you select a non-3D file type, the Edit Settings button may not be available or it may open a different dialog box.

3. Using the four tabs in the Conversion dialog box, specify the settings you want to include in the preset.
4. Above the tabs, in Description, type something that will help you to recognize the preset, such as its intended purpose or parameters.
5. Click the Add Preset icon.
6. Type a name for the preset, and click OK.
7. Click OK to close the Tetra4D Converter Conversion dialog box, and, if necessary, click OK to close the Preferences dialog box.

*Note:* You can delete a custom preset by reopening the Tetra4D Converter Conversion dialog box, selecting the preset from the menu, and then clicking the Minus Preset button.
Convert large assemblies

Converting large assemblies with numerous unique components to PDF can be both time-consuming and memory-intensive. For best results, create a tessellated representation of the assembly using PRC conversion settings. If the CAD file includes saved tessellation entities, Tetra4D Converter uses these entities instead of creating a new ones.

1. Choose File -> Create PDF -> From File -> Select the 3D file or part.
2. In the 3D PD Converter Conversion dialog box, click the Import tab.
3. Click Assembly to select the appropriate file path for part files, and click OK.
4. Click the Optimize tab and choose PRC Tessellation (Faceted) from the Format menu.
5. From the Level of Detail menu, select Medium. Select any other options, and then click OK.

**Note:** For you to complete this task, PRC settings must be available on the Optimize tab of the Tetra4D Converter Conversion dialog box.
Format specific reading options

STEP: Specific reading options

The STEP AP 242 standard supports “validation properties”. The “validation properties “ are additional meta-data added in the STEP file, meant to give the ability to validate a CAD data translation process (Conversion of CAD files from one CAD system into a different one, using STEP as intermediate format). The validation properties apply to parts and assemblies, geometry, PMIs and views.

This chapter describes how the validation properties already existing in a STEP file can be exploited during the conversion of this STEP file into a 3D PDF document.

1. Choose File -> Create PDF -> From File -> Select the STEP file.
2. In the 3D PD Converter Conversion dialog box, click the Import tab.
3. Click Specific to access the Validation properties related options.
4. Click Read Validation properties in order to read the validation properties that are present in the STEP file
   
   Note: The read validation properties can be accessed in the Log file.

5. Click Compute validation properties in order to compute the validation properties using the information from the 3D annotation
   
   Note: after the conversion of the STEP file into a 3D PDF document, validation properties will be calculated based on the 3D PDF information and then compared with the read validation properties. The validation properties are compared with the Geometry and PMI tolerances that are defined in this panel.

6. Use the Geometry and PMI sub-panel to define the tolerances that will be used when comparing the read validation properties and the computed one

7. Click (optional) Add Result To Name in order to add the results of the comparison to the names of the entities in the 3D annotation data tree

8. Click on OK to validate the options and continue the conversion process.
STEP Reader specific options (Validation properties feature)
Access to validation properties

The validation properties can be accessed after the conversion of the STEP file into a PDF document as follows:

1. In the Model Tree

   **Note:** If validation properties are only read (Compute validation properties not checked), the validation properties are presented in the Model Tree like other meta-data.

   or

2. Choose Tetra4D Converter (top menu) -> Last log file

   **Note:** If validation properties have been computed (Compute validation properties checked), the validation properties are presented in the Model Tree and also in the LOG file.
Chapter 5: Adding 3D models to PDFs

Adding 3D Data

Create new pages from 3D models

You can use 3D models in supported file formats as the basis of new PDFs, or you can bring them directly into existing PDFs. For many supported formats, you can do any of these in Acrobat Pro.

Add a 3D model as a new page

1. Open a PDF, and if Acrobat XI Pro, choose Tools > Pages > More Insert Options > Insert Blank Pages
   If Acrobat Pro DC, choose Tools > Organize Pages > Insert > Blank Page
2. Indicate where you want to place the inserted page in the document, and click OK.
3. Select Tools > Tetra4D Converter > Add 3D
4. Indicate where you want to place the 3D annotation by dragging to create a rectangle on the page.
5. In the Select File dialog box, choose the file type from the Files of Type menu. Select the supported 3D file you want to open, and then click Select.
6. In the Tetra4D Converter Conversion dialog box, select the preset or individual settings that you want to use, and then click OK.

Replacing 3D Data

Replacing 3D in a PDF

1. In the Select File dialog box, choose the file type from the Files of Type menu. Select the supported 3D file you want to open, and then click Open.
2. In the Tetra4D Converter Conversion dialog box, select the preset or individual settings that you want to use and then click OK. Replace 3D models to a PDF page.

You can use the 3D tool to place a 3D file on a page of a PDF. During this process, you can select how the model is displayed and the lighting, navigation, and display settings (like those found on the 3D toolbar), and change conversion settings.

After you place a 3D file, you can adjust the area or canvas in which the 3D model appears, edit the presentation properties for the 3D toolbar and content, and create additional views.
Managing 3D Data

Move, delete, or resize the 3D canvas

1. If Acrobat Pro XI, choose Tools -> Interactive Objects -> Select Object Tool.
   If Acrobat Pro DC, choose Tools -> Rich Media -> Select Object.

   **Note:** Be careful not to confuse the Select Object tool with the basic Select tool. Use the Select Object tool to adjust a 3D canvas.

2. Select the 3D canvas and change it as needed:
   - To move the canvas, drag it to a new location on the page.
   - To delete the canvas (and the 3D model), select it and press Delete.
   - To resize the canvas, drag the frame corners. The 3D content stays proportional within the adjusted frame.

3D properties

View 3D properties by right-clicking on the model and select Properties.
Launch Settings Tab

Activation Settings

- **Enable When**: Specifies when the 3D model is activated. When the 3D model is enabled, you can interact with it by using the 3D navigation tools, for example.

- **Disable When**: Determines how the 3D model can be deactivated. When a 3D model is disabled, the 2D preview image or poster appears in the canvas.

- **Playback Style**: Enables you to display the 3D model in a floating window outside the page. If you select Play Content in Floating Window, you can select the size of the window (in pixels) from the Height and Width menus.

Appearance

- **Border Width**: Select to create a border around the 3D object.

- **Transparent Background**: Removes any background color.

Poster Image

- **Poster Image**: To replace the default view of the 3D model when it isn’t activated, select a poster image option. Click Browse to find the image you want.

3D Tab

The options on the 3D tab determine how the 3D model is presented. Unlike the settings on the other tabs, 3D settings do not affect the imported file itself.
The options on the 3D tab are the same as the options on the 3D toolbar except for the following:

**Default Display Settings**

- **Animation Style:** For models created with animation, this setting determines how the animation runs in Acrobat.

**Navigation**

- **Add Default Views:** Allows you to use different model views. An orthographic projection (ortho) effectively removes a dimension, preserving the size ratio between objects but giving the 3D model a less realistic appearance. Orthographic projection is especially useful for viewing certain diagrams, such as 3D mathematical functions plotted on a graph. A perspective projection offers a more realistic scene in which objects in the distance appear smaller than objects of the same size in the foreground.

- **Retain Views, Comments and Scripts:** For models that have views, comments or scripts associated to them, it is possible to remove these default attributes during import.

- **Show Toolbar:** Displays the 3D toolbar along with the image. When this option is not selected, you can right-click the 3D image to view the 3D toolbar.

- **Open Model Tree:** Displays the model tree toolbar along with the image.

**Script**

Specifies the JavaScript file that runs if a 3D model is enabled. Click Browse to add a JavaScript file to the PDF.
Resources Tab

Use the Resources tab to add files developed in Flash® to a 3D model for animation, effects, and textures. To bind a Flash resource, select it from the list of resources, and then select a binding type (Foreground, Background, or Material). To bind a material, also enter the material name for the part or parts where you want to display the material.

Add

Use to add SWF files for animations and backgrounds for the 3D model.

Add Directory

Select to add a directory of resource files to the 3D object.

Remove

Select a file in the list, and then click Remove to delete it from the file.

Properties

- **Name**: Displays the name of the file that is selected from the list. You can also rename a resource, which is useful with scripting. For example, you can replace the name with the one used in a script.
**Binding**

When adding files that are developed in Flash as a resource for a 3D model, binding determines how those files interact. For example, you can identify a resource to run in the background and one to run in the foreground. After you add the files to the file list, select one, and in the Binding section, select either Background, Foreground, or Material.

- **Material**: 3D designers can use the Material field to define a material to use in a model. The material name can be associated with a resource by selecting Material in the Binding section.

- **FlashVars**: Flash developers can use the FlashVars field to add ActionScript variables for the selected file.
Chapter 6

Optimizing 3D Data

1. Open a PDF, and choose Tools > Tetra4D Converter > Optimize 3D Data.

Optimize

- **Compress B-rep To**: The amount (in millimeters) of lossy compression applied to geometry. For best results when exporting geometry, set the amount to 0.001 or leave this option unselected.
- **Compress Tessellation**: Applies lossy compression to polygons.
- **Remove B-Rep**: Remove geometry information of the 3D model from the PDF.
- **Remove Attribute**: Remove attributes of the model from the PDF.
Chapter 7: Interacting with 3D models

Displaying 3D models

In Tetra4D Converter, you can view and interact with high-quality 3D content created in professional 3D CAD or 3D modeling programs and embedded in PDFs. For example, you can hide and show parts of a 3D model, remove a cover to look inside, and turn parts around as if holding them in your hands.

A 3D model initially appears as a two-dimensional preview image. Clicking the 3D model with the Hand or Select tool enables (or activates) the model, opens the 3D toolbar, and plays any animation.

3D Toolbar Overview

The 3D toolbar appears after you click the 3D model with the Hand tool. This action activates the 3D model and plays animations that are set to play when the file is enabled. The 3D toolbar always appears in the area above the upper-left corner of the 3D model and cannot be moved. A small arrow appears to the right of the Rotate tool, which you can click to either hide or expand the toolbar.

You can use the 3D toolbar to zoom in and out, rotate, and pan across the object. Use the Model Tree to hide/isolate parts, or make parts transparent.
You manipulate a 3D model by selecting and dragging various 3D navigation tools. When you navigate in 3D, it helps to think of it as viewing the stationary 3D model from a camera’s perspective. You can rotate, pan (move up, down, or side-to-side), and zoom in or out.

**Note:** You can hide the toolbar by right-clicking the 3D model and choosing Tools > Hide Toolbar. To show the toolbar, choose Show Toolbar from the same context menu.

### 3D navigation tools

- **Rotate:** Turns 3D objects around relative to the screen. How the objects move depends on the starting view, where you start dragging, and the direction in which you drag.

  **Note:** You can also use the Hand tool to rotate an object. [Ensure that Enable Selection for the Hand Tool] is selected in the 3D & Multimedia panel of the Preferences dialog box.

- **Spin:** Turns a 3D model in parallel to two fixed axes in the 3D model, the x axis and the z axis.

- **Pan:** Moves the model vertically and horizontally only. You can also pan with the Hand tool: Ctrl: drag.

- **Zoom:** Moves you toward, or away from, objects in the scene when you drag vertically. You can also zoom with the Hand tool by holding down Shift as you drag.

- **Walk:** Pivots horizontally around the scene when you drag horizontally. Moves forward or backward in the scene when you drag vertically; maintains a constant elevation level, regardless of how you drag. The Walk tool is especially useful for architectural 3D models. To change the walking speed, change the default display units in the Preferences (3D). **Note:** The Walk tool is available when you select the Preferences setting that consolidates tools or when you right-click the 3D model and choose Tools > Walk.

- **Fly:** Navigates through a model while maintaining the surface orientation. Right-click and drag inside the 3D window. The Fly tool moves more slowly the closer you move toward an object. Drag the mouse pointer right or left to turn.

To rotate the camera view, click the left mouse button inside the 3D window and drag to turn the camera view. To return to the starting camera direction, move the mouse back to the initial click point.

Use the mouse scroll wheel to move rapidly backward and forward along the camera view direction. This is useful if you get lost within a model or fly into the surface.

- **Camera properties:** Defines the camera angle, alignment, and other properties that define the lens through which a 3D model is viewed. Camera properties are components of views but are set independently.

- **3D Measurement Tool:** Measures part sizes and distances in the 3D model.
3D toolbar view controls

- **Default View:** Returns to a preset zoom, pan, rotation, and projection mode of the 3D model. Use the Options menu in the View pane of the Model Tree to set a different view as the default. Or use the Manage Views command on the 3D toolbar Views menu to set a different view as the default.

  *Note: If an object ever moves out of your view, you have, in essence, turned your camera away from the object. Click the Default View icon on the 3D toolbar to move the object back into view. You can also right click in the 3D scene and select Part Options > Fit Visible to bring the model to view and reset the center rotation point."

- **Views menu:** Lists any views defined for the current 3D model.

- **Toggle Model Tree:** Opens and hides the Model Tree.

- **Play/Pause Animation:** Plays or pauses any JavaScript-enabled animation. The Play/Pause Animation pop-up menu opens a slider that you can drag back and forth to move to different times in the animation sequence.

- **Use Orthographic/Perspective Projection:** Toggles between displaying perspective and orthographic projection of the 3D object.

- **Model Render Mode menu:** Determines how the 3D shape appears.

- **Enable Extra Lighting menu:** Lists the different lighting effects that are available to enhance the illumination of the 3D object. Experiment to get the visual effects you want.

- **Background Color:** Opens the color picker, which you can use to select a different color for the space surrounding the 3D object.

- **Toggle Cross Section:** Shows and hides cross sections of the object. Click the pop-up menu to open the Cross Section Properties dialog box.

- **Add 3D Comment:** Enables you to add a sticky note to any part of the 3D model. The note stays with the view.
Examples of model rendering modes

The model rendering modes include combinations of factors that affect the appearance of the 3D object. The illustration below shows a simple object rendered in each of the available modes.

Model rendering modes
A. Solid B. Transparent Bounding Box C. Transparent D. Solid Wireframe E. Illustration F. Solid Outline G. Shaded Illustration H. Bounding Box I. Transparent Bounding Box Outline J. Wireframe K. Shaded Wireframe L. Transparent Wireframe M. Hidden Wireframe N. Vertices O. Shaded Vertices
Change rendering mode, lighting, projection, and background

The model rendering mode determines the surface appearance of the 3D model. The default rendering mode is usually solid, but you can also choose another rendering mode. You can also change the lighting of the 3D model as well as the background.

A. Default appearance
B. Wireframe rendering mode
C. Colored lighting
D. Different background color

Changing the appearance of the 3D model

Use items on the 3D toolbar to make any of these changes:

- To change the rendering mode, choose an option from the Model Render Mode pop-up menu.
- To view an orthographic projection, click the Use Orthographic Projection button. An orthographic projection effectively removes a dimension, preserving the size ratio between objects but giving the 3D model a less realistic appearance. Click the button again to use perspective projection.
- To turn lighting on or off, or to change lighting, choose an option from the Enable Extra Lighting pop-up menu.
- To change the background color, click the arrow next to the Background Color swatch and choose a color.

Note: Model rendering modes, lighting schemes, and background color options are also available by right-clicking the 3D model, and then clicking Viewing Options. Model rendering modes also appear under the Options menu on the Model Tree.
Model Tree Overview

The Model Tree appears in the navigation pane on the left side of the work area. You can also open the Model Tree by clicking the Toggle Model Tree button on the 3D toolbar. Or, right-click the 3D model and choose Show Model Tree.

The Model Tree has three panes, each of which displays a specific type of information or controls.

- **Structure pane**: The topmost pane shows the tree structure of the 3D object. For example, a 3D object depicting a car has separate groups of objects (called nodes) for the chassis, engine, and wheels. In this pane, you can move through the hierarchy and select, isolate, or hide various parts.

  Product Manufacturing Information (PMI) appears as a group of items on the same hierarchical level as its related object or assembly.

- **View pane**: The middle pane lists the views that have been defined for the 3D object. When you change a view, click one of the listed views to return the 3D model to a saved state.

  You can also add to and edit views in the View pane. For example, after you isolate and rotate a part, you can save that particular view, including the camera angle, background, lighting, and other attributes. This feature is not available for Acrobat Reader.

- **Object Data pane**: The lower pane displays other information, including properties and metadata, if any, about the object or part. You cannot edit this information for 3D objects in Acrobat.
**Note:** To change the default behavior for the Model Tree, open the Preferences dialog box and under Categories, select 3D and Multimedia. Then choose an option from the Open Model Tree On 3D Activation menu.

The author of the PDF can set up a 3D model in the conversion settings so that clicking it automatically displays the Model Tree.

### Hide, isolate, and change the appearance of parts

Some 3D models are composed of individual parts. You can use the Model Tree to hide or isolate parts, zoom into parts, or make parts transparent. Parts that show in the 3D model appear in the tree with a check mark next to them.

![Manipulating parts](image)

A. Selected part  
B. Hidden part  
C. Isolated part  
D. Transparent part

In the 3D model, use the Hand tool to click the part you want to manipulate. If a preference setting prevents you from using the Hand tool, select the part in the Model Tree list.

**Note:** The items that appear on the Options menu depend on whether the 3D model is composed of just one part or multiple parts. Many of these options are also available by right-clicking a part in the 3D model.

From the Options menu in the top pane of the Model Tree, choose any of the following:

- **Model Render Mode:** Changes the surface appearance of the entire 3D model according to the item you choose from the submenu: Transparent Bounding Box, Solid, Transparent, Solid Wireframe, and so on.
- **Show All Parts:** Displays the entire 3D model.
- **Fit Visible:** Displays all visible parts and centers them in the view.
- **Show Physical Properties:** Displays the surface area and volume (if available) in the Object Data pane of the Model Tree.
- **Display Bounding Box:** Displays the box that encloses the 3D object or selected parts of the model.
- **Set Bounding Box Color:** Changes the color of the bounding box. Choose this option, select a color, and then click OK.
- **Hide:** Displays the model without showing the selected parts. You can also select and deselect check boxes in the top pane of the Model Tree to hide and show different parts.
• **Isolate**: Displays only the selected part, hiding all others.

• **Isolate Part**: Displays the geometry, the Product Manufacturing Information (PMI), and all views (including PMI views) for the isolated part only. Views and information for all other parts are hidden or deselected. Changes occur in the Model Tree as well. In the Structure pane (top), only the isolated part is selected. The structure of the other parts is available but deselected. The View pane (middle) lists only the views that have been defined for the isolated part, including PMI views. If you click a view, you see only the PMI for that view in the document pane. (To view the PMI for the isolated part, make sure 3D PMI is selected in the Structure pane.) The View pane hides views related to the assembly or other parts, including custom views created in Acrobat. You can add parts to the view by selecting them in the Model Tree. You can also use the Hide/Show commands in the options menu of the Model Tree. To cancel the isolated part, do any of the following:

• **Zoom to Part**: Changes the center focus from the entire 3D model to the selected parts. This setting is especially useful for rotating a part, allowing the rotation to occur around the center focus of the part rather than around the entire model.

• **Part Render Mode**: Displays all of the rendering modes that are available for the part. The rendering mode changes the appearance of the 3D model according to the rendering mode you choose.

• **Transparent**: Displays a see-through version of the selected part.

• **Export as XML**: Creates a separate XML file of either Whole Tree or Current Node of the 3D model.

• **Export as CSV**: Creates a separate file in CSV format that contains all of the model data. You can export the data from the whole Model Tree or a selected node. The file can be opened in any program that supports CSV formatting, such as Microsoft Excel.

*Note: If the 3D model includes Product Manufacturing Information (PMI), options for showing and hiding the PMI are available on this menu.*

### View Product Manufacturing Information (PMI)

If **Product Manufacturing Information (PMI)** from the original CAD file was imported during PDF conversion, you can view this information in the 3D model. PMI is added to a CAD drawing to communicate manufacturing or inspection requirements and other data for a part or feature. CAD applications also call this **information Geometric Dimensioning and Tolerancing (GD&T) or Functional Tolerancing and Annotation (FT&A).**

Designers typically add PMI to one of the six standard views (top, bottom, right, left, back, or front) in the CAD application. Or they create unique views for this information. You can view PMI in the 3D model by selecting these views.
Import Product Manufacturing Information (PMI).

1. Click the 3D model to activate it, and then click the Model Tree icon in the 3D toolbar.
2. In the Structure panel (top) of the Model Tree, click 3D PMI to view the names of each notation.
3. To view PMI in the 3D object, do one of the following:
   - Select a view associated with PMI (if one is available) in the View panel (middle) of the Model Tree. Only the PMI in the selected view is visible in the 3D model.
   - Right-click a part and choose Part Options > Isolate to see the PMI for the selected part.
   - Select an individual notation in the Model Tree to highlight it in the current view.

*Note: The font used for PMI text must be installed on your computer for the text to display correctly.*
Create Cross Sections

Displaying a cross section of a 3D model is like cutting it in half and looking inside. Use the Cross Section Controls dialog box to adjust the alignment, offset, and tilt of the cutting plane.

Before and after cross section

1. Click the Toggle Cross Section icon on the 3D toolbar to turn on or off the cross section.
2. (Optional) Click the arrow next to the Toggle Cross Section icon, and choose Cross Section Properties, which opens the Cross Section Properties dialog box. Then do any of the following:
   - Change settings under Alignment, Display Settings, and Position and Orientation.
   - Click the Save Section View button to save the current cross-sectional view. (The saved view will appear on the Views menu in the 3D toolbar and in the View pane of the Model Tree with a default name, SectionView[n].)
Cross-Section Properties

Changes you make here are applied immediately. To see these changes, make sure that the Cross Section Properties dialog box does not block your view of the active 3D model. The Cross Section Properties dialog box remains on top if you focus or interact with the underlying PDF. To close it, click the Close button in the upper-right corner.

- **Enable Cross Section**: When selected, makes the other options available.
- **Alignment**: Determines the axis (x, y, or z) to which the cross-section aligns.
- **Align to Face**: Cuts the cross-section on a plane defined by the surface of any face that you then click in the 3D model. (The dialog box is dimmed until you click the face of a model part.)
- **Align to 3 Points**: Cuts the cross-section on a plane defined by any three points that you click the 3D model. (The dialog box is dimmed until you click three points of a model.)
- **Show Intersections**: Indicates where the cutting plane slices the 3D model by adding a colored outline. Click the color swatch if you want to select a different color.
- **Show Cutting Plane**: Displays the two-dimensional field that cuts the 3D model. Click the color swatch to select a different color, and enter a different percentage to change the opacity of the plane.
- **Ignore Selected Parts**: Removes the selected parts from the cross-section view.
- **Show Transparent**: Displays parts that are not part of the cross-section.
- **Cutting Plane Opacity**: Defines the transparency level of the cutting plane.
- **Align Camera with Cutting Plane**: Rotates the 3D model so that it is level with the cutting plane.
- **Offset**: Determines how much of the 3D model is sliced. Drag the slider left or right, or change the percentage.

**Note**: To understand how each axis divides the 3D model, select an axis and then drag the Offset slider back and forth. Observe the changes in the embedded 3D model.

- **Flip**: Reverses the cross-section. For example, if the top half of the model is cut off, click Flip to display the top half and cut off the bottom half.
- **Tilt sliders**: Determine the angles between the cutting plane and the axes. Drag the sliders left or right, or change the percentages.
- **Save Section View**: Opens the View Properties dialog box in which you can select the display properties to save with the view. After you select the properties to save, the cross-sectional view is added to the list of views in the 3D toolbar and the Model Tree. The saved view is given a default name, SectionView[n].

Display properties that you choose not to save revert to the setting of the previous view. For example, if you do not save the background color, the cross-section view retains the background color of the previously displayed view.
Measure 3D objects

Use the 3D Measurement Tool to measure 3D models. You can create measurements between combinations of points or edges of the 3D model. As you move the pointer over the 3D model, specific points and edges are highlighted. The 3D Measurement Tool supports four types of measurements: perpendicular distance between two straight edges, linear distance between two points, the radius of circular edges, and the angle between two edges (or three points).

You can associate 3D measurements with specific views. If the default view is active when a measurement is added, a new measurement view is created. This view is added to the view hierarchy in the Model Tree. The measurement is associated with that view only. The measurement shows up as a child of the view.

You can also display comments while taking measurements. These comments (also called measurement markups) are preserved after the document is closed.
1. Click a 3D model in a PDF to enable it.

2. Click the 3D Measurement Tool icon on the 3D toolbar. (If the 3D toolbar view is set for consolidated tools, select the 3D Measurement tool from the pop-up menu next to the Navigation tool.)

3. Select the options you want in the Snap Enables and Measurement Types areas of the 3D Measurement Tool palette.

4. Right-click the model background, and change the options as needed. Leave the 3D Measurement Tool palette open.

5. Measure the 3D model:
   - To measure the distance between two positions on the 3D model, click to set a start point. Then move the pointer to another location or an edge.
   - To measure the circumference of a round shape, move the pointer to the edge of the shape so that a circle appears, and click once.
   - To create and set an annotation on the measurement, right-click the object background and select Change Markup Label. Type a markup label. Measure the 3D model as described previously. Click to set the end point for the measurement, and then click a third time to set the location of the measurement and label.
   - To save a measurement as a comment, select the Hand tool, right-click the measurement, and click Convert to Comment.
   - To discontinue a measurement, right-click and choose Cancel Measurement.
   - To delete a measurement markup, click it with the 3D Measurement Tool and press Delete.

   Note: To learn how to rotate, pan, zoom, and snap while you measure, right-click the model and choose 3D Measurement Navigation Tips.

### Snap Enables options in the 3D Measurement Tool palette

<table>
<thead>
<tr>
<th>Snap Enable</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>3D Snap to Edge Endpoints</td>
<td><img src="image" alt="Icon" /></td>
<td>Snaps to the entire edge.</td>
</tr>
<tr>
<td>3D Snap to Linear Edges</td>
<td><img src="image" alt="Icon" /></td>
<td>Snaps to a straight-line segment of an edge.</td>
</tr>
<tr>
<td>3D Snap to Radial Edges</td>
<td><img src="image" alt="Icon" /></td>
<td>Snaps to a circumference.</td>
</tr>
<tr>
<td>3D Snap to Silhouettes</td>
<td><img src="image" alt="Icon" /></td>
<td>Snaps to the apparent edge of a part, such as the side of a cylinder.</td>
</tr>
<tr>
<td>3D Snap to Planar Faces</td>
<td><img src="image" alt="Icon" /></td>
<td>Snaps to the geometric plane making up a face of the part.</td>
</tr>
</tbody>
</table>
Measurement Types options in the 3D Measurement Tool palette

<table>
<thead>
<tr>
<th>Snap Enable</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>3D Point To Point Measurement</td>
<td>![Icon]</td>
<td>Measures the distance between two positions on the 3D model. Click to set a start point, and then click another location to set an end point or edge.</td>
</tr>
<tr>
<td>3D Perpendicular Dimension</td>
<td>![Icon]</td>
<td>Measures the distance between two edges taken at a right angle to the starting edge.</td>
</tr>
<tr>
<td>3D Radial Dimension</td>
<td>![Icon]</td>
<td>Measures the radius at the location clicked.</td>
</tr>
<tr>
<td>3D Angle Measurement</td>
<td>![Icon]</td>
<td>Measures the angle between two edges.</td>
</tr>
</tbody>
</table>

Units and markup options

To use the Units and Markup measurement tools, select the 3D Measurement Tool, and then right-click inside the model.

- **Define Model Units**: Select to change the measurement units.
- **Enable Coordinate Display**: Displays or hides the coordinates of the mouse pointer location in the Measurement Info Window.
- **Change Markup Label**: Type the text that you want to appear with the measurement, both in the 3D model area and in the Comments panel. (Not available if Measurement Markup is not selected.)
- **Disable Measurement Markup**: Select when you want to take measurements in a model, but not add them to the document. The measurements are only visible while the current measurement is active. If you start another measurement or change tools, the markup disappears.
- **Don’t Snap To 3D Content**: Disables the ability to snap the insertion point to a likely target. Select this option to improve performance when you are working with a large model. Return to Snap To 3D Content to ensure precise measurement in 3D objects.
- **3D Measurement Navigation Tips**: Opens a dialog box that lists the keyboard shortcuts for several navigation shorts. You can use these shortcuts while you are measuring.
- **Preferences**: Opens the Measuring (3D) Preferences dialog box.
- **Hide/Show Measurement Info Window**: The Measurement Info Window displays the Units and Markup settings for the model. Select to remove the window from the model window.
- **Hide/Show Measurement Toolbar**: Removes/displays the 3D Measurement Tool palette.
Measuring preferences

Change the 3D Measuring preferences to determine how 3D data is measured. These options appear in the Measuring (3D) panel of the Preferences dialog box.

*Note:* In Adobe Reader, these preferences apply to PDFs that have commenting enabled (Reader Enabled).
3D Measuring

- **Use Scales and Units from Model (When Present):** Displays measurements based on the model units, if present, generated from the original 3D model. Deselect this option to specify the units of measurements manually. This setting can be changed in the 3D Measurement Tool palette.

- **Use Default Display Unit:** Uses units of measurement that you specify here rather than the measurement units in the 3D model.

- **Significant Digits to Display:** Specifies the maximum number of digits in the measurement number.

- **3D Measuring Line Color:** Specifies the color of the line that appears when you click or drag to measure an object.

- **Measure Feedback Size:** Sets the text size for the measurement display.

- **Angular Measurements Shown In:** Specifies units as either degrees or radians.

- **Circular Measurements Shown As:** Designates whether the diameter or radius is measured for circular parts.

- **Show Circle For Radial Measurements:** Displays the circumference associated with the radial measurement.

3D Snap Settings

- **Turns on snap and specifies whether points, arcs, edges, silhouette edges, or faces are snapped to. Sensitivity indicates how close the pointer must be to the item being snapped to.**

- **Snap Hint Color:** Specify the color of the snap line that appears when you hold the pointer over the 3D object.
Change camera properties

Camera properties define the precise angle and positioning for a view of an object. Camera properties make up a camera view, which can be used both between views and between files.

1. On the 3D toolbar, click the Camera Properties icon. If you don’t see the icon, click the arrow next to the navigation tool on the left side of the 3D toolbar.

2. In the Camera Properties dialog box, click Save As to name a new camera view, or select an existing view from the menu.

3. Move the Camera Properties dialog box so that you can see the 3D model. Select a camera alignment:
   - Select Target to align the camera properties only to the target position.
   - Select Camera and Target to align the camera properties to both the camera direction and the target position.
4. Select the type of alignment:

- **Select Model:** After you select this option, click a 3D model in the document. The Camera Properties dialog box shows the current camera position.
  
  - If Target is selected, the new position of the camera target is the center of the selected model.
  
  - If Camera and Target is selected, the position of the camera target is the center of the selected model. The camera is aligned to the selected model.

- **Select Face:** After you select this option, click a face of the 3D model in the document. The Camera Properties dialog box shows the current camera position.
  
  - If Target is selected, the new position of the camera target is the center of the selected face.
  
  - If Camera and Target is selected, the position of the camera target is the center of the selected face. The camera is aligned to this face.

- **Select 3 Points:** After you select this option, select three points on the same or different models in the document. The Camera Properties dialog box shows the current camera position.
  
  - If Target is selected, the new position of the camera target is the center of the three selected points.
  
  - If Camera and Target is selected, the camera target is the center of the three selected points. The camera position is aligned to the plan composed by the three selected points.

5. In the Position section, select Angle Units to change the X, Y, and Z values to Azimuth, Altitude, and Distance. These values enable you to manipulate the camera by azimuth (distance) and altitude (X axis), and to zoom using the distance value.

6. Move the sliders in the Camera and Target positions to the desired location.

7. To change the focal angle of the camera, drag the Field Of View slider to the desired degree.

8. To change the roll angle of the camera, drag the Roll slider to the desired degree.

9. Click Save Camera View to save the settings and add the view to the Model Tree.

The view is added to the Model Tree with the default name of CameraView[n], with [n] being an incremental number. You can rename the camera view in the Views list.
Set 3D views

The default view of a 3D model lets you quickly revert to a starting point at any time as you interact with the model. A default view is different from a preview, which determines what the 3D model looks like when it’s not activated. The list of all available views for the 3D model appears in the Views menu on the 3D toolbar and in the View pane of the Model Tree.

You can also create additional views of the 3D model in Acrobat that let you quickly navigate the 3D content as you want (such as top, bottom, left, right, inside, outside, exploded, or assembled). A view can include lighting, camera position, rendering mode, the Model Tree state, and transparency and cross-section settings. Custom views can include precise camera properties.

You can link views to bookmarks in the Bookmarks panel, or you can use the Go To 3D View action to link views to buttons and links that you create on the page.

Create a custom view

1. With the Hand tool, click the 3D model to enable it.
2. Use the Rotate, Pan, and Zoom tools in the 3D toolbar to change the view.
3. In the Model Tree, hide or show parts, and then click the Create View icon.
4. In the View Properties dialog box, select the display settings to include in the view.

**Note:** Properties that are not selected use the settings that were last displayed. For example, if Background Color is not selected, the background color of the view remains the same as the background that was previously displayed.

**Note:** The view is listed as NewView in the View pane of the Model Tree. Select it to rename it.
Display a view

Use these methods to change the view, as appropriate:

1. From the 3D toolbar, select the view from the Views pop-up menu.
2. In the Model Tree, click the view name.
3. Click the Default View icon.

Change the default view

In the View pane of the Model Tree, do one of the following:

1. Select a view, and then choose Set as Default View from the Options menu.
2. Right-click a view, and then choose Set as Default View.

Add a 3D view to a bookmark or link

This process requires a 3D model with one or more defined views, which you can create. You can associate the view with an existing bookmark or link, or you can create a new one for this purpose.

1. Do one of the following:
   - To create a new bookmark, click the New Bookmark button at the top of the Bookmarks panel, and type a new name for the bookmark. Then, right-click it and choose Properties.
   - To create a new link, if Acrobat XI Pro, choose Tools > Content Editing > Add or Edit Link if Acrobat Pro DC, choose Tools > Edit PDF > Link > Add/Edit Web or Document Link tool, and drag to create a link rectangle anywhere on the page. Then, under Link Action, in the Create Link dialog box, select Custom Link, and click next.
   - To link a view to an existing bookmark or link, right-click the bookmark or link, and choose Properties.
2. In the Properties dialog box, click the Actions tab.
3. From the Select Action menu, choose Go to A 3D/Multimedia View, and then click Add.
4. In the Select A 3D View dialog box, select the 3D annotation for the 3D model from the list on the left, and then select a view option on the right:
   - Current View: Matches the 3D rotation, pan, and zoom characteristics that are active in your document at the time you create the link or bookmark, whether or not this view is listed on the Model Tree as a defined view.
   - First View: Changes to the view that appears at the top of the list in the Model Tree.
   - Last View: Changes to the view definition that appears at the bottom of the list in the Model Tree.
   - Previous View: Moves up the Model Tree list of defined views, one view at a time.
   - Next View: Moves down the Model Tree list of defined views, one view at a time.
   - Named View: Changes to the defined view that you select from the list appearing below this option.
5. (Optional) To make a bookmark or link also jump to a specific page and page view, choose Go to a Page View on the Selection Action menu, and click Add. Then use the scroll bars and zoom tools to adjust the page view before you click the Set Link button. When finished, click Close in the Properties dialog box.

Delete a 3D view

Do one of the following:

- On the 3D toolbar, open the Views pop-up menu and choose Manage Views. Select the views you want to remove, and click Delete View.
- In the View pane of the Model Tree panel, select the views you want to remove. From within the View pane, either click the Delete button or click the Options button and choose Delete View.

3D Preferences

In the 3D & Multimedia panel of the Preferences dialog box, you can determine whether the 3D toolbar and Model Tree are displayed by default. You can also specify a default renderer and determine whether animations are allowed.
Renderer Options

- **Preferred Renderer**: Specifies the rendering engine used to affect both performance and quality, so it’s important to select the appropriate renderer. Depending on your system, you can change your render engine. If you select a DirectX® or OpenGL option, all rendering takes place using the graphics chip on the video adapter. If Software is selected, rendering takes more time, but the performance is often more consistent with the model rendering of the originating application.

- **Enable Hardware Rendering For Legacy Video Cards**: Forces the use of a hardware accelerator for even video adapters that do not support a pixel shader.

- **Enable Double-Sided Rendering**: Some model parts have two sides. To save time and space, you can deselect this option to render only the side facing the user. If the user looks inside a part rendered with only one side, the back side would be invisible.

- **Preferred 3D PMI Rendering Mode**: Specifies the PMI mode to use for rendering. You can select one of the following options:
  - **Use Content Setting**: The rendering of the PMI uses the setting of each PMI to decide whether it uses the Z-buffer.
  - **Always Render 3D PMI In Front Of Model**: The rendering of the PMI ignores the Z-buffer regardless of the setting in the file.
  - **Always Render 3D PMI Using Z-buffer**: The rendering of the PMI always turns on Z-buffer regardless of the setting in the file.

3D Tool Options

- **Open Model Tree On 3D Activation**: Determines whether the Model Tree is displayed when the 3D model is activated. Choose Use Annotation’s Setting to use whichever setting the author used when adding the 3D model to the PDF.

- **Default Toolbar State**: Determines whether the 3D toolbar is shown or hidden when a 3D model is activated. Choose Use Annotation’s Setting to use whichever setting the author used when adding the 3D model to the PDF.

- **Enable Selection for the Hand Tool**: This allows the user select and highlight parts of the 3D model using the Hand tool. If this option is not selected, use the Object Data tool (If Acrobat XI Pro, Tools > Analysis > Object Data Tool. If Acrobat Pro DC, Tools > Measure > Object Data Tool.) to select the object.

- **Consolidate Tools On The 3D Toolbar**: Selecting this option places the manipulation and navigation tools under the Rotate tool, thereby shortening the 3D toolbar.

- **Enable View Transitions**: Some 3D models include animated transitions between views. Deselect this option if you want to prevent this 3D animation.

- **Show 3D Orientation Axis**: Turns on or off an in-scene display of an axis that indicates the current orientation of the 3D scene.
Auto Degrade Options

- **Optimization Scheme for Low Framerate**: Specifies what happens to animations of complex models when the framerate becomes low. None does not compromise the visuals and leaves the framerate low. Bounding Box shows the three-dimensional planes enclosing the parts instead of the parts themselves, which keeps the framerate high. Drop Objects does not show some parts of the model, which keeps the framerate high.

- **Framerate Threshold**: Sets the minimum framerate, either by dragging the slider or entering a number in the value box. If the framerate drops below that number of frames per second, the Optimization Scheme for Low Framerate option goes into effect.

Comment on 3D designs

Comments added to a 3D object are associated with specific views that are defined when the comments are added. If the view is changed—for example, if the 3D object is rotated or moved—the comments are no longer visible.

You have three ways to add comments to a 3D object:

1. Using the 3D Comment Tool on the 3D toolbar to add comments to specific parts of a 3D model.
2. Using the Comments Tool, Annotations and Drawings to add a variety of comment types to a 3D view.
3. Converting a 3D measurement into a comment.

**Note**: When the view of a 3D object is changed, any comment associated with that object disappears (right). If you don’t want a comment to be associated with a 3D view, add the comment outside the 3D object area.
Add a 3D Comment to an object

Comments created by using the 3D Comment Tool are like measurements in that they are associated with a specific part of the 3D geometry. When you add 3D comments to the default view of a model, a new view, called 3DCommentView is created. 3D comments added to other views are listed as components of that view in the Model Tree. You can edit and remove 3D comments the same way to edit and remove measurements.

4. Click the Add 3D Comment tool on the 3D toolbar.

5. Select a part of the model you want to add a 3D comment to.

6. In the Enter Comment String dialog box, type your comment.

When you add comments, a new view is created, allowing you to zoom directly to your comments.

Add comments from the Comment & Markup toolbar

Another way to add comments is to use one of Acrobat’s Annotation tools such as the “Add Text Comment” tool. Similar to adding a 3D comment, this comment will also show up as detail under a view.
Note: Acrobat Reader users can add comments to a PDF if the document author enables commenting for that PDF.

To add a generic comment in this fashion:

1. Display the Annotation toolbar (under the Tools pane).
2. Select a commenting tool such as “Add Text Comment”, and then click inside the 3D object area.

Note: If you delete one of these automatically generated commenting views, the associated comments are still available. You can view and select them in the Comments panel or in the Model Tree, where they are listed under the views. Selecting a comment switches the 3D model to the same viewing configuration it had when the comment was added.

Convert 3D measurements to comments

Individual measurements can be converted to comments, so that they can be reviewed and annotated like other types of comments.

1. In the View pane of the Model Tree, right-click the plus sign next to the measurement view to display the list of individual measurements.
2. Right-click a measurement name and click Convert To Comment.

Display comments for a 3D object

1. Do one of the following:
   • In the Model Tree, select a view that contains comments.
   • If Acrobat Pro XI, click the Comments button or choose View > Comment > Annotations. If Acrobat Pro DC, choose Tools > Comment.
   • In the View pane of the Model Tree, click Options and choose List Comments.
2. Double-click a comment to open its comment window.
3. Repeat steps 1 and 2 to see other comments associated with other views.

Note: When you select a comment, the 3D model appears in the same view it was in when the comment was added.
Chapter 8: Exporting geometry from 3D models

Export geometry

Reuse geometry in other applications by exporting it from the PDF. If the geometry of a 3D model is converted using a PRC B-rep conversion setting, you can export and use it in CAM and CAE applications. Geometry is translated directly to standard file formats that comply with published specifications: IGES, ParaSolid, STEP, VRML, and STL.

You can modify the exported data by specifying settings. In some situations, Acrobat modifies the exported data to improve the results, while avoiding any changes to the actual geometry. For example, if the source CAD application is loose-tolerant and the export format is tight-tolerant, Acrobat can add a tolerance to the exported file.

1. Open the 3D PDF and click the 3D model in the document pane.
2. Select Tools -> Tetra4D Converter -> Export 3D Data
3. Choose a file format from the Save as Type menu, click Settings to select the options for that format, and click OK.
4. Name and save the file.

Format options for exporting geometry

The following options are available by clicking the Settings button in the Save As dialog box. The options that are displayed depend on how the model was created and imported.

IGES Settings

IGES files are saved as version 5.1 and support solid entities.

- **Save Solid To:** Specifies how to write the geometry. The Surface option provides UV curves and any 3D curves (if present). The Solid option provides UV curves (if present) but calculates 3D curves.

- **Save Faceted To:** Specifies whether to write polyhedral solids as trimmed surfaces (Faceted) or as lines (Wireframe).

- **Save Analytics To:** Writes surfaces (cylinders, planes, spheres, cones, torus) and curves (circles, ellipses, parabolas, hyperbolas) as analytic shapes instead of NURBS (Non-Uniform Rational B-Spline).

- **Write Hidden Objects:** Specifies that blank entities in the file are included.
Parasolid Settings
Files are saved as version 11. Specifies whether to save geometry as solids or surfaces.

STEP Settings

- **STEP Standard**: Specifies the Application Protocol (AP) that best suits the intended use (AP 203, AP 214 or AP 242).
- **Save Faceted To**: Specifies whether to write polyhedral solids as trimmed surfaces (Faceted) or as lines (Wireframe).
- **Save Analytics To**: Writes surfaces (cylinders, planes, spheres, cones, torus) and curves (circles, ellipses, parabolas, hyperbolas) as analytic shapes instead of NURBS (Non-Uniform Rational B-Spline).
- **Use Short Names**: Uses internal coding for STEP entities and reduces file size.
- **Write 3D Attributes**: Specifies that the attributes linked to the 3D objects are included. This option is available when selecting the AP242 standard.
- **Write 3D PMI**: Specifies that the PMIs linked to the 3D objects are included. This option is available when selecting the AP242 standard.
- **Add Validation properties**: Specifies that validation properties will be calculated and saved in the STEP file. This option is available when selecting the AP242 standard.

VRML Settings
Specifies the version, either 1.0 or 2.0.

STL Settings

If the initial model has been converted into a 3D PDF using the option “PRC Tessellation (Faceted), the STL settings won’t have any impact on the quality of the exported STL file. In such a case, the tessellation is directly converter to STL.

If the initial model has been converted into a 3D PDF using the option “PRC B-rep (Solid)”, then the STL quality can be controlled using the options proposed in the Settings option because the mesh is recalculated during the export process.

Level of Detail
Specify the level of detail used to calculated the mesh that will be exported as STL. Higher settings produce more accurate results. Lower levels of detail are useful for quick visualization with reduced visual quality. Two additional settings allow you to set specific height and angle values:

- **User Defined**: Use to produce good quality model rendering for visualization and 3D printers. When you select User Defined, click Advanced to define the triangulation parameters.
Advanced

- **Chord Height Ratio**: Specifies the percentage of bounding box used to compute chord height. Set a value from 50 through 10,000.

- **Wireframe Chord Angle**: Specifies the maximum angle between two contiguous segments of wire edges for every face. The value must be from 10 through 40.

- **Binary File**: Creates a binary version of the STL output file, which is smaller than the standard ASCII STL file.

**U3D Settings**
There are no optional settings for exporting to the U3D format.

**PRC Settings**
There are no optional settings for exporting to the PRC format.

**X3D Settings**
There are no optional settings for exporting to the X3D format.

**3MF Settings**
If the initial model has been converted into a 3D PDF using the option “PRC Tessellation (Faceted), the 3MF settings won’t have any impact on the quality of the exported 3MF file. In such a case, the tessellation is directly converter to 3MF.

If the initial model has been converted into a 3D PDF using the option “PRC B-rep (Solid)”, then the 3MF quality can be controlled using the options proposed in the Settings option because the mesh is recalculated during the export process.

**Level of Detail**
Specify the level of detail used to calculated the mesh that will be exported as 3MF. Higher settings produce more accurate results. Lower levels of detail are useful for quick visualization with reduced visual quality. Two additional settings allow you to set specific height and angle values:

- **User Defined**: Use to produce good quality model rendering for visualization and 3D printers

When you select User Defined, click Advanced to define the triangulation parameters.

Advanced

- **Chord Height Ratio**: Specifies the percentage of bounding box used to compute chord height. Set a value from 50 through 10,000.

- **Wireframe Chord Angle**: Specifies the maximum angle between two contiguous segments of wire edges for every face. The value must be from 10 through 40.

- **Keep current tessellation**: Directly convert the current tessellation into a 3MF file.
**JT Settings**

- **Format**: Specifies what type of geometry or tessellation data to export to the JT file:
  - **B-rep (Solid)**
    Retains only the geometry data of the 3D model. This option produces the smallest files, but polygons must be regenerated each time the file is opened.
  - **B-rep + Tessellation**
    Retains the geometry of the 3D geometry and any saved polygon settings. If the 3D model doesn’t include polygon settings, they’re generated from the geometry during conversion.
  - **Tessellation (Faceted)**
    Retains the polygon settings of the 3D model or generates new polygons based on the geometry.
- **Write 3D PMI**: Specifies whether to export 3D PMI to the JT file.
- **Write hidden object**: Exports hidden objects to the JT file.

**ACIS Settings**

- There are no optional settings for exporting to the ACIS format.
Chapter 9: Adding functionality to 3D designs with JavaScript

3D JavaScript Overview

You can use JavaScript to do various things:

- Create animations that simulate a product in action, demonstrate an assembly and disassembly, illustrate the effects of one component upon another, or simulate camera movements around or through the model.
- Let users take pieces out of a model, add pieces to it, or activate overlays, animations, or lighting changes.
- Activate other files or modes. For example, you can display a 3D design as a wireframe, as nodes, in 2D, and so on.

You can set a JavaScript to start based on any action. For example, you can have it automatically start when a user opens the PDF, start when a user clicks a button or link in the PDF, or start based on another JavaScript file’s instructions.

For more information about using JavaScript with Acrobat, see these online resources:
http://www.adobe.com/devnet/scripting.html

JavaScript tips and tutorials:
http://acrobatusers.com/tutorials/filter/search&catagory=13&channel=tutorials&order=tut_hits_sort+desc/P20

Add a JavaScript to a PDF

When you embed a JavaScript file as part of a 3D model and then save the PDF, the JavaScript file becomes part of the PDF document.

1. Using the Select Object tool from the Advanced Editing toolbar, double-click the 3D annotation.
2. In the Edit 3D dialog box, on the 3D tab, select Browse in the Script section.
3. In the Select a Default Script dialog box, locate the JavaScript file and click Open.

By default, the embedded JavaScript runs when you activate the 3D model. You can also set page elements, such as buttons or links, to trigger the JavaScript.

*Note: Instead of embedding the JavaScript file in the PDF, you can include it as a separate file that users load and run manually. Typically, recipients must save the JavaScript file to their local hard drive. To activate this script, the user right-clicks the 3D design, chooses Run a JavaScript, and then browses to select the JavaScript file. This approach runs the script but doesn’t save it with the image.*