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Chapter 1: Work area 
The Tetra 4D ReviewerTM window includes some areas that are fixed and others that you can rearrange 
or resize. The Workspace menu selections determine which areas are open or closed. 

Looking at the work area 
The Tetra4D Reviewer window is arranged in areas. Each area has a specific purpose. The first time 
Tetra4D Reviewer opens, the areas are arranged in their default states. The next time you open Tetra4D 
Reviewer, the work areas appear as they did at the end of the previous work session. 

 

 
 

 
A. Menu bar B. Toolbars C. Model Tree D. Document pane E. File Tree F. Message bar G. Status bar 

A 
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Toolbars and toolbar presets 

About toolbars and toolbar presets 
Toolbars organize tools that apply to different common tasks. Tool tips appear when the pointer hovers 
over a tool, identifying the tool name. In almost all cases, toolbar tools represent commands that are 
also available through the main menus. 

The Tetra4D Reviewer toolbars function in ways like other Acrobat toolbars. You can show, hide, and 
rearrange toolbars in the toolbar area. 

Three toolbar presets organize the toolbar area by opening specific sets of toolbars. The presets are 
Visualization (the default), Design Review, and Technical Documentation. 

Almost all the tools on the toolbars are also available on the Tetra4D Reviewer menus. The icons on the 
menus are identical to the icons used on the toolbars. 

 

Note: In this Help system, the procedures tell you how to perform tasks using the menu commands 
rather than the toolbar tools. As you become familiar with the application, you can easily switch to 
using the toolbars. Some tools also open when you type a keyboard shortcut. 

See also 

“Shortcuts for Tetra 4D Reviewer”  

Toolbars in the toolbar presets 
The three presets are Visualization, Design Review, and Technical Documentation. 

Visualization (Default preset) 
Shows toolbars commonly used for viewing 3D assemblies and parts. 

Standard: Corresponds to certain File menu commands. 

 
A B C D E F G H 

 

A. New B. Open C. Import D. Save E. Save Back In PDF F. Export G. Document Log H. Print 

3D Controls: Corresponds to the View > 3D Controls menu. Contains tools that adjust orientation 
movements and zoom levels. 

 
         

A B C D E F G H 
 

A. Rotate B. Spin C. Pan D. Zoom E. Zoom Window F. Fit Visible G. Rotation Center H. Fly Mode 

Default Views: Corresponds to the View > Default Views menu. Contains tools that switch the 
orientation of objects in relation to different sides of a bounding box. 

 
A B C D E F G H 

 

A. Iso View B. Top View C. Bottom View D. Left View E. Right View F. Front View G. Back View  H. Set Camera From Selection 
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Display Mode: Corresponds to certain View menu commands. Contains tools that change the 
representation of the parts, such as solid or wireframe. Also contains tools for adjusting the display 
environment, such as lighting and background color. 

 
A B C D E F G H I 

 

A. Modify Level Of Detail B. Solid C. Wireframe D. Illustration E. Perspective F. Clipping G. Grid H. Light Settings I. Background 
Color 

Selection Filters: Corresponds to the Edit > Selection Filters menu. Contains tools that govern snap-to 
behavior and highlighting for selecting geometric entities in the document. 

 
A B C      D E F G 

 

A. Snap To Vertices/Points B. Snap To Edges/Curves/Axes C. Snap To Faces D. Snap To Solids/Surfaces E. 3D Snap To Collapsed 
Tree Node F. Highlight Selection G. Find By Name 

Hide/Show: Corresponds to certain View menu commands. Contains tools that change the visibility of 
parts. 

 
A B C D E F G H I 

 

A. Isolate B. Hide/Show C. Toggle Hide D. Show All Parts E. Phantom F. Hide 3D PMI G. Highlight 3D PMI H. Highlight 
Geometry I.Hide Session Markups 

View/Configuration: Corresponds to certain View menu commands. Contains tools relating to CAD or 
user- defined views that are part of the session file. 

 
A B C D E 

 

A. Views B. Filters/Layers C. Add Configuration D. Activate Previous Configuration E. Activate Next Configuration 

Design Review 
Contains toolbars frequently used during the process of analyzing parts and assemblies. 

Analysis Tools: Corresponds to certain Tools menu commands. Contains tools used to create bounding 
boxes, dimension markups, and other functions used in design review. 

 
A B C D E F G H 

 

A. Properties B. Bounding Box C. Add Dimension D. Section E. Physical Properties F. Create Entities G. Split H. Compare 
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Positioning: Corresponds to certain Tools menu commands. Contains tools used to move individual parts 
in the 3D display. 

 
A B C 

 

A. Drag Drop B. Move C. Restore Initial Position 

Axis: Contains tools for controlling the active coordinate system. 

 
       

A B C D E F 
 

A. Set X Axis As Main Direction B. Set Y Axis As Main Direction C. Set Z Axis As Main Direction D. Set As Main CS E. Set As View 
CS F. Create New CS 

Technical Documentation 
Contains toolbars technical writers use to create reports, illustrations, and animations for instruction 
manuals, manufacturing guides, and collaborative documents. 

Documentation: Corresponds to certain Tools menu commands. 

 
      

A B C D E 
 

A. Add 3D Markup B. Balloons C. Bill Of Material D. Create Animation E. Animation 

Play Animation: Corresponds to options available in the Animation controls window. 

 
           

A B C D E F G H I J 
 

A. Go To Start B. Previous Action C. Run Reverse D. Stop E. Run Forward F. Next Action G. Go To End H. Repeat I. Repeat Auto-
Reverse J. Show/Hide Path 

Snapshot: Corresponds to the Tools > Snapshot menu and submenus. 

 
      

A B C D E 
 

A. Window To Raster B. Region To Raster C. Window To Clipboard D. Window To Vector E. Quick Snap 

Other toolbars 
Two toolbars are not included in any preset. These toolbars are available on the Workspace > Toolbars 
menu. 

Edit: Corresponds to common Edit menu commands. 

 
A B C 

 

A. Copy B. Paste C. Preferences 
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• Windows: Corresponds to Window menu commands. 

 
A B C D E F G H 

 

A. New Window B. Split  C. Close D. Close All E. Cascade F. Tile Horizontally G. Tile Vertically H. Model Tree 

View and arrange toolbars 
You can customize your toolbars in several ways. You can open and close toolbars according to what you 
need for your current tasks. You can rearrange toolbars in the work area. 

All individual tools on a toolbar appear and are always in the same positions. 

Note: In Tetra4D Reviewer Help (this document), procedures describe the menu-and-command 
method of selecting tools. As you gain expertise with Tetra4D Reviewer, toolbar buttons become 
convenient alternatives to many menu commands. 

Open and close toolbar presets 
1 Choose Workspace > Toolbar Presets > [preset]. 

2 Choose Workspace > Toolbar Presets > [preset] to open another preset or to close an open preset. 
Visualization is the default preset. 

Move a toolbar 
You can rearrange toolbars in the toolbar area. You can also move toolbars to other parts of the work 
area. Toolbars in the document pane become floating windows with title bars. Toolbars in the toolbar 
area are docked. 

1 Drag the toolbar: 

• For docked toolbars, drag by the grabber bar on the left edge. 

• For floating toolbars, drag by the title bar. 
A B 

  

 
A. Grabber bar for a docked toolbar B. Title bar for a floating toolbar 

 
2 Release the toolbar in a new location: 

• To dock the toolbar in a different location, drop it in a different location in the toolbar area. Or, drop 
it in the Model Tree, File Tree, Message bar, or Status bar. 

• To float the toolbar, drop it in the document pane and move it to any location within that pane. 

Toolbar positions are set at the application level. They don’t change when you open a different 
document or exit Tetra4D Reviewer. 
 

Dock a floating toolbar 
Drag the title bar of the floating toolbar into the toolbar area. 
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Open and close toolbars 
• To open an individual toolbar, choose Workspace > Toolbars > [toolbar]. 

• To open all toolbars, choose Workspace > Toolbars > Show All Toolbars. 

• To close a toolbar, choose Workspace > Toolbars > [toolbar]. 

 

Document pane 

Grids 
Grids are available as part of the background for 2D and 3D views. You control the color, style settings, 
and positions of the lines and units in the Grid preferences. The active coordinates system determines 
the grid center point. 

The grid lines adjust automatically when you change the zoom level. You can include the grid when you 
print. 

Show or hide the grid 
Choose View > Grid. 

Set grid options 
1 Choose Edit > Preferences. 

2 On the Grid tab, select options for the axes and scale. 

See also 

“Grid preferences”  

Full Screen mode 
Full Screen mode expands the document display to cover the entire screen. Full Screen mode hides the 
title bar, menus, toolbars, Model Tree, File Tree, Message bar, and Status bar. The only control visible is 
a floating toolbar with a single button. Clicking that button restores the standard work area view. 

Activate Full Screen mode 
Choose Workspace > Full Screen. 

Escape Full Screen mode 
Click the standard view button     on the floating toolbar. 

 

The Ctrl-L keyboard shortcut toggles between Full Screen and standard views. 

Change the detail level 
The on-screen display of 3D objects approximates the curves and angles in those objects. The Level Of Detail setting 
determines how closely the display matches the actual geometry. 
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The Level Of Detail directly affects the display. Indirectly, it affects a few other functions. For example, 
Level Of Detail settings affect the selection modes when you take measurements or dimensions. Level Of 
Detail also affects the results of calculations you make based on display information. It has no effect on 
calculations based on exact geometry. 

1 Choose View > Level Of Detail. 

2 Choose the level you want in Level Of Detail. 

3 Click Apply, or click Close to leave the Level Of Detail unchanged. 

Level Of Detail is available only for documents that contain actual geometry. The geometry depends on 
the content of the read CAD data. 

Note: If you choose Advanced, the Advanced button opens a dialog box with the same options 
described for Physical Properties. See “Advanced options for Physical Properties calculations” . 

See also 

“Graphics preferences”  

Change the background color 
The background color is associated with the active configuration. You can set different background 
colors for individual configurations in a session file. 

1 Choose View > Background color. 

2 Select the color. 

Background changes are temporary if the active configuration is locked. To make the color change 
permanent, unlock the configuration after you change the background, and then immediately lock it 
again. 

Advanced background options are available on the 3D Preferences tab. 

See also 

“Saving views as configurations” 

“Lock or unlock an existing configuration”  

“3D preferences”  

Move the light source 
The orientation of the light source associated with a configuration. You can set a different light source 
for individual configurations in a session file. 

1 Choose View > Light Settings. 

A light icon appears in the document pane. 

2 Drag the light   to change its position. 

As you drag the light, rotational axes appear that help you visualize the light position. 

Note: You can set Preferences that customize lights. See “3D preferences”  
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Arranging windows in the document pane 
Tetra4D Reviewer is a multi-document application. It is possible to: 

• Work with several documents opened in different windows. 

• Copy and paste objects and entities between documents. 

• Create different views from the same document. The Split window command displays 
different views in the original window. The New Window command displays views in 
separate windows. 

The document windows for files follow behaviors that are common for virtually all Microsoft® Windows® 
applications and system windows. For example, you can use the buttons in the upper right corner to 
minimize, maximize, and restore the window size. You can drag the title bars or edges of a file to resize 
it. 

For more information on these basic functions, see Microsoft Windows Help system. 

Showing multiple views of sessions 
You can open an individual session file in multiple windows. Each window can show a view of the 
assembly that is independent of the views shown in the other windows. For example, when you can 
adjust the point of view, display mode, and zoom in one window, other windows for the same session 
file remain unchanged. 

You can resize the window like any other window by dragging an edge or corner of the window. Splitting, 
cascading, or tiling automatically arranges the windows in the document pane so that you can see all 
open files simultaneously. 

Note: Dimensions and the markups that you create in a window appear in that window but not in other 
windows of the same session file. 

Split views within one session window 
Splitting divides the window into four sections. Each section shows a different default view of the 3D 
objects. 

1 Choose Window > Split. 

2 Adjust the sashing that separates the four views as needed: 

• Drag the sashing horizontally or vertically to resize all four sections. 

• Drag the sashing to the edge of the document pane to close two of the sections. 

• Double-click the intersection of the two sashings to close three of the sections, leaving only one 
view open. 

Open a duplicate window for the active session file 
Choose Window > New Window. 

The appearance in the document pane doesn’t change because new window fills the area and shows the 
same view as the original window. You can resize and arrange the window by the techniques common to 
most Microsoft Windows applications. 
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Arrange multiple windows 
Choose Window > and one of the following: 

• Cascade: Arranges all currently open session files in identically sized windows that overlap. 

• Tile Horizontally: Arranges all currently open session files in equal horizontal rows. 

• Tile Vertically: Arranges all currently open session files in equal vertical columns. 

Model Tree panel 

About the Model Tree 
The Model Tree is a hierarchical structure that organizes the elements of the document by type. When 
multiple CAD files are open, each document appears in the Model Tree. 

The structure for each open document includes five major categories: 

• Recycle Bin: Stores any entities you delete from that individual document. 

• Configurations: Saved views of the parts and some session information, such as Bill Of 
Material and Animations created in that configuration. 

• Coordinate Systems X, y, and z axes defined by the CAD file and any custom coordinate 
definitions. 

• Annotations: Markups and dimensions you create. 

• Models: The assembly and its component parts. 

The Model Tree information is imported from the CAD source file. Tree management Preferences for the 
Reading Mode affect the default Model Tree structure. 

Model Tree icons indicate entity types. For example, a component icon is less complex than an 
assembly icon . Within a component, different icons represent individual items and geometries, such 
as surfaces . 

See also 

“Saving views as configurations” 

“Expanding and collapsing Model Tree structures”  

“Activate a coordinates system and axis”  

“Measure a distance, angle, or coordinate” 

“3D markups”  
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Expanding and collapsing Model Tree structures 
You can change your view of hierarchy levels in the Model Tree in two ways. You can expand individual 
levels, or you can simplify the tree structure. 

Plus [+] and minus [-] icons expand and collapse individual tiers of the Model Tree. By default, the plus 
and minus signs are available at all levels of loaded assemblies. 

The Collapse command simplifies the tree structure by limiting the number of levels that appear. The 
Expand command reverses the Collapse command so that you can open all levels of the structure. 

Note: Plus and minus signs don’t appear under Models for part levels you’ve collapsed with a context 
menu command. 

Expand and collapse individual elements 
1 Click the plus sign [+] to expand a branch by one level. 

2 Click the minus sign [-] to collapse all levels within that branch. 

Note: In the Models section of the Model Tree, plus and minus signs appear only for loaded parts. If you 
load only an assembly structure, only the top assembly level appears in the hierarchy. See “Loading 
parts of a 3D file”  

Expand or collapse one or more levels 
Expand commands on the context menu reveal the plus sign icons [+] for selected branches. Collapse 
commands collapse branches and hide the plus and minus signs for the selected elements. 

Right-click a branch of the Models hierarchy and choose an Expand or Collapse command: 

• One Level: To restore the plus sign [+] to the next tier of the branch structure of the selected 
entity. (Available only on the Expand menu.) 

• Component: To change the availability of the plus [+] and minus [-] signs for entities nested 
under the selected element. 

• All: To change the availability of the plus [+] and minus [-] signs for the selected branch and 
the entities nested under that branch. 

Note: Context menus for Models entities, such as assembly parts, bounding boxes, and sections, have 
Expand and Collapse commands. These commands don’t appear on context menus for other Model 
Tree entities, such as configurations and annotations. 

Models hierarchies 
The Models structure in the Model Tree expands to show several types of entities and information. The 
plus [+] and minus [-] icons beside the structure names expand and collapse the individual levels. 

Primarily, the Models shows the assembly structure for the 3D objects. The arrangement of 
subassemblies, component parts, and items reflects the structural levels read from the CAD file. The 
assembly structure also contains structures for any Product Views and 3D PMI markups read from the 
CAD file. 

Any Sections, Bounding Boxes, created entities, and imported or pasted-in parts appear under Models at 
the same level as the assembly. 
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About attributes 
An attribute is non-geometric information linked to solid parts. The CAD data defines attributes 
information. That information is included when you import the CAD file into Tetra4D Reviewer. 

Tetra4D Reviewer can include some attribute values in text that identifies individual parts of an assembly. 
This information appears at the fully expanded level for each individual component. 

Showing or hiding attributes is set at the document level. You can select which attributes to show or hide. 

Show attributes in the Model Tree 
1 In the Model Tree, right-click the document name and choose Show Attributes. 

2 Under Attributes, select the attributes that you want to show: 

• Select and deselect check boxes for individual attributes. 

• Select the Select All or Unselect All for all attributes. 

Note: Clicking an attribute name in the Attributes pane makes any known values for that attribute 
appear in the Values pane. 

Recycle Bins 
Recycle bins in the Model Tree stores entities that you delete from session files. Each open file has its 
own recycle bin. You can restore deleted items to the document. You can also delete items permanently 
by emptying the recycle bin. 

Note: The recycle bins within Tetra4D Reviewer are independent of the Recycle Bin on the Windows 
desktop. The 

desktop Recycle Bin holds only deleted files and folders. It doesn’t delete individual components or 
entities from within a document. The opposite holds true for the recycle bins within Tetra4D Reviewer. 

Restore deleted entities 
1 Click the plus sign [+] to expand the Recycle Bin for the current document. 

2 Right-click the entities that you want to restore and choose Restore. 
 

Empty a recycle bin 
Right-click the Recycle Bin that you want to empty, and choose Empty Recycle Bin. 

File Tree panel 
The File Tree panel is important for incremental loading. By default, the File Tree is closed when you start 
Tetra4D Reviewer. 

You can open or close the File Tree by choosing Workspace > File Tree. 

See also 

“Loading CAD files in increments”  
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Show or hide information bars 
The Message bar appears at the bottom of the work area, just above the Status bar. The Message bar can 
show information about any reading problems or direct your attention to part of the work area. 

The Status bar appears across the bottom of the work area. In some contexts, the Status bar contains 
information about the current process. For example, the Status bar can provide cues about actions 
needed during the process of a specific task. 

Show or hide an information bar: 

• Choose Workspace > Message Bar. 

• Choose Workspace > Status Bar. 
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Chapter 2: Opening and importing files 
Tetra 4D Reviewer opens files in various 2D and 3D CAD formats, PDFs, and PRW files. PRW files are 
Tetra4D Reviewer session files and have the .prw extension. You can open 3D data in new documents or 
import them into an existing session file. 

Complex CAD files often require large amounts of memory. You can load files incrementally so that only 
specific parts open in Tetra4D Reviewer. This option makes the loading more efficient and speeds up 
processing. Incremental 

loading is ideal in situations in which you want to work on only a few parts. 

Opening CAD files and PDFs 
Computer Aided Design (CAD) applications create the 3D models, using a variety of formats. You can see 
2D and 3D models in Tetra4D Reviewer by opening CAD files or by importing or pasting parts from other 
files. 

You can open the 3D models embedded in PDF files in Tetra4D Reviewer. If the PDF contains multiple 3D 
models, you can open the models in new documents or add them to existing documents. Tetra4D 
Reviewer doesn’t display other types of PDF content that are not within 3D models, such as surrounding 
text blocks or layout graphics. 

See also 

“Save a session file”  

“2D files”  

“Loading CAD files in increments”  

Open a file from within Tetra4D Reviewer 
The same basic method applies whether you want to open a CAD file, a Tetra4D Reviewer session file, or 
a 3D model embedded in a PDF. 

Choose File > Open, and select the file. 

Note: The Options button to the lower left of the Open dialog box opens two tabs of the Preferences. 
These tabs offer advanced options for specific file formats, caching, and reading modes. 

See also 

“Reading Mode preferences”  

“Read/Write CAD preferences”  

Open a PDF that contains multiple 3D models 
When you open a PDF with multiple 3D models, the document pane remains empty until you select which 
model you want to see. 

1 In Tetra4D Reviewer, choose Workspace > File Tree to open the File Tree, if necessary. 

2 Expand the Files structure and the PDF folder. 



20  Using Tetra4D Reviewer™ 
 Opening and importing files 

 

3 Right-click the model that you want to open, and choose where you want to open it: 

• Insert In Current Product: Adds the model to the current open document. 

• Create A New Product: Opens the model in a new document. 

Note: A PDF can include multiple 3D models and other types of content, such as ordinary graphics and text 
blocks. These other types of content do not appear when you open the file in Tetra4D Reviewer. 

Open a model in a multi-model CAD file 
Some CAD formats can include multiple configurations in a document. When you open this type of multi- 
configuration document in Tetra 4D Reviewer, no image loads into the document pane. You select and 
load the model that you want to activate. 

1 If necessary, choose Workspace > File Tree to open the File Tree pane. 

2 Click plus signs [+] to expand the Files Tree and the formats for the models. 

Note: A number, (x), after a format name indicates the number of models in that format. 

3 Right-click the model that you want to load, and choose an option: 

• Insert In Current Product: Opens the selected model in the active document. 

• Create A New Product: Opens the selected model in a new document. 

See also 

“Reading Mode preferences”  

“Read/Write CAD preferences”  

Open a 3D PDF from within Tetra4D ConverterTM 
4 In Acrobat® Pro X/XI/DC, activate the 3D model in the PDF. 

5 Expand Tetra4D Converter plugin in the tools pane, then select "Edit in Tetra4D Reviewer". 

Open a file from the desktop 
Select the file and open it: 

• Double-click to open a PRW session file. 

• Right-click another type of file with 3D content and choose Open With > Tetra4D Reviewer 
Application. 

Note: If Open With isn’t available, select Open. Then select Select This Program From A List, and choose 
Tetra4D Reviewer. 

Open a 3D file by dragging 
You can drag CAD files and PDFs with 3D content into Tetra4D Reviewer to open them. 

1 From the desktop or Windows Explorer, drag the CAD file or PDF into the Tetra4D Reviewer document 
pane. 

2 If the Import/Open dialog box opens (because another document is open), select options: 

• Import: To add the 3D model to an already open document. 

• Open: To open the 3D model as a separate document. 
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• Options: To open Preferences for Reading Mode and Read/Write CAD. 

• Always Do The Same Action: Sets your selection of Import or Open as the default behavior 
for dragging files into Tetra 4D Reviewer. If selected, the Import/Open dialog box won’t 
appear the next time you drag a file into Tetra 4D Reviewer. 

Note: You can turn off the Always Do The Same Action setting later by clicking it on the General tab of 
Preferences. 

Opening PDF files with mixed content or multiple 3D models requires an additional step: selecting a 
method for opening from the File Tree context menu. See “Open a 3D PDF from within Tetra4D Converter”. 

See also 

“General preferences”  

2D files 
Tetra4D Reviewer can read native 2D CAD files. The features and behaviors for 2D files varies from the 
functions for 3D files. 

All 2D CAD file drawings open as separate documents, regardless of how you open them. A 2D file can 
contain several pages, each of which appears on a separate tab in the document pane. The structure of 
the 2D file appears in the Model Tree. 

You can’t save 2D files as session files (PRW), but you can export them as PDF or PostScript® files. Within 
Tetra4D Reviewer, you can apply default views, select markups, show and hide certain entities, apply 
colors, and take raster snapshots. 

Other behaviors depend on the specific format of the read file and the features created in the authoring 
application. 

Import a model into an open file 
You can import into existing 3D files or into a new, empty document. Starting by importing into an empty 
document is useful when you intend to copy and paste selected geometry from another document. 

1 Open a target file: 

• Choose File > New to import the model into an empty file. 

• Choose File > Open and select an existing file to open. 

2 Choose File > Import, and select the file with the model you want to import. 

Note: If the file isn’t listed, make sure that the appropriate file type is selected in the Files Of Type option. 

3 Select the axis system for the positioning of the imported model: 

• Global axis: The default, which is the global CAD coordinate system of the active file. 

• Main axis: The activated coordinates of the active file. 

The file added model appears in the Model Tree under Models. In the File Tree, it appears under the 
format of the CAD file. 

Note: You can set reading Preferences for importing some types of files. If the Options button is available 
in the Import dialog box, you can click it to open the related Preferences tab. 
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Copy and paste an entity 
Ordinary copying and pasting is a simple way to add parts to a product. You can copy and paste parts only 
from one document to another, not within the same document. 

1 Choose File > Open and select the document with the parts you want to add to another document. 

2 Select the parts and choose Edit > Copy. 

3 Choose Window > [filename] to activate the target file for the copied parts. 

4 Choose Edit > Paste. 

Note: If the two documents use different units, a message appears, asking if you want to apply the current 
document units to the part. If you select No, the part resizes itself so that the new units apply to the 
original size values. 

Open and save the reading log as text 
The Model Information is the log of how Tetra4D Reviewer read the source file when it imported the 
model. Log files are available for only some CAD formats. The creation of a log also depends on the 
preferences set on the Read/Write CAD tab. 

Note: In some cases, you can open a log simply by choosing File > Log. 

1 If necessary, choose Workspace > File Tree to open the File Tree pane. 

2 In the File Tree, expand the format and assembly for the model. 

3 Right-click the model in the File Tree, and choose Properties. 

4 The Model Information window opens, showing the complete log for the model. 

5 Click Save, and select a name and location for the log text file. 

See also 

“Read/Write CAD preferences”  

Loading CAD files in increments 

About incremental loading 
The file size of complex product files can be large. Loading only the parts of the assembly needed for your 
current tasks can improve performance and reduce loading time. 

You can change the loading status of individual parts and assemblies from within an open CAD file. After 
you close the document as a session file (PRW) or PDF and exit Tetra4D Reviewer, links to the native CAD 
files are lost. 

Further loading and unloading are no longer possible in the saved session files and PDFs. 

Be careful about unloading parts temporarily because you want to work on another part of the assembly. If the 
unloaded parts are associated with any markups or dimensions, those annotations are lost when the part is 
unloaded. 

Instead, save a copy of the document under a different filename or location, and then load and unload parts 
before you start working on the data. 

Unloaded parts and hidden parts affect sessions differently. A hidden part is present in the session but 
doesn’t appear in the document pane. Hiding parts doesn’t improve performance. (See “Hiding and 
showing entities”.) 
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Loading parts of a 3D file 
You can set up your Preferences to load specific types of files in two stages. In the first phase, Tetra4D 
Reviewer loads only the assembly structure. In the second phase, the components or subassemblies that 
you select are loaded. 

This type of loading is useful to partially load pieces of large assemblies, while keeping the hierarchy and 
structure of the assembly tree. 

Phase 1: Load only the assembly structure 
To do a partial loading, you set up Tetra4D Reviewer   options before you open or import the file. These 
options are format- specific. Partial loading is available for only some types of files. 

1 Choose Edit > Preferences, and select the Read/Write CAD tab. 

2 In the File Formats list, select the format used for the CAD file you want to open. 

3 Click Assembly to open the Assembly Options dialog box. 

Note: If the Assembly button doesn’t appear, partial loading is not available for the selected format. 

4 Select Load Product Structure Only, and click OK to close the Assembly Options and Preferences. 

5 Open the file, using any method. 

At this phase, the only changes appear in the File Tree. Plus signs and numbers in parenthesis appear with 
the names of the relevant formats. No changes appear in the Model Tree or document pane. 

See also 

“Opening CAD files and PDFs”  

Phase 2: Load selected parts and assemblies 
In this phase, you select and load individual parts or subassemblies of the loaded assembly structure. 
When the selected items are open, they appear in the document pane. 

1 If necessary, choose Workspace > File Tree. 

2 In the File Tree, click the plus signs [+] to expand the Files structure, relevant formats, and 
assemblies. 

3 Click and Ctrl-click, as needed, to select the parts and assemblies that you want to load. 

4 Right-click the selected items in the File Tree and choose an action: 

• Insert In Current Product: Loads the items in the active document as new parts. 

• Create A New Product: Opens as a session file that you can save independently of the original 
file. 

Note: The Properties command is also available on the context menu when you select only one part or 
assembly. Choosing Properties opens a read-only window for the selected item. 

All parts appear under Models in the Model Tree, but only the loaded parts have colored icons. Unloaded 
parts are listed with gray icons. 

In the File Tree, a blue dot identifies partially or fully loaded structures. A green check mark appears 
above the icon for each loaded part. 
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Phase 3: Load and unload additional parts 
After you load at least one part, you can load other parts directly from the Model Tree. 

In the Model Tree, right-click an unloaded part and choose Load/Unload. 

Note: You can also use the process described in Phase 2 to load more parts. 

Unload and reload parts 
Unload commands appear on Model Tree context menus for product definitions  and assemblies . 
The commands don’t appear on context menus for parts . 

In the Model Tree, select the components that you want to unload: 

• To delete individual instances of parts and assemblies, click and Ctrl-click to select those components. 
Then right-click the selection and choose Load/Unload. 

• To delete all instances of specific parts or assemblies, select one instance of that component. Then right-
click the component and choose Unload All. 

To reload the parts, select them again in the Model Tree, right-click, and choose Load/Unload. 

Unloaded parts remain listed in both the Model Tree and File Tree, but the icons for unloaded elements 
are dimmed. 

Note: You can distinguish between unloaded items and items that are merely hidden by examining the 
File Tree. The icons for hidden parts are dimmed in the Model Tree but not in the File Tree. 

Expand a reloaded structure 
Special circumstances apply after you actively unload parts or assemblies. When you reload that same 
item, the listing under the Model Tree doesn’t include a plus sign [+] for expanding that branch of the 
Models structure. 

Right-click the reloaded assembly and choose an Expand command: 

• One Level: Shows the next tier of the assembly or part structure. 

• Component: Expands all tiers within the selected part or assembly down to the component 
level. 

• All: Expands all tiers for the selected part or assembly. 

View a Properties log 
1 On the File Tree, right-click the part or assembly and choose Properties. 

2 Click buttons at the bottom of the window to see information: 

• Log (Default): Shows the complete information log for the part or assembly. 

• Summary: Shows limited information from the log. 

• Missing File: Generates a list of any not-found files for the selected assembly. 

• Save: Opens the Save As dialog box, for saving a copy of the log as a text file (.txt). 
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Creating and opening session files 
Files you save in Tetra4D Reviewer are called session files and have the .prw extension. The PRW 
file contains all the originally read CAD data. It also saves all your work on the objects and assemblies, 
including any measurements, animations, or configuration views that you define. 

Opening a session file from the desktop, Windows Explorer, or Start/Documents menu starts Tetra4D 
Reviewer. 

Note: The data in a session file corresponds to Reading Mode preferences used to import or open 3D 
objects in the saved session. 

Save a session file 
Choose File > Save or File > Save As. 

When the file you are saving has not been saved before, the Save As dialog box opens. The Save As dialog 
box contains the usual options for saving files, such as the location and filename. 

Open saved Tetra4D Reviewer session files 
Do one of the following: 

• In Tetra4D Reviewer, choose File > Open; then find and select the session files that you want to 
open. 

• In Windows Explorer, double-click a session file. 

When you open multiple files simultaneously, each session opens as a separate file. 

Note: You can also drag session files from Windows Explorer into the Tetra4D Reviewer workspace. 
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Chapter 3: Managing entities and views 
For Tetra4D Reviewer, the word entity refers to various kinds of information. Some entities are read from 
the CAD data that is imported into the session. These entities can include physical parts, annotations, and 
PMI information. The entities read from the original CAD file flow into a hierarchical list in the Model 
Tree. 

Views combines the orientation of the 3D objects to the camera, or viewing position, the zoom level, and 
other factors. Views can be saved as configurations. 

Entities in 3D documents 
The Model Tree arranges entities under categories, according to type. For example, markups and 
measurements that you create in Tetra4D Reviewer sessions appear under Annotations. Items read from 
the CAD file, such as the component parts of an assembly and CAD PMI, appear under Models. 

The appearances of the icons in the Model Tree give clues about entity status. Colored icons represent 
entities that are visible in the document pane. Dimmed icons represent hidden entities. A small funnel on 
a dimmed icon indicates that the entity is hidden because it is on an inactive layer. 

You can’t create physical parts in Tetra4D Reviewer, but you can create various other types of entities. 
For example, annotations and bounding boxes are considered entities, but they aren’t physical parts of an 
assembly. Typically, you create these types of entities during an analysis or publishing workflow. You can 
also add selected parts from one document to another by importing or ordinary copying and pasting. 

Rename an entity 
1 Right-click the entity in the Model Tree and choose Rename. 

2 Type a name, and press Enter. 

Note: You can change entity names by two other methods. You can double-click the name in the 
Model Tree and type to overwrite the name. Or, you can change it on the General tab of the entity 
Properties. 

See also 

“View and edit entity properties”  

Removing entities 
You can delete unwanted entities from a 3D file, either temporarily or permanently. You can remove all 
types of entities: annotations, bounding boxes, and physical parts. 

When you delete an entity temporarily, the entity appears in the Model Tree under the Recycle Bin for 
that document. Markups and dimensions associated with that entity move automatically to the Recycle 
Bin. You can restore the entity from the Recycle Bin and then restore its associated markups and 
dimensions. 

Deleting an entity that is already in the Recycle Bin deletes it permanently. If the deleted entity was a 
physical component of the product assembly, you can import it again from the original source file, if 
available. 

Note: Instead of removing components from a file, you can hide them. The components remain in the 
session file and can be easily shown again. 
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See also 

“Hide or show individual entities”  

“Unload and reload parts”  

Delete entities from a document 
1 Select the entities that you want to delete. 

2 Choose Edit > Delete to remove the entity and store it in the Model Tree Recycle Bin. 

Restore deleted entities 
1 Expand the Recycle Bin for the file in the Model Tree panel. 

2 Right-click the entity, and choose Restore. 

Selecting entities 

About selecting entities 
An entity is anything in a 3D model that you can select. Selected entities are activated so that you can 
change entity properties, move the entities, change their visibility, and more. 

Tetra4D Reviewer offers advanced selection features, beyond the common clicking techniques. For 
example, you can select entities that are hidden in the document display. Also, you can quickly select 
multiple entities by letting Tetra4D Reviewer sort the selection for you. 

Note: Selecting geometric elements, such as points or edges, involves other features and processes. See 
“Selection filters for geometric selections”  and “Confirming geometric selections with the Accept/Reject 
pointer”. 

Select entities manually 
Select entities: 

• To select visible entities in the document pane, click, Ctrl-click, or hold down Shift and drag a selection 
box around entities. 

• To select entities in the Model Tree, click, Shift-click, and Ctrl-click to select visible and hidden entities. 
Ctrl-clicks select non-adjacent entities. Shift-clicks select all adjacent entities within a range. 

Note: The entities that can be selected in the display area depend on the active Selection Filters. 

See also 

“Changing a current entity selection”  

“Selection filters for geometric selections”  

Selecting multiple entities by attribute 
It takes only one step to select all entities that share a trait. For example, you could select all solid entities 
or all markups. You can also select all the entities in a document in one action. 

Note: After you select groups of entities, you can edit that selection. See “Changing a current entity 
selection” . 
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Select all displayed entities 
Choose Edit > Select All. 

Select entities by type 
1 Choose Edit > Select > By Types > [type]. 

2 Hold down Ctrl and choose Edit > Select > By Types > [type] again to add a second type to the selection. 

Note: The types include Point, Wire, Coordinates System, Planes, Surfaces, and Solids. Dimmed items on 
the By Type submenu indicate that no entities in the current document correspond to that type. 

Select entities by layer 
The list of layers depends on the layers that were read in the files present in the current document. 

1 Choose Edit > Select > By Layers. 

2 In the Select A Layer dialog box, select a layer or Ctrl-click to select more than one layer. When you 
close the dialog box, entities on the selected layers are selected. 

Note: The CAD application creates any layers for assemblies. Those layers appear in Tetra4D Reviewer 
session files only if the import options are set up to preserve these layers. 

Select entities by color 
Use this method to select components that have the same color property in the display. 

1 Choose Edit > Select > By Colors. 

The Select A Color dialog box shows all the colors in use in the document. 

2 Select User Selection to activate the selection process. 

3 Select colors: 

• Select a part in the document pane to select all parts of that color. 

• Select the name of a color in the dialog box to select all parts of that color. 

• Select one color in the dialog box and Shift-click another color name to select all parts of all colors in 
the range. 

• Ctrl-click to select multiple color names or multiple parts. 

Note: To restart the selection process, click User Selection twice. 

Select entities by Attribute value 
1 Choose Edit > Select > By Attributes. 

2 Select an attribute in the Attribute list or type the attribute name in the box below the list to jump to that 
attribute. 

• Select an item in the Attributes list. 

• Type the name of an attribute in the box below the list. 

3 In the Values pane, select a value for that attribute or type the value name to jump to that value. 

4 Click Select. 
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Select an entity by a name search 
You can use the Find feature to search for some kinds of entities, such as physical parts and assemblies, 
balloons, and annotations. 

1 Choose Edit > Find. 

2 In Find What, type part or all of the name for the entity. 

3 Select any options you want to apply to the search: 

• Match Whole Word Only: Ignores occurrences within longer words. 

• Ignore Hidden: Ignores entities that are hidden. 

• Match Case: Ignores occurrences with different capitalization of text. 

• Ignore Unloaded: Ignores instances that appear in the Model Tree but that are not currently 
loaded. 

4 Click Find Next or Find All. Found entities are automatically selected. 

Note: You can search for CAD-read Product Views and 3D PMIs. The Find feature ignores configuration 
names, animation actions, and bills of material. 

Changing a current entity selection 
After you select multiple entities by any process, you can change that selection. You can manually change 
the selection status of individual entities. You can deselect all entities. 

You can also switch the status of all visible entities in one step. This action automatically selects all 
previously unselected entities and deselects all entities that had been selected. 

Edit an entity selection 
In the document pane or the Model Tree, Ctrl-click each entity that you want to select or deselect. 

Deselect entities 
Choose Edit > Select > Unselect All. 

You can also cancel all selections by clicking an empty area of the document pane. 
 

Toggle an entity selection 
Toggling reverses the selection status of all visible entities. Hidden entities are not affected. 

Choose Edit > Select > Toggle. 

Note: This inversion of selection is independent of the selection filters. 
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Entity properties 

About entity properties 
The Properties dialog box contains information about a selected entity or entities. The information comes 
from one of two sources: the original CAD design file or default information applied by Tetra4D Reviewer. 
CAD information always takes priority over default information. 

Some of the information in the Properties dialog box is read only. Non-interactive information appears 
with a gray background. 

You can change some Properties information for entities. The changes you apply to the selected entities is 
saved with the session file. 

A related dialog box, Physical Properties, has a different function from the Properties dialog box. For 
example, Physical Properties includes features for making calculations of area, volume, and mass. These 
calculations are based on information in the Properties dialog box. 

See also 

“Calculating physical properties”  

View and edit entity properties 
Properties dialog boxes are available for all types of entities. 

You can change some entity properties. Most of the editable properties are on the Color/Material tab. 
Properties that are dimmed in the dialog box can’t be edited. 

1 In the Model Tree or document pane, select the entity. 

2 Choose Tools > Properties. 

3 Change the properties on each of the four tabs, as needed. 

4 Click Apply to apply the change to the entities without closing the Properties and examine the entity appearance 
in the document pane. 

5 Continue adjusting settings, as needed. 

6 When you finish, either close the Properties or click Apply and select the next entity that you want to edit. 

Note: Configurations, Coordinate Systems, and the file itself do not have Properties dialog boxes. You 
can open an information display for the file itself by right-clicking the file in the Model Tree and 
choosing Document Information. 

Add and delete user-defined materials 
Tetra4D Reviewer includes several default material definitions, such as Aluminum, Copper, and Steel. 
Each material definition incorporates specific density, color qualities, and transparency settings. When 
you apply a Material option to an entity, the entity assumes all of the characteristics specified in the 
definition. 

You can define, save, and apply custom materials. These user-defined materials appear on the Properties 
dialog box Material menu and are saved with the session file. 

After you apply a material, you can adjust the settings for that entity. Those changes apply only to the 
selected entity and do not alter the saved definition for the material. If you want to change the material 
definition, define a new material with the settings you want and delete the old material. 
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The attributes you choose apply only to the selected entities. If you want to make this set of attributes available 
for future use, create a user-defined material before you close the dialog box. User-defined materials are saved 
with the session file. 

See also 

“Properties options”  

Add a user-defined material 
1 Select an entity, choose Tools > Properties, and select the Color/Material tab. 

2 Specify the Colors, Transparency, and Density settings for the material. 

3 Choose User Defined for Material and click the plus sign . 

4 Type a name for the custom material in the Material Name dialog box, and click OK. 

Delete a user-defined material 
1 In the Material pop-up menu on the Color/Material tab, choose the user-defined material that you want to 

delete. 

2 Click the minus sign . 

Note: The minus sign button is not available for the default materials because they can’t be deleted. 

Edit a user-defined material 
Once you create a user-defined material, its properties are permanent and can’t be edited. However, you 
can easily define a new material based on the existing material properties. 

1 Select a part and choose Tools > Properties. 

2 On the Color/Material tab, select the Material definition that you want to replace, and change the settings, as 
needed. 

3 Click the plus sign , type a name to define the new material, and click OK. 

Note: Reusing the name of an existing user-defined material does not overwrite it or alter its settings. 
Both instances of the name appear on the Material menu until you individually delete them. 

4 In Material, select the user-defined material that is now obsolete, and click the minus sign  to delete it. 

Properties options 
Four tabs organize the Properties information. Some contain read-only information and some include 
interactive options. 

General tab 
• Name: Name of the item, as shown in the Models structure. 

• Text area: Descriptions of attributes, if any exist. Look here for information about geometric 
characteristics and the number of faces, for example. 

Color/Material tab 

• Material: Options for predefined and user-defined substances, such as copper, steel, and 
aluminum. 
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• Simple Color: Limits the available color options to Diffuse. 

• Material Colors: Makes options available for individual Diffuse, Ambient, Emissive, and 
Specular colors and for Shininess. 

• Transparency: Sets the opacity of the selected entity. Lower percentages produce more 
transparent views of the entity. At 0% Transparency, the entity is invisible. 

• Density Sets: the physical property for the selected material, using the specified units of 
weight and volume. 

Position tab 

• Matrix: Indicates the translation and rotation information for each axis (Tx, Ty, Tz, and Rx, Ry, 
and Rz in relation to the Tx, Ty, and Tz values). 

• Sx, Sy, and Sz: values Scale information. 

• Restore : Resets position options. 

• Is Mirror: Indicates if a symmetry is applied on the entity. 

• Is Unit: Indicates if transformations are applied on the entity (translation, rotation, symmetry, 
scale) 

Source tab 
The Source tab provides information related to the original CAD file. The tab lists the original filename, 
the design application used to create the file, and the units of measurements. 

Changing appearances of entities 

Hiding and showing entities 
You can change the display in the document pane to hide or show any individual entities. Visibility does 
not affect the structure of the Model Tree. The Model Tree icons for hidden (invisible) entities become 
gray. Icons for visible entities are colored. 

You can change the look of an entity in the document pane in several ways: 

• Altering visibility by hiding and showing selected entities. 

• Adjusting the transparency of selected objects. 

• Setting an object to phantom mode. 

You can also apply global changes to the display. See “Change the detail level”  and “Change the display mode” . 

Isolate an entity 
Isolating hides all unselected objects. 

1 Select the entities that you want to isolate. 

2 Choose View > Isolate. 
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Hide or show individual entities 
1 Select the entities that you want to change. 

2 Choose View > Hide/Show. 

Choosing Hide/Show again restores the entities to their previous visibility status. 

Note: If the entity that you want to hide is a bounding box, select it in the Model Tree. If you want to 
hide only some segments of a bounding box, select them in either the Model Tree or the document 
pane. 

Toggle all entities between hidden and shown 
Choose View > Toggle Hide. 

All visible entities are hidden and all hidden entities become visible. 

Display all entities 
Choose View > Show All Parts. 

This action leaves all entities visible, including previously hidden elements. 

Hide and show all annotations by type 
Session annotations are 3D markups and dimensions you create in Tetra4D Reviewer. PMI markups are 
read from the CAD file. 

The context menu Hide/Show command changes the visibility of annotations. Two View menu commands 
change the visibility globally, by type. 

Choose View > [command]: 

• Choose Hide 3D PMI to hide all PMI markups. 

• Choose Hide Session Markups to hide all dimensions and markups created in Tetra4D Reviewer. 

Note: Individually hidden 3D PMIs are dimmed in the data tree. When you choose Hide 3D PMI, the PMI 
markup icons aren’t dimmed even though the markups aren’t visible. 

Changing the transparency of entities 
Changing transparency adjusts the opacity of an entity so that you can see it and see through it. 

You can change transparency temporarily, to get a quick glance at the underlying parts or to do other 
work. Temporarily transparent objects aren’t selectable. 

You can also change the Transparency property. This type of transparency leaves the entity selectable. 
The entity remains semi-visible until you actively reverse the transparency setting. 

Phantom mode applies a preset level of transparency to the selected entity. You can’t select an entity 
that is in Phantom mode. 

Note: Phantom mode is a different type of transparency. Phantoming is persistent, so it applies to the 
entity until you actively reverse it. Phantomed objects are always unselectable. 

See also 

“Phantom mode”  
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Change the transparency of an entity 
The Transparency property adjusts your ability to see through entities without preventing you from selecting those 
entities. 

1 Select the entities that you want to set at a specific level of transparency. 

2 Choose Tools > Properties. 

3 On the Color/Material tab, drag the Transparency slider or enter a value for the percentage of 
transparency. 

4 As needed, click Apply and repeat the preceding steps to set other entities at a different percentage of 
transparency. 

5 Click OK to apply the changes and close the Properties dialog box. 

Apply transparency temporarily 
This technique applies transparency without requiring you to select entities first. While a part is 
temporarily transparent, it is unselectable. However, you can select other parts, take dimensions, and do 
other work without reversing the temporary transparency. 

1 Move the pointer over the part that you want to make transparent. 

2 Press H. 

3 As needed, press H again to make more parts transparent temporarily. 

Note: You reverse temporary transparency actions one step at a time by pressing S. 

4 Click anywhere in the background to remove the temporary transparency and restore selectability. 

Phantom mode 
In Phantom mode, selected parts appear semi-transparent and can’t be selected. 

You can apply phantoming to any geometric entity. The segments of a bounding box in Phantom mode 
appear as dotted white lines. Annotations can’t be phantomed. 

Phantoming applies independently of configurations. When you switch from one configuration to 
another, the phantoming remains unchanged. 

Display entities in Phantom mode 
1 Select the parts in the Model Tree or document pane. 

2 Choose View > Phantom. 

The phantoming remains in effect until you choose View > Phantom again to exit Phantom mode. 

Add and remove entities from Phantom mode 
Changing which parts are phantomed requires an in-and-out round trip to Phantom mode. 

Exiting Phantom mode automatically changes any active selection by adding the phantomed parts to the 
selection. You can then change the selection and reapply Phantom mode. 
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1 Choose View > Phantom. 

2 Change the selection, as needed: 

• Ctrl-click to add or remove parts from the current selection. 

• Click outside the current selection to deselect, and then make a new selection. 

3 Choose View > Phantom. 

When adding entities to a phantomed display, select those entities first. Then choose View > Phantom twice or 
click the Phantom toolbar button twice. These actions reapply the phantoming to both the originally 
phantomed entities and to the ones you selected later. 

Change the display mode 
1 Select the 3D objects that you want to change. 

2 Choose View > [display mode]: 

Solid 
Shades in the entire surface area of the parts. 

Wireframe 
Outlines the geometric areas of the parts. 

Illustration 
Outlines the edges of the parts. 

Perspective 
Adjusts Solid, Wireframe, or Illustration mode so that the geometry resembles a physical view. 

Note: Wireframe and Solid modes can be applied together. 

About PMI view management 
The Product Manufacturing Instructions (PMIs) read from CAD files can be numerous and of various 
types. PMIs are often associated with Product Views read from the CAD files. Product Views appear in a 
folder under Models in the Model Tree. 

Product Views are like Configurations that you define and save in Tetra4D Reviewer. A Product View sets 
the orientation, zoom level, and visibility of the 3D objects and 3D PMI markups. 

Views created in CAD can also be associated with the 2D environment, as views defined in a drawing. 
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Apply a PMI Product View 
1 Choose View > Views. 

2 Select Views or Annotation Views (if available). 

3 Under PMI Types, select the types of PMI markups you want to show: Notes and References (if available). 

4 Under View, select the view you want to see: 

5 Click the arrows to step through the list, which automatically applies each Product View as you progress. 

6 Click a check box to select a view, and click Apply. 

7 Close the Views window. 

Note: You can select or deselect all PMI Types with the Select All and Unselect All buttons. 

Moving parts and assemblies 

About moving components 
You can change the positions of individual parts and assemblies in the document display. This feature is 
especially useful if parts from different resource files appear superimposed at the same location. 

The new positions are associated with the currently active configuration. When you switch to a different 
configuration, moved parts appear in their original positions. When you reactivate the configuration with 
the moved parts, they jump back into their moved locations. 

Note: You can move all parts simultaneously in different directions by creating an exploded view. 
Exploded views can also be saved as part of a configuration. (See “Create and view an Explode 
animation” .) 

 

Activate the direct movement controls 
1 If a locked configuration is active, switch to an unlocked or new configuration. 

2 Select in parts that you want to move. 

3 Choose Tools > Drag & Drop. 

The directional arrows, center dot, and box outline appear around the selected parts. 

Moving parts freely with direct movement controls 
The direct movement controls must be activated before you begin this task. 

1 Clicking only once, select the yellow dot that appears in the center of the activated area. 

2 Without pressing the mouse button, slide the pointer to move the selected parts in any direction. 

3 Click once to release the parts in a new position. 

 

Directly moving parts along axes 
The direct movement controls must be activated before you begin this task. 
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1 Clicking only once, select an axis arrow. 

2 Without pressing the mouse button, slide the pointer along the direction of the arrow. 

Note: As you slide the pointer, a small box displays the value of the displacement along the axis. 

3 Click once to release the parts in a new position. 

4 As needed, continue to move and rotate the parts using the other activated controls. 

 

Rotating parts with direct movement controls 
The direct movement controls must be activated before you begin this task. 

1 Clicking only once, select the directional band around an axis arrow. A control appears, showing a radius 
within a circle. 

2 Without pressing the mouse button, slide the pointer around within the circle to rotate the radius and the 
part. 

Note: As you slide the pointer, a small box displays the angle (in degrees) between the original position 
and the rotated position. 

3 Click once to release the parts at the rotated position. 

4 As needed, continue to move and rotate the parts using the other activated controls. 

Move parts directly in the document pane 
The first step of moving parts directly is to activate the movement controls. When the controls are active, 
a box outline appears in the display, enclosing the selected parts. Three control elements also appear: 

• A yellow dot at the center of the enclosed volume. 

• Arrows for each axis. 

• A circular band around each axis arrow, indicating a rotational direction. 
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Yellow center dot B. Arrows show each axis C. Circular band indicates rotational direction 

Note: The Edit menu doesn’t have an Undo command, but you can undo the movement of a part. See “Restore the initial 
position of moved parts” on page 32. 

Activate the direct movement controls 
1 If a locked configuration is active, switch to an unlocked or new configuration. 

2 Select in parts that you want to move. 

3 Choose Tools > Drag & Drop. 

The directional arrows, center dot, and box outline appear around the selected parts. 

Moving parts freely with direct movement controls 
The direct movement controls must be activated before you begin this task. 

1 Clicking only once, select the yellow dot that appears in the center of the activated area. 

2 Without pressing the mouse button, slide the pointer to move the selected parts in any direction. 

3 Click once to release the parts in a new position. 

Directly moving parts along axes 
The direct movement controls must be activated before you begin this task. 

1 Clicking only once, select an axis arrow. 

2 Without pressing the mouse button, slide the pointer along the direction of the arrow. 

Note: As you slide the pointer, a small box displays the displacement value along the axis. 

3 Click once to release the parts in a new position. 

4 As needed, continue to move and rotate the parts using the other activated controls. 
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Rotating parts with direct movement controls 
The direct movement controls must be activated before you begin this task. 

1 Clicking only once, select the directional band around an axis arrow. A control appears, showing a 
radius within a circle. 

2 Without pressing the mouse button, slide the pointer around within the circle to rotate the radius 
and the part. 

Note: As you slide the pointer, a small box displays the angle (in degrees) between the original position 
and the rotated position. 

3 Click once to release the parts at the rotated position. 

4 As needed, continue to move and rotate the parts using the other activated controls. 

See also 

“Saving views as configurations”  

Move parts with the Move Controls 
You can control movements through options in the Move controls window. The Move features are 
available only when an unlocked configuration is active. 

As you work in the Move controls window, notice the text area near the bottom of the window. This area 
displays context-sensitive information about actions that are required as you complete steps in the process. 

 
1 If necessary, activate a new or existing unlocked configuration. 

2 Choose Tools > Move. 

3 Select a button at the top of the Move controls window for the type of movement. 

4 Under Direction Definition, select a Method, if available: Main CS, 2 Points, Edge, or Plane. 

5 Drag the Displacement slider or type a value for the amount of movement. 

Note: If you aren’t satisfied with your selections, click Reset to start over from the original position. 

6 When you are satisfied with the position change, continue working: 

• Click Apply to save the results, and continue to move other parts. 

• Click OK to save the results and close the Move controls window. 

Types of Move controls movements 

Move From Point To Point  

Moves the parts along a direction that you define by clicking two reference points in the document pane. 

Move Along  Axis  

Moves the parts along an axis defined for the selected Method option. 

Rotate  Around  Axis  

Moves the parts along an axis defined for the selected Method option. 
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Move From Axis To Axis  

Moves the parts in relation to your selection of an initial coordinates axis system and a target coordinates 
system axis. 

Move With  Coordinates  

Moves the parts according to the x, y, and z coordinates that you specify. 

Rotate With  Angles  

Moves the parts according to angles you specify to the x, y, and z axes. 

Mirror   

Creates a mirror-image copy of the selected part, naming the new version “SYM_[part name].” The part 
appears on the opposite side of a symmetry plane that you define. 

Method menu for Direction Definition 

The Method menu is available for Move Along Axis and Rotate Around Axis. The menu also appears for 
Mirror, but only Main CS and Plane are listed. 

Main CS 

Moves along the active axis of the designated Main CS. 

2 Points 

Sets the direction by two points that you select in the document pane. The Accept/Reject pointer 
appears as you select points so that you can confirm the position or toggle to another possible location. 
(See “Confirming geometric selections with the Accept/Reject pointer” .) 

Edge 

Sets the direction parallel to an edge that you select in the document pane. 

Plane 

Sets the direction along a plane that you select in the document pane. 

Note: Clicking Select Direction cancels any previous reference items and restarts the process of setting a 
direction. 

Stack up a multi-part movement 
Stack Up simultaneously moves multiple parts but by different amounts. The order in which you stack up 
the parts determines how far they move. For example, if the first part moves by x amount, the second 
part moves 2x, the third part moves 3x, and so on. 

1 Choose Tools > Move. 

2 Select a type of action, action options, and displacement, as usual. (See “Moving parts and assemblies”) 

Note: Stack Up is available only for Move Along Axis  Rotate Around Axis , Rotate With Angles, and 
Move With Coordinates . 

3 Select Stack Up . 

4 Ctrl-click to select parts, selecting the part you want to move least first. Continue selecting in order of 
increasing multiples of the displacement. 

5 Set the displacement value, and click Apply or OK. 

The Stack Up feature is also available for custom animations. 
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See also 

“Options for custom action types”  

Restore the initial position of moved parts 
After you move one or more parts, you can restore them individually to their previous positions. 

Note: If you locked the configuration after moving the part, unlock it. When it is unlocked, you can restore 
parts to earlier positions. 

1 Select the moved parts. 

2 Choose Tools > Restore Initial Position. 

3 When a message appears asking you to confirm the repositioning, click OK. 

Note: If you have moved a part several times, you can only restore the most recent previous position. 

Locate entities visually 
Complex assembly displays can make it challenging to locate specific parts and other entities, such as 
markups and balloons. 

One method of identifying an entity is to select it. Selecting highlights entities in both the document pane 
and the Model Tree. 

Another method is to use the Focus and Show Me features. These features are especially useful when you 
want to locate an object without selecting it. 

You can also locate an entity by searching by some or all of the entity name. 

See also 

“Select an entity by a name search”  

Highlight an entity 
Highlighting draws a red, translucent sphere around the image of the selected entities in the document 
pane. 

• In the Model Tree, right-click the entity and choose Show Me. Clicking anywhere in the 
document pane removes the highlight. 

Focus on an entity 
Focusing does two things: It adjusts the zoom level to the maximum level at which you see all selected 
entities. It places the center of rotation to correspond with the center of a bounding box for the selected 
entities. 

1 In the Model Tree or document pane, select one or more entities. 

2 Right-click a selected entity and choose Focus. 

The zoom level and center of rotation set by focusing remain in effect until you change them. 
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Creating geometric entities 
You can generate some simple entities based on existing geometry. For example, you can create a 
reference point, an intersection, or an axis, or define a new coordinate system. 

These entities are enduring and appear in the Model Tree. The location of the entity in the Model Tree 
and the type of icon appearing with it depend on the entity type. You can use these entities for other 
operations, such as measuring. 

Note: Created entities are not solids or components in the 3D assembly. Physical parts and assembly 
entities must be created in a CAD application and can be imported into a session file. 

See also 

“Create a bounding box entity”  

“Import a model into an open file”  

Create an entity 
1 Choose Tool > Create Entities. 

2 Select the type of entity that you want to create. 

3 Follow the cues that appear displayed in the status bar at the bottom of the application window to make 
selections in the document pane. 

4 Create the entity: 

• Click Apply to create the entity and leave Create Entities open. 

• Click OK to create the entity and close Create Entities. 

• Click Close to close Create Entities without creating an entity. 

• Reset to deselect and start creating a different entity. 

Types of created entities 
The Create Entities control window provides tools for creating nine types of entities. These entities are 
geometrics, not physical parts. 

In the same way as with measurement tools, several Create Entities tools ask you to confirm the locations 
you select. The pointer changes to the Accept/Reject pointer, indicating that you can right-click to 
reject the proposed location and see another proposed location. (See “Confirming geometric selections 
with the Accept/Reject pointer” ) 

Create  Point  From  Selection  

Creates a Point entity at a position you select after selecting this tool. 

Create Point As A Center Of A Circle Defined By 3 Points  

Creates a Point entity from three points you select in the document display after selecting this tool. 

Create  Point  By  Coordinates  

Creates a point from the values you type in X, Y, and Z, using the CAD coordinates system. 

Create  Point  As  Intersection  Of  Segments  

Creates a point where two selected line segments cross. 
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Create Point As An Intersection Of A Face And A Segment  

Creates a point where a selected line segment crosses a selected face. 

Create Axis From A Cylinder  

Creates a wireframe entity from the axis of a cylindrical part or entity. 

Create  Curve As  Intersection  Of  Faces  

Creates intersecting curves from faces that you select. 

Create  Entity By Extraction  

Retrieves information from the selected items as entities under an entity named “[PART NAME] Extraction.” 
Extracted entities can be based on any combination of the three Selection options: 

• Basis Surface: Generates the original surface for the selected face of the solid or the surface 
as it was before any trimming operations. 

• Face: Generates a copy of the selected face from the solid or the surface. 

• Wire: Generates subcurves and characteristic points from a selection of composite curves. 
Generates original and characteristic curves for a selected face. Original curves refers to 
trimming curves. Characteristic curves refers to elements such as the axis of a cylinder. 

Create  Coordinates   System  

Defines a set of reference directions based the selected reference option and elements you select in the document 
pane. The new coordinates system appears as Axis [#] under the Coordinates System section of the Model Tree. 

See also 

“Managing custom coordinates systems”  

Options for creating coordinates systems 
Normal To Surface 

Sets the origin at the point you click. Sets the Z axis normal to the surface at the origin. The orientation of 
X and Y axes are set automatically in relation to iso-curves of the surface, and can’t be edited. 

Points 

Sets the origin at the first point you click. Your second click sets the X axis. Your third click defines the Y 
axis and XOY plane. 

Note: The vector defined by the points 2 and 3 isn’t necessarily perpendicular to the first vector defined by 
points 1 and 2. 

2 Edges 

Sets the origin at the intersection of the two edges. The first edge you select sets the X axis. The second 
edge defines the XOY plane. 

Note: The two selected edges aren’t required to be perpendicular, but they must be linear, nonparallel, 
and secant. 

Curve + Point 

The first point clicked sets the origin and the Z axis. The second click sets the X axis. 

Note: Cylinder parts present a special case for the Curve + Point method. Selecting the cylinder sets the 
cylinder axis as the Z axis. The second click sets the position of the origin and the direction of the X axis. 
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From CS 

Creates a copy of the selected coordinates system. 

Names for created entities 
Tetra4D Reviewer assigns default names to created entities. The default name varies with the type of 
entity created. Some names include a number that indicates the order in which it was created. 

Numbers in parentheses following the entity name indicate how many individual entities are included in 
the created item. 

Different created entities can have identical names. You can rename entities to make it easier to tell them 
apart, as needed. 

See also 

“Rename an entity”  

Changing document views manually 

About manual view changes 
You adjust the view of 3D entities with the 3D Control tools, which are available on a toolbar and on the View menu. 
The 3D Control tools in Tetra4D Reviewer correspond to similar 3D tools in 3D PDF Converter for Acrobat X Pro. 

The selected 3D tool determines what happens when you drag within the 3D display. For example, some tools change 
the 3D orientation of the object. Others change the magnification. 

You switch from one tool to another by selecting it on the 3D toolbar or through the View menu. If all 3D Control 
tools are deselected, default tools are active for the mouse buttons. The Zoom Window tool is the default for the left 
mouse button. The Rotate tool is the default for the right mouse button. 

 
 

A B C D E F G H 

 

A. Rotate B. Spin C. Pan D. Zoom E. Zoom Window F. Fit Visible G. Rotation Center H. Fly Mode 

See also 

“Document pane”  

“Changing appearances of entities”  

“Change the display mode”  

“Graphics preferences”  

Rotate a 3D model 
Rotating turns the model around a specific point in the 3D object. Typically, the Rotate tool is active by 
default. 

1 If necessary, choose View > 3D Controls > Rotate. 

2 In the document pane, set the center of rotation: 

• Drag from any position in the background to rotate around the center of a bounding box that encloses all 
visible parts. 
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• Drag from a position on a component to rotate around that starting point, as indicated by a cross hair 
 that appears. 

Lock a rotation axis 

By default, the rotation turns around all axes. 

1 Choose View > 3D Controls > [active tool] to deselect it. 

2 Using the right mouse button, start dragging to rotate the 3D objects. 

3 As you drag, press the spacebar repeatedly to lock a specific axis: 

• One time Locks the X axis. 

• Two times Locks the Y axis. 

• Three times Locks the Z axis. 

• Four times Unlocks all axes so that you can rotate freely around any axis. 

A double arrowhead in the View CS display in the lower left corner of the document pane appears as a 
reminder of the locked axis. The axis remains locked after you stop dragging, even if you activate a 3D 
Controls tool. 

You unlock all axes by repeating this process, pressing the spacebar until no axis has a double arrowhead. 

Set a fixed center point for rotating and spinning 

By default, the position at which you start dragging becomes the center of rotation only for that specific 
action. You can set a center of rotation that does not change as you manipulate the view in different 
ways. 

You can set a fixed center of rotation at any position on any part but not on the background or in empty 
space between parts. 

1 Choose View > 3D Controls > Rotation Center. 

Note: The Rotation Center tool is available only when the Rotate tool or Spin tool is active. 

2 Click a position on the assembly that you want to serve as the center of rotation. 

A white cross hair marks the position in the display, even if you switch to a different type of tool. 

3 Drag to spin or rotate the 3D object. 

Note: Notice that the Rotation Center tool remains active as you work, even if you switch back and forth 
to other 3D Controls tools. 

4 Choose View > 3D Controls > Rotation Center again to cancel the fixed center. 

Spin a 3D model 
Spinning rotates in relation to the Z axis of the View CS. It is especially appropriate for turning images set 
on a fixed horizontal plane, such as buildings. 

1 Choose View > 3D Controls > Spin. 

2 Drag in the document pane. 

See also 

“Set a fixed center point for rotating and spinning”  
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Pan horizontally and vertically 
Panning changes the position of the 3D object but does not change its orientation. 

1 Choose View > 3D Controls > Pan. 

2 Drag the 3D object left, right, up, or down. 

3 Click again the same icon to restore the standard controls. 

Note: You can also select the Pan on the 3D Controls toolbar to activate and deactivate the Pan tool. If 
you want to switch to Pan temporarily, drag with both the left and right mouse buttons held down. 

Zoom in and zoom out 
Zooming in enlarges or shrinks the view in the document pane. 

Zoom in or out 

1 Choose View > 3D Controls > Zoom. 

2 In the document display, drag up to zoom in and drag down to zoom out. 

Note: Clicking the Zoom tool and dragging horizontally do not change the zoom level. 

If your mouse has a wheel button, you can zoom without selecting the Zoom tool. Instead, turn the wheel 
forward and backward to change the zoom level. Wheel-button zooming centers around the current pointer 
position in the 

document pane. 

Enlarge a specific area 

1 Choose View > 3D Controls > Zoom Window. 

2 In the document display, drag around the area that you want to enlarge. 
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The area within the area enlarges to fill the document pane. 

You can switch temporarily to the Zoom Window tool by holding down Shift and dragging. When you 
stop dragging and release the Shift key, the previously active tool is reinstated. 

Fit the 3D model into the display 

The Fit Visible feature shows the model at the maximum magnification that keeps all visible components 
in the document pane window. 

Choose View >3D Controls > Fit Visible. 

Double-clicking the document display with any tool also changes the view to Fit Visible. In some contexts, you can 
right-click and choose Fit Visible to show all visible parts. 

Applying default document views 
Tetra4D Reviewer offers several features that quickly shift your view of the 3D objects: 

• Default views Align 3D objects in various orientations to the axes of the active view 
coordinates system (View CS). 

• Camera Aligns the view in relation to a selected element in the geometry. Associated with 
Default Views. 

Configurations bear a similarity to default views in that they quickly shift the view. You can create custom 
configurations, lock or unlock them, and use them in later work sessions. 

See also 

“Managing custom coordinates systems”  

“Saving views as configurations” 

Apply a default view 
Applying a default view leaves the zoom level and other viewing characteristics unchanged. The default 
views appear both on the Views menu and in the Default Views toolbar. 

• Choose View > Default Views > and one of the following: 

o Top, Front, Back, Bottom, Left, or Right Aligns the view normal to one of the planes 
defined by two of the three axes of the View CS. 

o Iso Sets the 3D objects in a standard isometric view, based on the active View CS. 

The Smooth Transitions preferences can help you visualize how the view changes. Selecting these preferences 
animates the 3D objects as you apply built-in views. If these preferences are deselected, the view changes in one 
step. 

See also 

“Graphics preferences”  

Set the camera 
A camera setting refers to a combination of zoom level and orientation. Some camera settings are 
independent entities. Other camera settings change the view according to the entity that is currently 
selected. 
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Camera settings can play important roles in an animation. See “Set changing camera angles for an animation”  

1 If appropriate, select one or more entities. 

Set the appropriate Selection Filters for the type of selection you want to make, such as a curve, face, or axes. 

 
2 Choose View > Default Views > Set Camera > [setting]: 

• From Selection Aligns the view to the currently selected entity or to the next entity that you 
select. 

• Restore Config. View Resets the orientation to either the initial settings for the current 
configuration or the initial view when the file opened. 

• From Curve/Edge Sets the view perpendicular to the next curve or edge that you select. 

• From Face Sets the view parallel to the next planar face that you select. Or, if the face is not 
planar, sets the view normal to the face at the point that you select. 

• From Coordinate Axis Sets the view perpendicular to an axis (X, Y, or Z) that you select next. 

• Flip Rotates the view to the opposite side of the assembly or part. 

 

See also 

“Activate a coordinates system and axis”  

“Selection filters for geometric selections”  

Saving views as configurations 

About configurations 
A configuration is a view of a 3D model. A configuration includes basic characteristics, such as zoom level, orientation 
and positions of the 3D objects, visibility of entities, lighting, and background color. 

Configurations also apply specific types of features created in that configuration. These features include 
bills of material, balloons, and sections. 

When you start a Tetra4D Reviewer session or open a new document, the default, Initial Configuration, is 
active. Unless Initial Configuration is locked, objects open as they appeared at the end of your most 
recent work session. 

Create and apply custom configurations 
A session file can contain many configurations. 

Add a configuration 
1 Adjust the orientation, zoom level, visibility settings, and other characteristics for the view, as needed. 

2 In the Model Tree, right-click Configuration and choose Add Configuration. 

3 Type a name for the new configuration. 

The saved view becomes the active configuration. 
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Apply a configuration 
In the Model Tree, right-click the configuration and choose Activate Configuration. 

You can also use the View > Configuration menu to step through configurations, or just double-click a configuration 
in the Model Tree to activate that view. 

Rename a configuration 
1 In the Model Tree, right-click the configuration and choose Rename. 

2 Type a new name. 

Delete a configuration 
1 In the Model Tree, select the configuration. 

2 Click Delete from the context menu, or press Delete key. 

Lock or unlock an existing configuration 
In the Model Tree, right-click the configuration and choose Lock or Unlock. 

About locked configurations 
When a defined configuration is active and unlocked, any changes to the zoom level, orientation, and so 
forth, are incorporated into the configuration definition. Locking a configuration prevents changes from 
altering the configuration definition. Each configuration is individually locked and unlocked. You can lock 
the default Initial Configuration and custom configurations. 

You can change the zoom, rotate, hide parts, and make other view adjustments when a locked 
configuration is active. When you switch to a different configuration and then back to the locked one, the 
locked configuration appears in its original state. 

Some features are disabled or can’t be applied to a locked configuration: 

• Positioning tools 

• 3D Markups 

• Animation controls 

Locking a configuration doesn’t affect your ability to create balloons and bills of material in that 
configuration. 

Hiding and showing by layers and filters 
Layers and filters are CAD structural features created within certain file formats. When the CAD file 
imports into Tetra4D Reviewer, the filters and layers are imported, too. You can’t change filters and layers 
in Tetra4D Reviewer. 

However, you can use them to select parts or to change the view of the 3D objects. 

The Model Tree for a part on a hidden layer isn’t colored and includes a funnel shape . The icon serves 
as a reminder that you can’t use the ordinary Hide/Show command to display the part. 

See also 

“Select entities by layer”  
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Hide and show parts by layers 
1 Choose View > Filters/Layers. 

Note: Immediately after the Filters/Layers window opens, you can click Remove Unused Filters to 
remove the filters that don’t refer to any layer. 

2 Select and deselect layers until only the layers you want to appear are selected, using any combination of 
methods: 

• Click the layers check boxes to select and deselect individual layers. 

• Select Filters in the left pane to select layers associated with that component part or assembly. 

• Click Select All to select all layers. 

• Click Unselect All  to deselect all layers. 

• Click Show Layers In Selected Filter to select layers currently displayed in the document pane. 

3 Click Preview, and review the results of your selection in the document pane and Model Tree. If necessary, 
adjust your layer selections and click Preview again until you are satisfied with the results. 

Note: The Preview is temporary. If you close the Filters/Layers dialog box without clicking OK, the view 
resumes its previous condition. 

Show a part on a hidden layer 
The usual Hide/Show command doesn’t affect the visibility of parts on hidden layers. Layer visibility can 
be reversed only in the Filters/Layers dialog box. 

1 Choose View > Filters/Layers. 

2 Select the layer that includes the part you want to bring out of hiding. 

3 Click Preview to confirm the layer visibility settings, make any adjustments, and click OK. 

Viewing in Fly mode 

View a model in Fly mode 
1 Choose View > 3D Controls > Fly Mode. 

2 Press and hold the following keys to control Fly Mode direction and speed: 

• Q and D Move left and right 

• Z and S Move up and down, left and right (parallel movement without rotation) 

• A and E Rotate left and right 

• R and F Forward and backward. 

• Spacebar Stop movement. 

You can also use your mouse to move up, down, right, and left. Use the center mouse wheel to increase 
and decrease Fly Mode speed. 

3 Release the key to stop the fly through motion. You can also use the mouse wheel to increase and decrease fly 
through speed. 

To see a complete list of keys to use in Fly Mode, open the Preferences dialog box, and click the Fly Through tab. 
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To exit Fly Mode, press ESC or right-click in the model and choose End Fly Mode. 

Manage Fly Mode views 
With Fly Mode, you can view a model at different angles and magnifications. You can save these views, or 
positions, to use later. You can also constrain Fly Mode movement to a horizontal plane so that altitude 
doesn’t change as you move. This feature is useful for moving through architectural models. 

Save a Fly Mode position to use later 
1 In Fly Mode, position the model as you want to save it. 

2 Right-click the model, and then choose Position > Store Current Position. 

3 Type a name of the position in the dialog box, and click OK. 

Change a saved position 
After you create a position, you can rename it, activate it, or delete it. 

1 Right-click inside the model and choose Position > User Positions. 

2 Select a user position, and then select what you want to do with the position. 

3 Click Close. 

Return to the default position 
The default the position in Fly Mode is <Automatic> and always corresponds to the Isometric view. 

1 In Fly Mode, click in the document pane, and then right-click in the model. 

2 Choose Position > Activate Default Position. 

Set a reference for Fly Mode movement 
You can set a horizontal reference in Fly Mode to retain the same height as you move through a model. 
This feature is called walk through mode. Altitude doesn’t change in walk through mode. 

Note: You can change the default height and reference plane settings on the Fly Through tab of the 
Preferences dialog box. 

1 In Fly Mode, click inside the model, and then right-click the model. 

2 Choose Reference, and then select the reference type to use: 

• Plane Uses a horizontal plane as the reference point. The camera position is constrained to 
the height of the reference plane. The reference-plane height is specified in the Fly Through 
preferences. 

• Main UCS Uses the main coordinate system to define a new reference. When selecting this 
option, the reference plane is the one that is perpendicular to the active axis (X, Y, or Z). The 
camera is located at the specified height, which is constant. 

• Curve Or Axis Constrains movement to the length of the curve. The axis is selected 
automatically by selecting a cylinder face. For an axis or line, you can move anywhere using 
the keyboard controls (except A and E). 

• Free Deactivates the previously set reference and restores default Fly Mode behavior. 
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• Invert Direction When Plane Of Main UCS is used, Invert Direction changes the orientation of 
the reference to be opposite the current orientation. 

Change the reference plane 
1 In the Preferences dialog box, click the Fly Through tab. 

2 In the Walk Through section, do the following: 

• To change the height of the horizontal plane, set the height value and corresponding 
measurement unit. 

• To hide the reference plane, clear the Display Plane option in the Walk Through section. 

Graphic rotation controls 
The graphic rotation controls are displayed in the lower-left corner of the model. Use the graphic controls 
for quick access to user-defined positions and rotation functions. 

1 In Fly Mode, right-click a part of the model to be the reference point for the rotation. The graphic rotation 
controls are displayed in the lower-left corner of the model. 

2 Select a control to change the view of the model: 

• Click the triangle to view a list of user positions, and then select a position from the list. 

• Click a square to make a 90-degree rotation around the reference point selected in step 1. For example, 
click the right square to make a 90-degree rotation around the vertical axis to the right. Click the same 
square again to turn around the model, keeping the same reference point. The back square displays the 
back view of the model. 

Note: The squares are visible only when the mouse is over a model part when you right-click. The point at 
which you right- click is used as the center of the rotation. 

Restore the original reference plane 
Apply a horizontal reference plane to restore an initial state. 

1 In Fly Mode, click in the document pane and then right-click inside the model. 

Note: The model position remains the same, but the direction moves horizontally. 

2 Choose Horizontal from the context menu. 

Define a target point for Fly Mode 
In a complex assembly, defining a target point keeps the focus on that point as you move through the 
model. When defining the target point, the current position is used as the starting point. The final 
position is the target point. 

1 In Fly Mode, right-click inside the model, and choose Target Point. 

2 Select a point on the model. 

The red beam represents the distance between the two points. 

3 Right-click in the model, and then click Play. 

4 Press and hold the rotation keys A and E to move the model. 

Use the controls to define the speed and camera orientation. The camera follows the red beam, but the 
view direction can vary. When the target point is reached, the movement stops. 
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5 To stop the movement, do one of the following: 

• Right-click in the document pane, and then choose Reference > Free. 

• Define a new reference. 

• Define a new target point, and make an empty point selection (by clicking in an area of the window 
where no part is displayed). 

Note: Because the starting point is fixed, you cannot change the height and the lateral position of the 
rotation. The Fly Mode direction keys Z, S, Q, D are not active. 
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Chapter 4: Analyzing product designs 
The tools on the Design Review toolbar and in the Tools menu facilitate design-review work. Calculations 
for analysis can be precise, based on exact geometry defined by the original CAD file. Or, calculations can 
be approximate, based on the level of detail set for the display. 

Bounding boxes 
A bounding box is a rectangular wireframe entity that encloses the selected components. The active 
coordinates system (Main CS) determines the orientation of the bounding box faces. Each segment of a 
bounding box is also an entity. 

Bounding boxes are calculated from geometric elements. You can make bounding boxes of a part, 
multiple parts, assemblies, or subassemblies. 

Bounding boxes appear under the Models branch of the Model Tree structure. You can hide or show 
bounding boxes or individual segments, as needed. You can also rename them. 

Each segment of a bounding box is an entity. Tetra4D Reviewer gives default names to the bounding 
boxes and segments. You can change the names in the Model Tree after you create the bounding box. 

See also 

“Rename an entity”  

“Create an entity”  

“Managing custom coordinates systems” 

Create a bounding box entity 
1 Choose Tools > Bounding Box. 

2 Select options for displaying units with the bounding box wireframe: 

• Choose the measurement system in the Unit menu. 

• Select Display Unit to display the units of measurements with the dimensions, or deselect it to see the 
dimension values alone. 

Note: The unit options apply only to bounding boxes created with the middle button, Create Bounding 
Box With Dimension. 

3 Select the parts or assemblies that you want to enclose in the bounding box. 

The Selection area displays the volume and X, Y, and Z dimensions of the bounding box. 

4 Click to create bounding boxes: 

• Create Bounding Box , to create a wireframe bounding box. 

• Create Bounding Box With Dimension , to create a wireframe bounding box that displays each 
dimension measurement. 

• Create Gravity Center , to create a point entity for the center of gravity of the bounding box. Each 
click creates a new bounding box. 
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You can create bounding boxes for other parts without closing the dialog box: Select a different part, parts, or 
assemblies in the document pane or Model Tree. Then click buttons for the types of bounding boxes you want to 
create. 

Review bounding box information 
1 In the Model Tree, select an existing bounding box or bounding box segment. 

2 Choose Tools > Bounding Box. 

Information about the selected element appears in the Selection area. 

3 As needed, choose an option on the Unit menu to change the units of measurements for the Selection 
area. 

4 Select another bounding box or segment to review it or close the Bounding Box controls window. 

Note: You can select and copy information in the Selection area, but it can’t be edited. 

Measuring and dimensioning 

About measurements and dimensions 
Dimensions are annotations of distances, angles, or coordinates in the 3D model. Dimension entities are 
saved as part of the session file. The dimensions you create appear in the Model Tree and in the 
document pane. You can select, hide, show, and view the properties for a dimension. 

A measurement is like a dimension except that measurements appear only temporarily. When you click 
anywhere in the document pane or Model Tree, the measurement disappears. 

Measuring and dimensioning involve selecting specific geometries rather than entire parts. Selection 
filters and the Accept/Reject pointer help you select exactly the elements that you want to use as your 
start and end points. 

Dimensions can be moved and edited. 

See also 

“View and edit entity properties”  

“Calculate physical properties”  

Selection filters for geometric selections 
The selection filters control the snap-to behaviors when you click a point in the 3D display area. When a 
specific selection filter is inactive, clicking ignores that type of geometry. When the same selection filter is 
active, clicking snaps to and selects the nearest geometry of that type. When all selection filters are 
active, clicking selects any type of geometry close to the location you click. 

For example, if you want to select only edges, you can disable the selection filters for points, faces, and 
solids. 

Selection filters sometimes adjust automatically. For example, when the Radius measurement tool is 
active, the Points, Faces, and Solids filters are deselected. The Edges filter remains active so that you can 
select only geometries appropriate for a radius measurement. 
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Types of selection filters 
Points: Snaps to vertices and points. 

Edges: Snaps to edges, curves, and coordinates systems axes. 

Faces: Snaps to faces from solids, surfaces, and planes. 

Solids: Snaps to solids. 

Collapsed Tree Nodes: Collapsed branches of the Model Tree can be selected. The full collapsed branch is selected if 
one part from that branch is selected in the display area. 

Highlight Selection: Highlights entities as the pointer moves over the display, before you click to select. 

Note: Selection filters don’t affect selections in the Model Tree. 

Automatic changes in selection filters 
Selection filters sometimes adjust automatically as you perform specific tasks. These automatic 
adjustments leave on the filters that are appropriate for that task and turn off the other filters. For 
example, when the Radius measurement tool is active, the Points, Faces, and Solids filters are deselected. 
The Edges filter remains active so that you can select only geometries appropriate for a radius 
measurement. 

The selectable entities can be explicit or implicit. Implicit entities are characteristic entities extracted from 
another entity. For example, the center point for a circular edge is an entity that is implicit for the edge. 

Confirming geometric selections with the Accept/Reject  pointer 
When you select geometries in the display rather than parts, clicking can be ambiguous. For example, 
clicking close to the circular edge of a cylindrical solid can select various geometric objects. It can select a 
point, a face, the circumference, or an axis running vertically through the cylinder. In situations like that 
example, a Accept/Reject  pointer icon appears. This icon gives you the opportunity to use the left and 
right mouse buttons to accept or reject a series of possible selections. 

When you click the right mouse button, the first possibility is rejected and the selection changes to the 
next possibility. Clicking the right mouse button repeatedly cycles through all the possible selections and 
back to the first one. 

When the element that you want to select is highlighted, clicking the left mouse button confirms the 
selection and restores the default pointer icon. 

The active selection filters influence which types of geometries are shown as possibilities. 

See also 

“Selection filters for geometric selections”  

Measurement tools 
The types of measurement correspond to the tools in the Dimension control window. 

Distance  Measures on a straight-line between two elements that you select, such as points, lines, 
surfaces, and axes. 

Radius  Measures the distance between a center point and an arc. 

Diameter  Measures the distance across the center point of a circle. 
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Length   Measures the distance along an edge or curve. Length markups look like a standard distance 
dimension, with two lines attached to the extremities of the dimension entity. If the measured entity is 
not a line, only one attachment line appears, connecting the dimension with the middle of the selected 
entity. 

Angle   Measures the angle between two geometric elements. 

Orientation    The angle between a selected edge, curve, axis, or face and a reference plane. The 
reference plane is perpendicular to the active axis of the current coordinates systems. For example, if X is 
active, YZ is the reference plane. 

Coordinates   Identifies the x, y, and z coordinates for a point. 

Note: Coordinates are calculated according to the active coordinates system. The Lock option in the 
Dimension controls window creates an absolute reference. Locking disables the automatic update that 
occurs when you change the coordinates system. 

Minimum/Maximum   Distance The maximum distance is a measurement between an infinite planar 
reference and a part. The reference is the plane that is perpendicular to the active axis of the current 
Main CS. 

See also 

“Selection filters for geometric selections”  

Measure a distance, angle, or coordinate 
As you select elements for a measurement, notice the information in the status bar. The status bar provides cues 
about each step of the selection process. These cues vary according to which measurement tool is active. 

1 Choose Tools > Dimension. 

2 Select a tool for a measurement type. 

3 In the main workspace, choose Edit > Selection Filters or use the Selection Filters toolbar to limit the snap-to 
options by element types: 

Points  , to snap to vertices and points on a part. 

Edges  , to snap to edges, curves, and axes. 

Faces , to snap to faces. 

Solids  , to snap to surfaces and solids. 

Note: You can select multiple Selection Filters. Some filters are automatically deselected and unavailable 
for specific tools. 

4 Click More, and select Dimension options, as needed. 

Note: Selecting the Saved option creates a dimension annotation that is saved with the session file. 
Measurements you make with Saved deselected appear only temporarily. 

5 In the document pane or Model Tree, select the first location or geometric element for the 
measurement. 

Note: Some tools present a Accept/Reject selection pointer that you use to toggle through selection 
possibilities. (See “Confirming geometric selections with the Accept/Reject pointer” ) 

6 If necessary, use the context menu to change the orientation of the 3D objects, and then select a second 
element for the measurement. 

7 If Attach is selected, click the dimension annotation to set its location in the document pane. As needed, drag 
the dimension to reposition it. 



 Using Tetra4D Reviewer™ 
 Analyzing product designs 
 

58 
 

The context menu holds four view commands you can use during the process of creating a dimension: Fit Visible, 
Undo Fit All, Redo, and Restore Config. View. 

See also 

“Edit a dimension”  

“General preferences”  

“Measurement tools”  

“Selection filters for geometric selections”  

Options in the Dimension controls window 
By default, the Dimension controls window opens with only the tool buttons and Selection area shown. 
Clicking the More button expands the windows so that you can see more options, such as Saved and 
Attach. 

Measurement tool buttons Determines the type of measurement. 

Selection Displays information available about the selected element, such as the part name and 
geometry. 

Value Displays the measurement result. 

Note: You can edit the measurement result. For example, you can enter a comment in the dimension or 
force a specific value. 

Saved When selected, creates a permanent annotation of the measurement. 

Attach Creates lines in the document connecting the dimension markup to the locations being measured. 
You can drag an attached dimension within the display. When deselected, the dimension markup appears 
on the measurement. 

Units Defines the units of the dimension. The default units are those read from the CAD file data or set as 
session units in General Preferences. 

Real Creates the actual measurement. 

Along X, Along Y, and Along Z Creates measurements of the x, y, and z projections of the Real 
measurement. Labels in the document pane identify projection measurements as dx, dy, and dz 
components. When Saved is active during the measuring, the x, y, and z projections are saved as 
independent entities and appear in the Model Tree. Projections are calculated according to the active 
coordinates system. 

Display Units Shows the value and unit of measurement together in the markup. 

Font Opens the Font dialog box, for selecting font characteristics. 

Edit a dimension 
After you create a dimension, it appears in the Model Tree under the Dimensions portion of the 
Annotations structure. You can change the appearances and behaviors of some dimensions. 

1 In either the Model Tree or document pane, right-click the dimension and choose Edit. 

2 Change the dimension: 

• To change the value displayed for the dimension, type new text or numbers in Value. 

• To move the dimension markup, select Attach (or deselect and then select again). Click to set 
the new position for the markup. 
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• (For Coordinates dimensions only.) Select or deselect Along X, Along Y, and Along Z for the 
projection of the dimension along the Main CS. 

• To tie a Coordinates dimension to the current Main CS, select Lock. To automatically update 
the dimension when another Main CS is activated, deselect Lock. 

• To change the measurements units, select from the Units menu. 

• To show the units as part of the annotation, select Insert. To hide the units, deselect Insert. 

• To change the font characteristics for the annotation, click Font and select options. 

 

You can quickly change the text of a dimension by clicking its text in the Model Tree and typing. 

 

Move a dimension 
1 In either the Model Tree or document pane, select the dimension. 

2 Right-click the dimension, and choose Move. 

3 Move the pointer to reposition the dimension annotation, and click to set the new position. 

Show and hide annotations 
In either the Model Tree or document pane, right-click the dimension or markup and choose Show/Hide. 

About visible and hidden dimensions 
Visibility of dimensions also depends on the visibility of the parts being measured. These changes occur 
automatically when you hide and show 3D objects. 

• Dimensions associated with elements that are all visible are also visible. 

• Dimensions associated with one or more hidden elements are also hidden. 

• Dimensions associated with a deleted part are deleted. If you restore the associated part, you can then 
restore the dimension, too. 

When you move a part, the dimensions associated with that part also change: 

• Internal measurements of the part remain intact and move in the same way that the part moves. 

• Measurements between points on that part and points outside the part are hidden. A red x on the 
dimension icon in the Model Tree indicates that it is no longer valid. 

See also 

“Moving parts and assemblies”  

“Restore deleted entities”  
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Calculating physical properties 
The Physical Properties dialog box contains built-in functions that calculate area, volume, mass, and the 
center of gravity for parts and assemblies. All these calculations are performed simultaneously. 

It’s important to remember the distinction between Properties and Physical Properties. Properties are 
persistent characteristics for individual entities. Physical Properties temporarily displays calculations. 
These calculations are based on Properties values and the geometry of the selected parts. You can save 
Physical Properties calculation results by exporting them. 

See also 

“Entity properties”  

Calculate physical properties 
You can save calculations only by exporting results to a text file. Otherwise, the Physical Properties 
information clears itself when you close or click outside Physical Properties. 

1 Select the entities in the document pane or Model Tree. 

2 Choose Tools > Physical Properties. 

3 Click Advanced, and change the precision level, as needed. 

4 Click Compute. 

5 Review the results on the Area, Volume/Mass, and Gravity Center tabs. 

6 (Optional) Click Save and choose a location and filename for the text file of the calculations. 

You can calculate physical properties for one entity after another without closing Physical Properties. After you finish 
one calculation, select a different part in the Model Tree or document pane, and click Calculate again. 

See also 

“Advanced options for Physical Properties calculations”  

Physical Properties calculation results 
When you calculate physical properties, the results appear on the three tabs that run across the lower 
area of the Physical Properties. 

Area tab 
Area Shows the surface area of physical parts (the area you could cover with paint). 

Projected Area Projected areas are calculated according to the active axis of the current coordinates 
system. 

Volume/Mass tab 
Volume Physical volume of the selected parts. 

Density Value of the Density property for the selected parts, as specified in the Properties. If the parts 
have different densities, the Density physical property appears as Various. 

Mass Calculation result based on the volume and density values. 

  



 Using Tetra4D Reviewer™ 
 Analyzing product designs 
 

61 
 

Gravity Center tab 
X, Y, and Z Coordinates of the center of gravity for the selected parts. 

Advanced options for Physical Properties calculations 
The Advanced button in Physical Properties opens a dialog box with precision options. 

Settings you select in the Advanced dialog box apply only to the next calculation. If you close the Physical 
Properties or select different parts, the detail level reverts to a default setting. 

Note: Level Of Detail options are also available on the Graphics preferences. As preference settings, the 
options you choose apply globally. 

User Defined 
When selected, these options are available: 

Precision list Includes Extra Low, Low, Medium, High, and Extra High. When you select one of these 
levels, the Chord Height Ratio and Wireframe Chord Angle change to preset values for the selected level. 

Chord Height Ratio Specifies the percentage of bounding box used to compute chord height. 

Wireframe Chord Angle Specifies the maximum angle between two contiguous segments of wire edges 
for every face. The value must be from 10 through 40. 

Note: If you change your selection in the precision list after you adjust the Chord Height Ratio or Wireframe 
Chord Angle, those changes are lost. 

 

Controlled Precision 
When selected, these options are available: 

Wireframe Chord Angle (As described under User Defined.) 

Maximum Chord Height Specifies the maximum distance between surface and tessellation. 

Minimal Triangle Angle Specifies the angle between two contiguous segments of wire edges for every 
face. Allowable values range from 10 through 30. 

Managing custom coordinates systems 
By default, all session files inherit a global coordinates system from the original CAD source file. This 
coordinates system is listed under Coordinates in the Model Tree as CAD CS. When you open a session 
file, the default coordinates system is always active. 

You can’t delete, move, edit, or rename these default global coordinates. You can define and save 
additional coordinates systems with the orientation and origin that you specify. 

Coordinates systems are especially important for sectioning, dimensioning, displacement of parts, and 
controlling standard views. 
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Create a coordinates system 
1 Choose Tool > Create Entities. 

2 Select Create Coordinates System . 

3 Select a Method option and set any required geometry. 

Note: To undo geometry selections, click Reset and select different geometry. 

The custom coordinate system appears as Axis x under Coordinates Systems in the Model Tree. 

See also 

“Confirming geometric selections with the Accept/Reject pointer” 

“Options for creating coordinates systems”  

Rename a custom coordinates system 
1 In the Model Tree, right-click the custom coordinates system and choose Rename. 

2 Type a name. 

Activate a coordinates system and axis 
Two roles apply to coordinates systems: Main CS and View CS. You can assign both roles to the same 
coordinates system or assign the roles to different coordinates systems. 

1 Expand the Coordinate Systems structure in the Model Tree so that you can see the available coordinates 
systems. 

2 Right-click the coordinates system and choose its role: 

Main CS Serves as the reference environment for measurements and calculations. The Main CS is the 
active coordinates system. 

View CS Serves as the reference for Default Views. Solid arrow shapes in the lower left corner of the 
document pane represent the current View CS. 

3 (Optional) Right-click the Main CS coordinate system and choose Direction > and X, Y, or Z to change the mainaxis. 
Assigning a role to a custom coordinate system temporarily changes its name in the Model Tree to Main CS (Z) 
or View CS. If you activate a custom coordinates system in both ways, its name becomes View & Main CS (Z). The 
custom coordinates system reverts to its original name when you assign the roles to a different coordinates 
system. 

When you assign the Main CS or View CS role to the CAD CS, the name doesn’t change. 

Note: Simply selecting a coordinates system in the Model Tree highlights the three lines indicating the 
axes in the document pane. However, selecting or double-clicking doesn’t activate that coordinates 
system in any role. 

View axes of a coordinates system 
Coordinates system axes appear as a trio of lines in the document pane at the origin for that coordinates 
system. 

1 In the Model Tree, expand the Coordinates Systems so that you can see the CAD CS and all custom coordinates 
systems. 

2 Right-click the coordinates system that you want to view, and choose an item from the context menu: 

• Isolate Hides all entities except the coordinates system. 
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• Hide/Show Toggles the visibility of the axes. 

• Focus Zooms in on the origin point. 

• Show Me Draws a circular highlight around the origin point. 

Delete a custom coordinates system 
In the Model Tree, right-click the coordinates system and choose Delete. 

Cutting through parts 

Types of cutting 
Two methods of cutting through parts are Sectioning and Clipping. 

Sections cut through either selected parts or all parts. Sectioning can cut with multiple evenly spaced, 
parallel planes, or with a single plane. You can save sections, which appear as entities in a Sections #x or 
Multiple Sections #x folder under Models in the Models Tree. Sections can be exported as vector images. 

Clipping affects the view but doesn’t create an entity. Clipping cuts through all visible parts with one or 
two planes that can be parallel or not parallel to each other. You can associate only one clipped view with 
a configuration, but each configuration can have a different clipped view. The Clipping command on the 
View menu toggles the clipped view off and on. 

If you simply want to view inside an assembly, sectioning is easier than clipping. If you want to save the 
view and work on the displayed parts, clipping is the better choice. 

Be careful not to confuse splitting with sectioning and clipping. Splitting is a different type of function that 
is useful primarily for making molds of parts. 

See also 

“Splitting parts”  

Creating sections 
Sections cut a plane through 3D objects. You can restrict sectioning to selected parts or section the entire 
assembly. Cross-sections are saved as entities under Models in the Model Tree. Like other entities, you 
can select, hide/show, and review properties for a cross-section. 

Tetra4D Reviewer gives you freedom to create a wide variety of cross-sections. The options that control 
where, how, and through what parts the cross-sectioning happens are in the Sections control window. 

The cutting planes for sections are parallel to each other and equally spaced. 

A Section Plane entity appears in the Model Tree under each Section group. You can activate the section by right- 
clicking Section Plane and choosing Activate Position. The display shows the original orientation and position of the 

section plane. It doesn’t change aspects of the view, such as zoom level or hidden and shown parts. 

See also 

“Clipping”  

Create a simple section 
The Section By Direction method uses the active coordinates system (Main CS). This method sets the 
cutting plane perpendicular to the active axis of that coordinates system. 
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Changes to most of the Section position and display options immediately alter the 3D display. This change 
is temporary until you click Compute. 

You can make and save snapshots of a temporary section display without actually computing the section. 

 
1 Choose Tools > Section. 

2 Under Methods, select Section By Direction. 

3 Under Parameters, select Show Cutting Plane, and leave other display options deselected. 

4 Leave the Position options, Multiple, and Step settings at the default values, and click Compute. 

5 Click More, and drag the sliders or type values to change the X and Y orientations of the cutting plane. 

6 Click Compute to create a section entity. 

After you create a section, the results appear in the Model Tree under Models. The default name is 
“Section [x],” where x indicates the order in which sections are created. You can select, hide, rename, and 
apply other entity options by right-clicking section entities in the Model Tree. 

Note: If you close the Section control window without clicking Compute, the section is not created and the 
display reverts to its previous condition. If you leave Section open after clicking Compute, you can select 
different options and create additional section entities. 

See also 

“Managing custom coordinates systems”  

“Snapshots”  

“Rename an entity”  

Options for complex sections 
The options in the Section controls window provide flexibility for the creation of cross-sections. You can 
specify a different cutting plane and rotate that plane in three-dimensional space. You can customize the 
way a section appears in the document pane. You can cut with multiple parallel planes. You can limit the 
parts that are sectioned and export sectioning results as vector image files. 

Methods 

By default, selection is based on direction, but you can select a different method. Three of the Methods 
options in Section controls create planes based on geometric elements that you select. 

Section  By  Direction  Aligns the cutting plane normal to the active axis of the Main CS. 

Note: You can reassign the Main CS, active axis, and define new coordinates systems while the 
Section controls window is open. See “Activate a coordinates system and axis” on page 53 and 
“Create a coordinates system” on page 52. 

Section  By Plane  Aligns the cutting plane along one of the selected planes in the geometry. Section By 
3 Points  Defines the cutting plane by three points that you click in the 3D display. Section  Along  A  
Curve  Aligns the cutting plane along a curve that you select in the geometry. 

Look for instructions in the text area to the left of the Compute button. Text appears here when the method you 
select requires further actions. 
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Calculation 

Geometrical   Section  Calculates based on exact geometry, if read from the CAD file. When not 
selected, sections are calculated using display information (tessellation). 

Create  Face   (Available only when Geometrical Section is selected) Calculates the face corresponding 
to the section. The results are used to calculate the section area in Physical Properties. 

DXF  Export  Exports the section to a vector image file that can be used for documentation. 

Note: When Multiple is selected, each calculated section is saved in a separate file. The filenames 
include the text typed in File Name and a number corresponding to the number of the section. 

Add  In  Configuration  Makes it possible to reinstate all conditions that existed when you created the 
section. For example, this option retrieves the orientation, part positions, default view, and so forth. You 
can add sections to locked or unlocked configurations. 

Parameters 

Show  Capping  Faces  Displays surfaces covering the cut sides of parts. Capping faces appear in Shading 
mode with no edge, using the part color. 

Use Part Color For Curves Color  Toggles the coloring of the intersection between parts and the cutting 
plane. When deselected, these intersection lines appear in yellow. 

Show  Cutting  Plane  Displays an outline of the cutting plane with a solid arrow indicating the axis 
normal to the plane. 

When the cutting plane is shown, it appears with an arrow and dots at the end of the axes lines. You can drag 
the arrow or dots to move and rotate the cutting plane. 

Flip Cut  Side  Reverses the visibility of sectioned parts from one side of the cutting plane to the other. 

Show  Only Section  Curves  Hides the parts and outlines the intersections between the cutting plane 
and the sectioned parts. 

Cut  Only  Selected Parts Restricts the sectioning to cut only the parts you select in the document 
pane or Model Tree. 

Show  Parts  Completely   When selected, the entire parts remain visible, and highlight lines show 
where the plane cuts through them. When deselected, the section appears in a tear-away view (with 
everything on one side of the cutting plane hidden). 

Position 

Position slider and value box Moves the cutting plane. 

Reset  Value   Restores the cutting plane position to the default value. 

Select Point To Put Section Plane  Moves the designated section plane parallel to itself to the position 
of the selected point. 

Multiple Creates sections using multiple parallel cutting planes. 

Note: You can see the sections after you click Compute. The Multiple option doesn’t include a preview. 

Nb Sections option and value (Appears only when Multiple is selected.) Activates the box that you can 
edit to set the number of cutting planes. When not selected, the number appears in the value box but 
can’t be edited. 

Step value Has two effects. First, it adjusts the effect of clicking the Position slider arrows. Larger Step 
values move the slider more. Second, when Multiple is selected, Step determines the distance between 
the cutting planes. 
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More options 

Clicking the More button expands the Section controls window. The button is not available for the Section 
Along A Curve method. 

Tilt Y slider and value box Rotates the cutting plane around the Y axis of the Main CS. 

Tilt Z slider and value box Rotates the cutting plane around the Z axis of the Main CS. 

Align the camera to a section 
The Set Camera feature arranges the 3D display according to your choice of elements. You can use this 
feature to adjust the view in relationship to section entities. 

1 In the Model Tree, select the Section #x folder. 

2 Choose View > Default Views > Set Camera > From Selection. 

Clipping 
Clipping (or double-clipping) is a view created by two planes cutting across parts. The clipped portions 
lying between the two planes are visible and other portions are hidden. Clipping doesn’t create entities, 
so nothing new appears in the Model Tree after a clipping operation. 

Clipped views are associated with the active configuration at the time they are created. You can toggle 
the clipped view off and on when its associated configuration is active. 

This mode helps and facilitates the understanding and the manipulation of complex assemblies. 

Create a clipped view 
1 Choose View > Clipping. 

2 Select the method for orienting the first plane, and select geometries, as needed. 

3 Drag the Position slider or type a value for the plane displacement. 

4 In Plane, choose Second Plane, and select a method and position. Select from the same options and controls as 
for the First Plane. 

5 Choose Display options, as needed. 

6 (Optional) Select Offset Plane and enter a value for the offset. 

7 (Optional) Click More and drag the orientation sliders to rotate the clipping plane around the Y and Z axes. 

Clipping Methods and Display options 
Clipping and Sections include similar options for defining and positioning cutting planes. The Display 
options for the two features are also similar. 

Methods options 

Clipping  By  Direction  Aligns the cutting plane normal to the active axis of the Main CS. 

Note: You can reassign the Main CS, active axis, and define new coordinates systems while the Section 
controls window is open. See “Activate a coordinates system and axis” on page 53 and “Create a 
coordinates system” on page 52. 

Clipping  By  Plane  Aligns the cutting plane along one of the existing planes in the geometry. 

Clipping  By 3 Points  Defines the cutting plane by three points that you click in the 3D display. 
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Select Point To Put Plane  Moves a defined section plane at the selected point, parallel to its original 
position. 

Display options 

Show  Capping  Faces  Displays surfaces covering the cut sides of parts. Capping faces appear in Shading 
mode with no edge, using the part color. 

Use Default Curves Color Or Use Part Color  Toggles the coloring of the intersection between parts 
and the cutting plane. When deselected, these lines appear in yellow. 

Display  Clipping  Plane  Displays an outline of the cutting plane with a solid arrow indicating the axis 
normal to the plane. 

Display   Curves   Outlines the intersections between the cutting plane and the clipped parts. 

Flip Clip  Side  Reverses the visibility of clipped parts from one side of the cutting plane to the other. 

Show, hide, or edit a clipped view 
Choose View > Clipping. 

Note: When you reopen a clipped view, the Clipping controls window opens. You can close it to leave the 
clipping display the way it is. Or, you can change and apply different clipping options. 

Comparing and splitting parts 

Compare two parts 
The Compare feature identifies spatial differences between two parts within a document. You can 
compare two different parts or two versions of the same part. 

The results appear in the document pane and in the Model Tree. 

Note: This feature works when B-rep is selected as the Reading Mode preference. See “Reading Mode 
preferences” on page 91. 

1 Choose Tools > Compare. 

2 Select Define Old Model, and then select a part in the Model Tree or document pane. 

3 Select Define New Model, and select a second part. 

4 As needed, change the value for Detection Limit, and then click Compute. 

Note: The Detection Limit sets the tolerance threshold for the comparison. Differences under the specified 
value aren’t identified as modifications of the part. 

5 Select a Display menu option and colors, and drag transparency sliders for the display of results, as needed. 
When you click OK, a new entity, Compare #x, appears under the Models structure of the Models Tree. 

Note: The actual results of a Compare Parts computation are based on precise geometry. The 
Representation Results also calculates based on exact geometry, but they are shown in tessellated form. 
Viewing Representation Results is useful because you can easily identify which areas changed and how 
they changed. 

Results options for part comparisons 
Display Indicates the level of accuracy for the calculated results. 

• Geometric Results Calculated from exact geometry. 
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• Representation Results Calculated from the currently active level of detail for the display. 

Unchanged Three-dimensional spaces common to both parts. 

Old Three-dimensional spaces unique to the first component part. 

New Three-dimensional spaces unique to the second component part. 

Check boxes Set the visibility the Unchanged, Old, and New spaces. Selected items are shown. Deselected 
items are hidden. 

Color swatches Open color pickers for designating the Unchanged, Old, and New spaces. 

Sliders Change the transparency of the Unchanged, Old, and New spaces. 

Splitting parts 

Splitting parts is an important function for preparing molds for manufacturing parts. In Tetra4D Reviewer, you can 

split parts in your choice of directions and analyze draft angles for a specific split. You can make sequential splits in 
various directions. 

After splitting, different colors apply to parts on either side of a split. Each split is an entity that appears as a Split #x 
folder under Models in the Model Tree. 

Splitting is available only for files read with B-rep selected in the Reading Mode preferences. 

See also 

“Reading Mode preferences”  

Split a part 
1 Choose Tools > Split. 

2 Select Volume or Sheet as the Split Mode. 

3 Choose a Direction for the splitting axis, and then select the reference items in the display. 

Note: An Accept/Reject pointer icon appears when the position you click could mean various things, 
such as a point, edge, or surface. Use the right and left mouse buttons to step through the possible 
selections. (See “Confirming geometric selections with the Accept/Reject pointer” .) 

4 As needed, select Inverse Direction   and any buttons in the Options area that you want to apply. 

Note: Before you finalize the split, you can check your settings by right-clicking Undercut Preview and 
choosing Draft Angle Analysis. 

5 Click Compute. 

6 (Optional) Change Split options, and click Compute again to create more splits. 

7 Click OK to create the splits, or click Cancel to close the controls without creating the split. 

Split options 
Options are organized in five areas. 
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Parting Mode 

Volume  The default setting. 

Sheet Processes parting in only one direction. Optimizes results for splitting parts without any thickness. 
(Available only for shell-based surfaces.) 

Direction 

Main CS Aligns the splitting axis to the active coordinates system. (No selection required.) 

2 Points Aligns the splitting axis to points that you designate. Edge Aligns the splitting axis to an edge of a 
designated part. Plane Aligns the splitting axis to a designated flat surface. 

Inverse Direction  Reverses the direction of the splitting axis. For two-headed arrow lines, a brightness 
gradient on the axis line indicates direction. 

Select Direction Restarts the process. Click Select Direction when you want to change your selection of 
two points, an edge, or a plane. 

Note: The text under Select Direction describes the currently set splitting axis. 

Options 

Part In Active And Opposite Directions  Determines two groups of faces instead of just one group. 

Split Faces With  Their Silhouette  Curves  When available, splits any non-planar face into two faces 
according to the splitting direction. Also useful for some non-planar faces that are partially visible from 
both sides of the splitting direction. The determined subfaces are automatically linked to the appropriate 
group. 

Add Vertical  Faces  To  Bottom  Group  Attaches non-assigned faces to the bottom group. Available 
only when Inverse Direction is deselected. 

Add Vertical  Faces To  Upper Group  Attaches non-assigned faces to the upper group. Available only 
when  Inverse Direction is selected. 

Slider 

Move Groups Along Directions (Visual aid, available after a split computation.) Moves the split entities 
from their original positions, following the direction of the splitting axis. 

Reading Split results 
The results of a split appear immediately in the Split controls window and in the Model. If you close the 
Split window and reopen it later, the results of the original split don’t appear there. The results remain in 
the Model Tree. The organization of information is similar in both places. 

Note: Be careful to leave the Split controls window open if you want to see a separation display. The 
slider in the Draft Angle Analysis dialog box creates this view. (See “Analyze draft angles in a split” on 
page 60.) 

Unassigned Faces Remaining  Stores all faces that were undetermined during the split operation. 

Split #[x] (In the Model Tree only.) Entity representing the splitting session. Groups, Unassigned Faces, 
and Parted Faces listings are nested under the Split. 

Group #[x] The splitting session listings. If you compute multiple splits simultaneously, then multiple 
Group # items appear, each with a unique value for x. 

Parted Faces #[x] The faces that are assigned during a splitting operation. A single split produces either 
one or two Parted Faces groups, corresponding to the number of directions selected. Parted Faces are 
nested under the Group #. 
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Position slider Moves the display of separated parts along the splitting axis. 

Right-clicking an item in the results area opens a context menu. The options available depend on the item clicked. 

Note: You can hide or show individual groups from a split like any other entity. The Hide and Show 
commands appear on the context menu that opens when you right-click the group in either the Split 
window or Model Tree. 

Analyze draft angles in a split 
You can analyze draft angles during the splitting process, either before or after you compute the split. 
Draft angle analysis is useful for testing directions before you finalize a split. 

Note: After you close the Split controls window, draft angle analysis is not available. 

• In the Split controls window, choose Draft Angle Analysis on a context menu: 

• Before making a split, right-click Undercuts Preview in the results area. 

• After making a split, right-click Group #x in the results area. 

• Adjust settings and selections, as needed: 

• Click the color swatches to open color palettes, and select preset or custom colors. 

• Change the values for the angles taken according to the split directions. The angle values become 
threshold values for the colors display. 

• View the effects of your changes: 

• Click Show Undercuts. 

• Drag the slider to move the separated parts along the splitting axis. (Available only for computed splits, 
not for Undercuts Preview.) 

Note: If you make further adjustments to the colors and values, click Show Undercuts to toggle back to 
the original view. Then click Show Undercuts again to update the view. 

• Close the Draft Angle Analysis dialog box: 

• Click Back To Split to return to the Split controls window to finalize the split or change the settings 
for the split. 

• Click OK or Cancel to close the dialog box and return to the document window without finalizing 
the split. 

Reassign split faces 
You can change the assignment of faces only immediately after the split, while the Split controls window 
is still open. 

Before you begin, drag the slider in the Split controls window to visually separate the various unassigned and assigned 
group displays. 

1 1  With Split controls still open, select faces: 

• To change an entire group of faces, select the group in the results area. 

• To change individual faces, click or Ctrl-click in the document pane to select faces in the groups. 

2 Choose from the context menu: 

• Right-click a group in the Split controls window and choose Part With. 

• Right-click the selection in the document pane and choose Part With. 
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3 In the document pane, click any part in the group to which you want to assign the selection. 

Unassign individual split faces 
1 In document pane, click or Ctrl-click to select individual assigned faces. 

2 Right-click the selected faces and choose Unassign. 
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Chapter 5: Preparing technical documents 
Technical writers can use Tetra4D Reviewer to prepare screen captures, diagrams, cut-away views, and 
other graphics to incorporate in instructional documents. 

Writers can also prepare animations and exploded views to include in exported  PDF files. Users working 
in Acrobat or  Reader® can view and manipulate the 3D images exported as PDFs. 

Writers can use Tetra4D Reviewer to prepare informational content, such as different types of markups 
and customized bill-of-material lists. 

3D markups 

About 3D markups 
3D markups are entities that appear in the Model Tree, under Annotations, and in the document pane. 
Like any other entity, you can hide, show, delete, and see properties for individual markups. You can 
select and edit a markup. 

Note: Balloon markups serve different purposes than 3D markups and appear in a different location in 
the Model Tree. Balloon markups assign numbers to individual parts. These numbers are useful for 
identifying parts for exploded-view callout captions and the bill of materials. 

See also 

“Create balloon notes”  

Create a simple 3D markup 
You can attach markups to all types of geometries, such as points, edges, axes, surfaces, and solids. 

If you want to limit your markup to a specific type of entity, change the Selection Filters. (See “Selection filters for 
geometric selections” ) 

 
1 Choose Tools > 3D Markup. 

2 Under Title, type the text to appear as the markup label, or leave the Title blank to use the part name as the 
markup text. 

3 Set other options, as needed: 

• Type in the Comment area. 

Comment text appears only as a tool tip for the markup in the Model Tree and in the markup Properties. 

• Click Font and select options for font characteristics. 

• Click Attributes and select property information to include in the markup. 

Important: Be careful to leave the 3D Markup dialog box open. If you close the dialog box before placing 
the markup in the document pane, no markup is created and your selections are lost. 

4 Select the reference entity in the Model Tree or document pane. 

5 Without clicking, move the mouse over the document pane to move a preview version of the markup. 
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As you move the mouse, the reference point snaps to various positions on the selected entity. The 
preview text position and connector line also change. 

1 When the preview 3D markup is in the position you want, click to set it in place. 

2 Continue working: 

• To create another 3D markup, change the text and options in 3D Markups, as needed, and select a 
reference entity. 

• To work on a different task, close 3D Markups. 

After you click to set the markup position, the markup appears in both the Model Tree and the document 
pane. 

Hide and show 3D markups 
Change the visibility of 3D markups: 

• To hide and show individual markups, select them, right-click the selection, and choose 
Hide/Show. 

• To hide all 3D markups, choose View > Hide Session Markups. 

• To show 3D markups, choose View > Hide Session Markups to deselect it. If any markups remain hidden, 
select them in the Model Tree and choose Hide/Show from the context menu. 

Advanced 3D markups 
You can add advanced options and features to markups either as you create them or later, by editing 
existing markups. 

See also 

“Edit a markup”  

Attach Fixed 
The Attach Fixed establishes an uneditable reference point for a markup. As a reminder, the reference 
end of the connector line appears as an arrow instead of a dot. You can select the Attach Fixed option 
when you create a markup or later, by editing. 

When you create an Attach Fixed markup, your first click sets the reference point. When Attach Fixed is 
not selected, a preview markup snaps to different positions as you move the mouse over the document 
pane. When you click, the current preview sets the markup in place. 

You can apply the Attach Fixed feature when you create a markup or by editing it later. 

Multiple connector lines 
You can attach one 3D markup to multiple parts or locations. You can add lines immediately after you 
create a markup by right-clicking anywhere in the document pane and choosing Add Geometry. Or, you 
can add connector lines later, by editing. 
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Bent connector lines 
Connector lines can be segmented so that they bend around other displayed items. You can bend lines before you 
set the final location of the markup by right-clicking anywhere in the document pane and choosing Add Bend Point. 
Your next click sets the position of the bend point. You can also bend lines later, by editing. 

You can add multiple bend points to a connector line. 

Comments 
Notes you add here appear as a tool tip in the Model Tree and in Properties for the markup. Comments 
aren’t part of the markup label. 

Font options 
You can set font options for new markups in two ways: 

• Globally, by changing settings on the Preferences Markup tab. 

• Individually, by opening the Fonts dialog box from within 3D Markup as you create the markup. You 
can change font options for existing markups by editing. 

Attributes 
The Attributes dialog box provides an opportunity to add certain CAD data to the 3D markup label. For 
example, you can include information about the Modeler or density of a component part. This attribute 
information in added to Title text you type when you create or edit the markup. 

Edit a  markup 
You can edit the text, the text display, the connector lines, and the position of an existing markup. Editing 
always begins by selecting the markup. 

You can select multiple markups and edit them simultaneously. Simultaneous editing is useful for certain 
kinds of changes, such as moving markups in the same direction or changing font characteristics. 

You can select markups in three ways: 

• Expanding the Annotations and Markups structures in the Model Tree and clicking and Ctrl-clicking 
individual markups. 

• Clicking and Ctrl-clicking the connector line or text of markups in the document pane. 

• Choosing Edit > Select > By Types > Markups. 

Note: Simultaneously editing the text of all markups isn’t recommended. The Edit menu has no Undo 
command. If you change your mind and want to revert to the original text, it would require editing each 
markup one at a time. 

Move a markup 
1 Right-click the selected markups and choose Move. 

2 Move the mouse until the markup preview appears in the position you want, and then click to complete the 
move. 

Note: When Attach Fixed is active for the markup, you can move the markup text and change the 
connector line, but not reference point. To make the reference point movable, too, right-click the 
markup, choose Edit, and deselect Attach Fixed. 
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Edit 3D markup text 
1 Right-click the markup and choose Edit. 

2 Type text edits in Title and Comment. 

3 When finished, click the Close [x] button in the upper right corner. 

You can edit the title by double-clicking the markup name in the Model Tree and typing. 

Change font characteristics for a 3D markup 
4 Right-click the markup and choose Tools > Edit Markup Font. 

5 Change the font options as needed. 

Note: You can also open the Font dialog box by clicking Font in the Edit Markup dialog box when you are 
editing markup text. 

Bend a markup line 
Bend points create a segmented line so that it can bend around other display items. You can create 
multiple bend points in a connector line. 

6 Click the markup text or line in the document pane to select the markup, or select it in the Model Tree. 

7 Choose Tools > Edit Markup. 

8 In the document pane, right-click the markup and choose Add Bend Point. 

9 Click a position in the document pane to set the bend point position, and then click again to set the position of 
the markup. 

You can create multiple bends in a line by choosing Add Bend Point again in the context menu. 

Add markup lines pointing to other geometries 
Adding geometry means creating multiple connector lines between a markup and the component parts. 

1 Click the markup text or line in the document pane to select the markup, or select it in the Model Tree. 

2 Choose Tools > Edit Markup. 

3 In the document pane, right-click the markup and choose Add Geometry. 

4 Click to set the position of the new connector line. 

You can create more lines by choosing Add Geometries again in the context menu. 

Note: You can also bend the lines as you add geometries, using the right-click Add Bend Point command. 

Remove one of multiple markup lines 
1 Select the markup. 

2 Choose Tools > Edit Markup. 

3 In the document pane, right-click the markup and choose Remove Link. 
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Create balloon notes 

About balloon notes 
Balloon notes assign numbered balloons to parts. These useful references identify individual parts for the 
bill of material and in illustrations. 

Balloons appear as “Balloon definition” in the Model Tree. Balloons fit under the Configurations structure, 
as part of the configuration that was active when you generated the balloons. 

You can create balloons for locked or unlocked configurations. 

Create balloons 
1 Choose Tools > Balloons. 

2 Select a Method area, select Automatic or Manual, and type a Start Value for the numbering. 

3 If appropriate, choose a Multiple References option to handle cases of multiple instances of the same 
part. 

4 If appropriate, choose an Assemblies option to handle cases in which your selection includes a branch 
assembly. 

5 In Arrangement area, choose how to organize the balloon positions in the document: Classic (each balloon close 
to the part it numbers), Square, Circle, Top, Bottom, Left, or Right. 

Note: You can change the Arrangement later by right-clicking the Balloon listing in the Model Tree. 

6 In the document pane or Model Tree, select the parts or assemblies that you want to number. 

7 Click Create. 

Balloon note options 
The Insert Balloon Note controls window organizes related options together. 

Automatic and Manual number assignments 

You can apply manual and automatic numbering either alone or together. 

Manual numbering Automatic numbering doesn’t change the balloon numbers in any parts you 
numbered manually. Manual numbering is useful when you want to reserve a number or series of 
numbers for specific parts. In these cases, apply the Manual numbering first. Then apply Automatic 
numbering to add balloon labels to the unnumbered selected parts. 

Automatic numbering The default starting value is 1, but you can start with any positive integer or zero. 
Regardless of what value starts the numbering, the increment is always 1. 

Multiple References options 

Only The First Numbers only one instance of the part. 

All With Same Number Assigns the same number to all instances of the part. 

All With Different Number Assigns a unique number to each instance of the part. 
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Assemblies options 

Number head group Creates balloons for the selected branches themselves but not for the components 
within those branches. 

Number Components Creates balloons for the components within a branch but not for the items located 
within those components. 

Number Items  Creates balloons for all components and for the items nested within the components. 

 

Arrangement options 

Classic Sets balloons according to the available space so that they are close to parts but don’t block the 
view of those parts. 

Square or Circle Sets balloons on a plane along the edges of an imaginary square or circle. 

Top, Bottom, Right, or Left Sets the balloons in a straight line across the top, bottom, left or right of the 
display. 

Edit a balloon number 
You can change the numbering of individual balloon markups or replace balloon numbers with text. 

In the Model Tree, double-click the number and type replacement text or numbers. 

The size of the balloon adjusts so that it fits around the replacement text or number. Multi-word text 
doesn’t wrap within the balloon but appears on a single line. The Balloon column in any existing Bill Of 
Materials updates to show the revised balloon text. 

Bill of material 

About bills of material 
A bill of material (BOM) collects data about selected parts and organizes it in table form. A bill of material 
is especially useful for checking assemblies and producing technical documents. You determine which 
parts appear in each bill of material you create. 

You can create multiple BOM entities. These entities are named BOM #x, where x is a number 
representing the order in which you created it. Each new bill of material appears in the Model Tree under 
the currently active configuration. 

See also 

“Apply a configuration”  

Create a simple bill of material 
The default settings for Bill Of Material work well on small assemblies or when you want to list only parts. 

1 In the Model Tree, activate the configuration in which you want to create the BOM. 

2 Choose Tools > Bill Of Material. 

3 Under Selection, click the selection button   to enable the manual selection process. 

4 In the document pane or Model Tree, click and Ctrl-click to select elements that you want to include in the bill of 
material. 

5 You can select individual items (parts), components, and assemblies. 
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6 In the Bill Of Material window, click Create. 

The information appears in the table and a BOM #x entity appears under the active configuration in the 
Model Tree. 

Note: You can reopen any bill of material (BOM) entity by double-clicking it in the Model Tree. 

Advanced options for creating a bill of material 
Settings for creating a bill of material are organized in three areas in the Bill Of Material window. 

Type area options 

Part List Bill Of Material  Includes the selected parts at the item level only, and ignores the assembly 
hierarchy. 

Hierarchical  Bill  Of Material  (Requires a selection in the Model Tree, not in the document pane.) Lists 
according to the Models structure and the selections in the Options area. If Items is selected, small 
indents in the Part Name column reflect the relationships between assemblies, subassemblies, and 
components. 

Selection area options 

Selection   button  Enables you to manually select entities that you want to include in the bill of 
material. 

Information area Shows the current number of selected elements and identifies them as Groups or 
Items. 

Detail Level button Determines what elements are included when you select a group. Repeated clicks 
cycle through three selection levels: 

Group   Lists a selected assembly, subassembly, or component without listing subordinate elements 
within that group. 

Component    Lists all product definitions (components) in the selected group but does not list the 
group itself. 

Item   Lists only the individual parts (geometries) in the selected group. 

Balloons Automatically selects all entities with balloon markups. If the active configuration contains no 
balloon markups, the Balloons option is not available. When Balloons is selected, you can manually edit 
the parts selection by Ctrl-clicking, as needed. 

Option area options 

Additional options are available when Hierarchical is selected in the Type area: 

Geometric Set As Component Interprets any geometric sets as hierarchical nodes. (Geometric sets are 
available as a feature in only some CAD formats.) 

Include Invisible Lists all parts in the selection, regardless of whether they are hidden or shown. When 
deselected, hidden parts don’t appear on the list. 

Components Lists structures down to the component level on separate rows. Rows include references to 
geometric parts. 

Items Lists each individual geometry (item) and product definition (component) on a separate row. 
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Open a bill of material 
The information for parts is organized in columns. By default, attributes columns are hidden. 

1 If necessary, activate the configuration in which the bill of material appears. 

2 Choose Tools > Bill Of Material. 

You can also open a bill of material by double-clicking it in the Model Tree. BOMs appear under 
individual Configurations listings in the tree structure. 

Information in a bill of material 
The displayed columns appear in the order shown here and with these names: 

Number  Value corresponding to the order of the row on the table. 

# Balloon Balloon value for the listed part (if available). 

Note: A check box appears next to the # Balloon column name when balloons exist for any of the parts. 
Deselecting the check box hides the balloon numbers in the column but leaves the column open. 

Part name Name of the listed element. 

Quantity Number of instances of the listed part. 

File Name Name of the CAD file corresponding to the listed part. 

File Path Location of the CAD file for the listed part. 

Comments  A placeholder column for text notes you add to the bill of material. 

Attribute columns By default, columns for part attributes, such as density, don’t appear in the bill of 
material. 

Adjust views of bill of material data 
The data and arrangements in a bill of material can be changed like other types of tables. 

Change column width 
Drag the bar next to column name. 

Double-clicking a cell expands the column width so that you can see all the text in that cell. 

Rearrange columns 
Drag the column headings left or right. 

Shadow highlights show the possible positions as you drag. 

Sort table by the data in a column 
Sorting arranges the table rows in alphabetic or numeric order for the selected column. 

1 Click a column header once to sort the table in ascending order. 

2 Click the column header again to sort in descending order. 

Show and Hide individual columns 
1 Right-click any column heading, and choose Show/Hide Columns. 

2 Under Standard, deselect only the columns that you want to hide. 
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3 Under Attributes, select only the additional columns that you want to include in the bill of material. 

Add notes in an open bill of material 
Double-click inside a Comments column cell, and type any text you want to add. 

Your notes are saved with the bill of material. You can edit Comments text by double-clicking a cell and typing. 

Update a bill of material 
Only the Comments text can be directly edited in a bill of material. However, you can update the list with 
new selections and options. 

1 If necessary, activate the configuration with the BOM, and choose Tools > Bill Of Material. 

2 Change settings for the BOM type and hierarchy, as needed. 

3 Select the selection button  to activate part selection. 

4 Select and deselect groups and parts, as needed. 

5 Click Update. 

Note: Updating removes any text in the Comments column. To keep a record of the comments, choose 
Create instead of Update. Or, export a reference copy of the BOM before updating. 

See also 

“Advanced options for creating a bill of material”  

“Export a bill of material”  

Interactions between a bill of material and document views 
The Bill Of Material includes a toolbar. You can use these tools for interactions between the Bill Of 
Material window and the parts display. 

Highlight  Selected  Parts  When selected, parts that you select in the Bill Of Material are also selected 
and highlighted in the document pane. 

Display  Only  Selected  Part  Hides all parts except those parts that are currently selected in the Bill Of 
Material. 

Restore  State  Reverts to the document pane view in effect when you created or opened the bill of 
material. 

Always Fit All  Adjusts the document pane zoom to the maximum level that still shows all selected 
parts. When you select a different part, the zoom adjusts again. (Available only when Display Only 
Selected Part is selected.) 

Always  Display  All  Instances  Displays all instances of a selected part instead of displaying only that 
instance of the part. (Relevant only when Always Display Only Selected Parts is also selected.) 

Select In View To Find Item In Current Bill Of Material  When selected, parts that you select in the 
document are also selected and highlighted in the bill of material. 

The final button in the row deals with saving a copy of the bill of material as a text or HTML file. (See 
“Export a bill of material” ) 
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Export a bill of material 
When you export a bill of material, the resulting file includes all information in the visible columns. Data 
in hidden columns isn’t included. 

1 With the bill of material open, click Export Bill Of Material to open the Save As dialog box. 

2 Select a location and filename. 

3 In Save As Type, choose a file format: Text Files (*.txt) or HTML Files (*.html). 

4 Select additional options for the selected format: 

• For a text file, choose separator characters in the Field Separator and Text Separator menus, and 
click Save. 

• For an HTML file, select Automatic Snapshot to include snapshots of all listed parts. Then select an 
image file format (.bmp or .jpg), and click Save. 

Note: The Automatic Snapshot option adds an Automatic Snapshot folder to the location selected for 
the exported HTML file. 

See also 

“Show and Hide individual columns”  

Snapshots 

About snapshots 
Tetra4D Reviewer includes built-in features for capturing screen shots of the document pane. You 
determine how much of the image to capture, the resolution, and the format of the saved snapshot file. 

Snapshots don’t become part of the session file. You save snapshots externally as independent image files 
or by pasting them into a different application. Your format choices for raster snapshots include bitmap, 
JPEG, and TIFF. Vector snapshots are saved in AutoCAD DXF format. 

You control the resolution of snapshots through the Read/Write Image preferences. 

See also 

“Read/Write Image preferences”  

Create and export a snapshot 
1 Adjust the view as needed, such as changing the orientation, zoom level, background color, and so forth. 

2 Choose Tools > Snapshot > and the type of snapshot: 

• For BMP, JPEG, and TIFF formats, choose Raster > Window To Raster or Raster > Region To 
Raster. 

• For 2D DXF or EMF formats, choose Vector > Window To Vector. 

3 (Only for the Region To Raster method.) Adjust the black outline that appears to enclose the area that you want 
to capture: 

• Drag the corners and midpoints to move the image borders. 

• Drag within the outline to move it. 

• Click Snap in the Snapshot dialog box when you finish changing the outline. 
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Note: While you are defining a region, you can zoom with the mouse wheel or by choosing View > 3D 
Controls > Fit Visible. Other 3D Controls tools aren’t available. 

4 In the Export dialog box, select the file format, filename, and location for the snapshot. 

 

Elements shown and ignored in vector exports 

Vector snapshots always include all geometric entities and balloons currently appearing in the document 
pane. The background color is ignored and replaced with white. Vector snapshots capture geometries in 
real size. 

Vector snapshots ignore any grid displays. In DXF format, dimensions and markups are ignored. In WMF 
format, dimensions and markups are included. 

Copy and paste a snapshot 
1 Adjust the view as needed, such as changing the orientation, visibility, zoom level, background color, and so 

forth. 

2 Choose Tools > Snapshot > Raster > Window To Clipboard. 

3 Paste the image into a document in another application. 

Create Quick Snap images 
Quick Snap creates snapshots using the settings for a previous snapshot in the same work session. 
Consequently, Quick Snap is not available before you export at least one snapshot or immediately after 
you capture an image to the clipboard. 

1 Create and export a snapshot by another method, using the parameters you want to apply to your Quick Snap 
images. 

2 Adjust the view of the 3D model, as appropriate for the next screen capture. 

3 Choose Tools > Snapshots > Quick Snap. 

4 (Only if you used Region To Raster for the original snapshot.) Adjust the size and position of the cropping outline, 
and click OK in Snapshot. 

Note: The Quick Snap capture is automatically named and saved without any notification. 

You can continue changing views and taking Quick Snaps. Quick Snap remains available until you close the 
document. 

The Quick Snap capture is saved in the same location as the previous snapshot. Quick Snap applies the 
same filename as the previous snapshot with an identifying number. For example, if you took a raster 
snapshot and named it engine.bmp, the subsequent Quick Snap images would be named engine_00.bmp, 
engine_01.bmp, and so forth. 

Set Snapshot resolution 
1 Choose Edit > Preferences, and click the Read/Write Image tab. 

2 Click Resolution. 
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3 Select a resolution: 

• Select Window to use the current resolution of the document window. 

• Select Desktop to use the screen resolution set on the Settings tab of the Display properties 
Control Panel. 

• Select the numeric option and choose a resolution from the menu of resolutions supported by your 
computer graphics board. 

• Select Custom and enter Width, Height, and DPI values. 

When DPI is selected, a second set of Width and Height options are available. The pixel values define the 
dimensions of the snapshot image. 

Note: Settings changed in the Preferences remain in effect until you change them again. If you select a 
high resolution and want to go back to a default resolution setting, use the Read/Write Image 
preferences to reset the resolution. 

See also 

“Read/Write Image preferences”  

Advanced resolution options 
The pixel values for Height and Width determine the actual size for image output. If DPI is selected, the 
DPI and pixel values are used to calculate the print size of the snapshot. The Height (mm) and Width (mm) 
describe that print size. 

If you change the DPI or a height or width dimension, other values are automatically recalculated. These 
changes appear after you press Tab or click to advance to another option in the Resolution dialog box.“Set 
Snapshot resolution” . 

For example, changing the Width (pixels) value automatically changes the Width (mm) value. Changing 
the DPI value automatically changes both the Width (pixels) and Height (pixels) values. However, changes 
to a Width value don’t affect Height values. 

See also 

“Set Snapshot resolution”  

Creating animations 

About animations 
Animations show individual parts or groups of parts in action. Animations can be simple or complex, 
multi-step actions. Animations can show all or selected parts in motion and changes in visibility. 

Animations are associated with the active configuration at the time of their creation. You can create 
animation only when the active configuration is unlocked. 

Built-in features create exploded views in a minimal number of steps. You can create other simple or 
complex custom animations one action at a time. Animations are saved with the session file and can be 
exported in AVI format or within a PDF. 

See also 

“Export an animation to AVI”  

“Exporting to PDF”  
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Create and view an Explode animation 
An exploded view shows the component parts separated from each other around a central point. 
Exploding moves each part in a separate action. You can rearrange the action sequence and add other 
actions by editing the animation after you create it. 

Note: An animation appears under the configuration that is active when you create it. The active 
configuration must be unlocked to create an exploded view. 

1 Choose Tools > Animation > Create Animation and select Explode  in the Create Animation controls 
window. 

2 In the Model Tree or document pane, select the assembly or specific parts that you want to separate in 
space. 

3 Select options, as needed: 

• Hierarchical Moves assemblies and parts in the order that they appear when the Models 
structure is fully expanded. The first assembly on the list moves first, followed by the first 
subassembly under that assembly. Next, any tiers under the first subassembly move, and so 
forth. 

• By Level Moves assemblies and parts by tier levels. All assemblies at the top tier explode first, 
starting at the top of the Model Tree structure. Next, all second-tier subassemblies move, in 
the order that they appear in the Model Tree. Then all third-tier structures move, one at a 
time, and so forth. 

• Project Path Keeps actions parallel to the Main CS.  Displacement slider Controls the amount 
of movement for parts. Level Limits the number of structural tiers that move. 

4 Finish the animation: 

• Click Apply to set the first action of the animation and continue adding more actions. 

• Click OK to save the animation with just the exploded view action. 

See also 

“Edit an animation”  

Apply and collapse exploded views 
You can show or reverse an exploded view as a single-step change. 

1 In the Model Tree, apply and expand the configuration with the exploded view animation. 

2 Right-click the animation and choose the available command: 

• Compact To collapse an exploded view. 

• Expand To apply an exploded view. 

 

Hide and show animation lines 
By default, blue lines appear in the document pane to show the travel distance and direction of animated 
parts. You can hide or show these lines. 

In the Model Tree, right-click the animation and choose Hide Path or Show Path. 
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Create animations with custom actions 
Actions are individual movements or visibility changes in an animation. Several methods of defining 
movements are familiar techniques used to move parts in the document pane. 

1 In the Model Tree, activate the configuration in which you want to create the animation. 

Note: You can create new animations only in unlocked configurations. If you lock the configuration after 
creating an animation, you can edit the animation without unlocking the configuration. 

2 Choose Tools > Animation > Create Animation. 

3 Select an action type for the first action, using the buttons across the top of the window. 

4 In the Model Tree or document pane, select the parts that you want the first action to move. 

5 Select the appropriate options for the action type, and review the preview results in the document pane. 

6 Click Apply to define the final state for the action. 

7 Repeat the process to create more actions, using your choice of methods, options, and parts. 

After you create an animation, you can set cameras in the Play Animation controls window. Cameras 
change the point of view as the animation plays. 

See also 

“Move parts with the Move Controls”  

“Move parts directly in the document pane”  

“Create and view an Explode animation”  

“Define cameras for an animation”  

Action types 
Move Along  Axis  Moves parts in a straight line that you specify in Direction Definition. Rotate  Around  
Axis Turns parts around a line that you specify in Direction Definition. Move With  Coordinates 
Displaces parts by specific values for the X, Y, and Z axes. 

Move On Helix  Combines movements along and around a line that you specify in Direction Definition. 

Move On Curve  Moves parts along an exact-geometry curve that you select in the Model Tree. Or, 
moves along a selection in the document pane that is either the edge of a surface or a face of a solid. 

Moving  Box  Moves with the Drag & Drop controls. Multiple changes made with different controls can 
apply to a single action. 

Explode    Separates parts in space around a central point. 

Hide/Show    Toggles the visibility of selected parts. 

Options for custom action types 
The options that appear vary according to the selected action type. Options are available only after you 
select the parts for the action. 

Note: For Explode options, see “Create and view an Explode animation” . 
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Stack  Up  Stack Up creates a separate action for each part you select. The parts move by successive 
multiples of the displacement setting. 

The order in which you select parts determines how far and in what order they move. For example, if the 
first part moves by x amount, the second part selected moves 2x, the third part selected moves 3x, and so 
on. 

The actions occur in the reverse order that you selected the parts. For example, if you create a Stack Up 
animation with four selected parts, part #4 moves first. Part #3 moves next, and so on. 

Note: Stack Up is available only for Move Along Axis , Rotate Around Axis , and Move With Coordinates 
action types. 

Displacement sliders Move selected parts, either by linear displacement or rotation. Two methods have 
multiple sliders: 

• Move On Helix The upper slider sets the translation (linear displacement). The lower slider 
sets the rotation angle. 

• Move With Coordinates Each of the three sliders sets the displacement along a specific axis 
of the Main CS. 

• Direction Definition  

o Main CS Moves along the active axis of the active coordinates system. 

• 2 Points Sets the direction by two points that you select. The Accept/Reject pointer  
appears as you select points so that you can confirm the position or toggle to another 
possible location. (See “Confirming geometric selections with the Accept/Reject pointer” .) 

• Edge Sets the direction parallel to an edge that you select in the document. 

• Plane Sets the direction perpendicular to a plane that you select in the document. (Not 
available for Move On Helix actions.). 

Select Direction When highlighted, shows that the selection process is active. You can click Select 
Direction to deactivate and restart the selection process. (Not available when Main CS is selected.) 

Reset Sets all options back to the default values. 

Step value The Step value controls the number of intermediate positions shown when you play the 
animation. Smaller step values show more intermediate positions. 

Reverse Path (Available for Move On Curve.) Changes the direction of movement along the curve. 

Keep Parallel (Available for Move On Helix and Move On Curve.) 

When Keep Parallel is selected, the orientation of the parts is always parallel to their original orientation. 
This type of rotation compares to a human hand sliding in circles on a flat surface. The hand always points 
in the same direction. 

When Keep Parallel is deselected, the selected parts stay oriented to the center of rotation as they move. 
This type or rotation compares to a passenger airplane circling around an airport at constant altitude. The 
plane constantly changes its orientation to align with the circumference of the circle. 

Hide and Show (Available for Hide/Show.) Sets the visibility of the selected parts for the current action. 
The visibility state applies to all intermediate actions until you change it again in a later action. 
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Play an animation 
1 In the Model Tree, apply and expand the configuration with the animation. 

2 Choose Tools > Animation > Play Animation. 

3 Set the starting point for the animation: 

• Drag the long action slider in the middle of the Animation controls window. 

• Click Go To Start or Go To End . 

• Click Previous Action or Next Action to progress through actions one step at a time. 

4 Drag the smaller slider to set the animation speed. 

5 Select automatic pause options: 

• To play in continuous loops without pauses, select Repeat Simulation . 

• To play forward and then backward in continuous loops without pauses, select Auto Reverse . 
(Available only when Repeat Simulation is selected.) 

• To pause at the end of each action, select Auto Pause. 

6 Set the camera option: 

• To play entirely from the default point of view, deselect Enable Camera. 

• To show assigned changes in the point of view, select Enable Camera. 

7 Play the animation, either by dragging the action slider or by selecting Play Forward or Play Backward . 

Note: The Chg./Slide option determines whether or not the camera changes appear when you drag the 
animation slider. 

Advanced options for playing animations 
Line. Step Controls the default speed at which linear displacements play. Smaller values move the 
selected parts by smaller fractions of the total displacement, which slows the movement during playback. 
The linear step value applies only to actions without custom Step values. 

Ang. Step Controls the default speed at which rotations play. Smaller steps rotate the selected parts by 
smaller angles, slowing the movement during playback. The angular step value applies only to actions 
without custom Step values. 

Show Path Toggles the visibility of a line and dots indicating the travel positions of parts for each action. 

Show  Current  Action  Slider  button Toggles what the main slider shows: global actions (the entire 
animation sequence) or individual actions (the current action only). 
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Set changing camera angles for an animation 
A camera sets the view at a specific orientation and zoom level. You can define cameras that change the 
point of view as an animation plays. Camera changes in an animation make smooth transitions as they 
shift from one point of view to another. 

After you define custom cameras in the Play Animation window, you can apply them to the actions in the 
animation. You can edit the camera assignments after you make them. You can play animations with the 
camera disabled, so the action appears from a constant point of view. 

Define cameras for an animation 
1 In the Model Tree, apply the configuration with the animation, and choose Tools > Animation > 

Play Animation. 

2 Select Enable Camera. 

3 Using the 3D Controls tools, set the orientation and zoom level for the camera. 

4 Click Add Camera . 

5 Repeat the process, as needed, to add more cameras. 

The camera is automatically named Camera #x, where x represents the order in which you created it. 
Cameras can’t be edited, renamed, or removed from the menu. 

Apply cameras to actions 
1 In the Model Tree, apply the configuration with the animation, and choose Tools > Animation > 

Play Animation. 

2 Select Enable Camera, and click Action List. 

3 Activate an action in the Action List in any of these ways: 

• Drag the action slider. 

• Click Go To Start or Go To End . 

• Click Previous Action or Next Action to progress through actions one step at a time. 

Note: Be careful to use these controls to navigate to the action you want to see. Merely highlighting the 
action in the Action List does not activate the selected action. 

4 Choose a camera from the Camera menu, and apply that camera: 

• To apply the camera to only the currently selected action, click Define Camera For Current Action . 

• To apply the camera to all actions before the selected action, click Define Camera For Previous Actions 
. 

• To apply the camera to the selected action and all later actions, click Define Camera For Current Action 
And Next Actions . 

5 Continue activating actions and applying cameras, as needed. 

You can apply a specific camera to several actions or apply a different camera to each action. You can also 
apply a mixture of No Camera and custom cameras. 

Note: The Chg./Slide option enables camera changes when you drag the action slider. By default, 
Chg./Slide is deselected, which prevents changes in the point of view when you drag the action slider. 
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Edit an animation 
Animations fall under configurations in the Model Tree. To edit an animation, it’s important that you 
activate the appropriate configuration first. 

Add actions to an existing animation 
Adding actions simply continues the process you used to create the original animation. To review those 
steps and options, see “Create animations with custom actions”. 

1 Choose Tools > Animation > Create Animation. 

2 Select an action type, parts, and options, and click Apply. 

The new actions are added to the end of the animation sequence, as shown in the Model Tree structure 
of the animation. 

Change the action sequence 
Changing the sequence can be especially useful for Explode animations. You can change the order in 
which parts move out from the center. You can also intersperse other actions, such as changing the 
visibility of individual parts. 

1 Choose Tools > Animation > Play Animation. 

2 Select Action List to expand the Animation controls window. 

3 Select an action in the list and select changes that you want to apply: 

• Move Up and Move Down buttons Changes the sequence of a selected action in the 
Action List. 

• Group   Actions  Groups the selected actions so that they play simultaneously. 

• Ungroup   Actions  Removes the selected actions from any groups in which they were 
included. 

• Remove  Action  Deletes the selected action from the animation. 

Note: Although you can directly rearrange or delete actions in the Model Tree, using the Action List is 
the preferred method. The advantage of using the Action List is that you can immediately check results 
by playing the animation with the slider or play controls. 

Edit options for an individual action 
1 Right-click the action in the Model Tree or the action path in the document pane, and choose Edit Action. 

Note: The paths of all actions appear in the document pane. Yellow arrows, green end points, and step 
numbers appear for steps that can be lengthened or shortened. 

2 Make changes available for the action, as needed: 

• Type a new name for the action. 

• Drag the slider or type a value to change the displacement. 

• Type a new Step value. 

• Select or deselect Keep Parallel. 

Note: You can also drag the yellow arrows, endpoints, or X, Y, and Z arrows for an action to make 
changes in the document pane. The displacement value in Edit Action updates as you drag. 
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3 Click Apply. 

4 Select another action in the animation: 

• Select the action in the Model Tree. 

• Select the yellow arrow or path of the action in the document pane. 

5 Change the action, as needed, and click Apply. 

6 Continue selecting, changing, and applying new options to other actions, as needed. 

Note: If you select another action without clicking Apply, any changes you made to the previously 
selected action revert to their previous settings. 

Add or remove parts to an action 
1 Right-click the action in the Model Tree or the action path in the document pane, and choose Edit Action. 

2 In the document pane or Model Tree, select the parts you want to add. 

3 Right-click the selection and choose Add Geometry or Remove Geometry. 

4 Click APPLY. 

Group and ungroup actions 
Grouped actions occur simultaneously. Actions can be grouped only when they have no common part. 

1 Select the actions in the Model Tree. 

2 Right-click the selection and choose a command: 

• To group the selected actions, choose Group Actions. 

• To remove the selected actions from an existing group, choose UnGroup Actions. 
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Chapter 6: Exporting and printing 
When you are ready to share the results you’ve created in Tetra4D Reviewer, you can export and print. 

An important feature of Tetra4D Reviewer is the ability to export 3D models to PDF. Users who open the 
PDF in Acrobat or Reader can collaborate in reviewing the design. For example, you can apply one of the 
prepared form templates to create a PDF form that other users fill in and return. Or, you can use the 
Review features in Acrobat to distribute the PDF and collect feedback from team members and clients. 

Exporting 

Export an assembly 
1 Choose File > Export, and select a filename and location for the exported file. 

2 Choose a format in Save As Type. 

3 Click Options to open the Read/Write CAD for the selected format, and make changes, as needed. 

See also 

“Read/Write CAD preferences”  

Export only some parts of an assembly 
1 Choose Workspace > File Tree to open the File Tree, if necessary. 

2 Expand the File Tree format for the parts you want to export, and select those parts. 

3 Right-click the selection and choose Create New Product. 

4 Load, unload, import, delete, and copy-and-paste to include just the parts you want to export, as needed. 

5 Choose File > Export, select a filename, location, format, and format options, as needed. 

See also 

“Loading parts of a 3D file”  

“Import a model into an open file”  

Exporting to PDF 
Acrobat and Reader users can view and manipulate the 3D models that you export to PDF fromTetra4D Reviewer. 
For example, users can activate a 3D model in those applications. Users can then manipulate the model, such as 
rotating it, adjusting the lighting, viewing markups, and adding 3D comments. Acrobat and Reader users can also 
open and expand a view of the hierarchical structure of the model. 

Several templates for exporting to PDF are included with Tetra4D Reviewer. Some templates are PDF forms. These  
forms include various fields that are typically needed for product design review and other manufacturing processes. 

In Acrobat, you can also create and save custom templates. These templates are typically based on documents that 
you prepare in various business applications. 

For information about creating and using PDF templates and PDF forms, see Tetra4D Converter Help. 
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Export using a PDF template 
1 Choose File > Export. 

2 Choose PDF Files (*.pdf) on the Save As Type menu. 

3 Click Options. 

4 Under Write Options, click Options. 

5 Under Template PDF, select Use Template, and then click the Browse button. 

6 Select the provided or custom template that you want to apply. 

7 Select any other export options that you want to apply, and then designate a file name and location for the 
exported PDF. Once you select a template, the choice is used for all subsequent PDF exports. To stop applying 
the template, you can deselect Use Template. You can reopen the PDF Export Options either during another 
export or by opening the Read/Write CAD preferences for PDFs and clicking Options. 

PDF templates provided in Tetra4D Reviewer 
The PDF templates for Tetra4D Reviewer include: 

3DTemplate_Tetra4D_ACR 

Opens the model as a form with all the elements in a3drtemplate_02 plus boxes for Comments, 
Configurations, Functions, Results, and Details. Created and editable with Acrobat X Pro forms features. 

3DTemplate_Tetra4D_LC 

Identical to a3drtemplate_03, but created and editable with LiveCycle® Designer ES2. The LiveCycle 
Designer application is installed with 3D PDF Converter Premium and Acrobat X Pro. 

The PDF templates for Tetra4D Reviewer can be found in the 3DPDFConverter\templates folder that is 
installed in the plug-ins folder with Acrobat 

Export an animation to AVI 
1 In the Model Tree, apply and expand the configuration with the animation. 

2 Choose Tools > Animation > Play Animation. 

3 Adjust the playing options for the animation. 

Note: Exporting with Auto Pause  selected creates a separate AVI file for each action. The AVI filenames 
include a number corresponding to the action. Exporting ignores the Repeat Simulation setting. 

4 Click Save AVI , select a location and filename, and click Save. 

5 In the Video Compression dialog box, select Compressor and Compression Quality Settings. If appropriate, click 
Configure and select settings for your compressor utility. 

See also 

“Creating animations”  



93  Using Tetra4D Reviewer™ 
 Exporting and printing 

 

Printing 
You can print the current view in the document pane on a color printer or black ink printer. The printed 
image includes all visible entities, including balloons, dimensions, markups, and axes for the coordinates 
systems. 

The Printer Setup Preferences determine the text, alignment, and font options for the header and footer 
for the pages. The same Preferences tab contains an Options link to additional settings for scale, grids, 
and other advanced features. 

You can print two images in two ways: raster (pixelated) and vector. Raster images show parts as they 
appear in the document pane. For example, if Solid is selected, then the printed image includes shadings 
and surfaces. Vector images ignore shadings and print only edges, wireframes, markups, and dimensions. 

Printing involves the standard dialog boxes and options that are common to most Windows applications. 
For simple print jobs, the only difference is the presence of Scale options in the lower left corner of those 
dialog boxes. 

Set the scale for a print job 
You can include or exclude the background color and the View CS indicator in the printed image. 

1 Choose File > Print Setup or File > Print. 

2 Select Scale and the amount of scaling that you want to apply: 

• Scale value Choose a scale coefficient, or type to enter a decimal number. 

• Automatic Scale Calculates the scaling for you so that the image fits on one sheet of the 
selected paper size. 

You can set the scale value and advanced Scale features in Preferences. Use the Options button on the 
Printer Setup tab to see these settings. 

Scale values that you change in the Preferences, Print, or Print Setup dialog boxes update all three places. 

Define headers and footers for print jobs 
Printed documents can include a header, a footer, or both. A header or footer can contain multiple items 
of typed and automatic entries. 

1 Choose Edit > Preferences, and select Printer Setup. 

2 Select Header, and type to add text. 

3 Select an Align option for the header to set the horizontal position. 

4 In Add Option, choose an automatic entry for the header, if appropriate: 

• File Name Adds the name of the read file. 

• User Name Adds the name you registered when you installed Tetra4D Reviewer. 

• Printing Date Adds the current date when you print the document. 

• Scale Adds a note about the scale setting. 

5 Select Footer, and specify the text, alignment, and any of the automatic entries, as needed. 

6 Select options in the Font area or click Select to set these options in the Font dialog box. The header and 
footer Preferences apply to future print jobs until you change them. 



94  Using Tetra4D Reviewer™ 
 Exporting and printing 

 

Print multiple views on pages 
You can print several views of the components on the same page. 

1 Choose Edit > Preferences, select the Printer Setup tab. 

2 Select Options, choose frame and sheets options under Multiple Views, and close the Preferences. 

3 Choose Window > Split. 

4 Change the orientation, zoom, and visibility settings for each segment of the document pane, as needed. 

5 Start printing: 

• Choose File > Print Preview to see how the page appears, and then click Print. 

• Choose File > Print to print without a preview. 

The Preferences apply to future print jobs until you change them. If you drag the borders to collapse view 
panes, collapsed panes aren’t printed. Dragging the borders to resize the view panes has no effect on the 
printed views. 

See also 

“Showing multiple views of sessions”  

“Printer Setup preferences”  

Show the grid on printed pages 

Set up the printer for raster or vector printing 
1 Choose File > Print Setup. 

2 Set the Scale option: 

• To print raster images, deselect Scale. 

• To print vector images, select Scale. 

Set options for printing grids 
After you set up the printer for raster or vector printing, you can include the grid in the printed images. 
Some advanced options are available for vector images. 

1 Choose View > Grid. 

For raster printing, no further steps are necessary. For vector printing, you can continue to set advanced 
options. 

2 Choose Edit > Preferences, and select the Printer Setup tab. 

3 Click Options. 

4 If necessary, select Scale, and then select grid options: 

• Select one or more Step On [axis] options, to specify which axes you want to print. 

• Set values for the grids along each selected axis. 

• Select Extend To View to print the grid over the entire page. Or, leave it deselected to print the grid only 
over the area that contains parts. 

5 Click OK to apply and close the Preferences. 
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6 Choose File > Print Preview to make sure that the grid appears the way you want it to. 

• If you are satisfied with the appearance of the grid, click Print. 

• If you want to change the grid settings, click Cancel, and go back to the Grid preferences and select 
different settings. 

Preferences apply to future print jobs until you change them. If the grid is hidden at the time of printing, 
it doesn’t print. 

See also 

“Grids”  

“Printer Setup preferences”  
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Chapter 7: Preferences 
The Preferences dialog box determines global settings for Tetra4D Reviewer. After you change Preference 
options and click either OK or Apply, you must close and reopen the document for the changes to take 
effect. 

The Edit > Preferences command opens the Preferences dialog box so that all tabs are available. 

General preferences 
Language Sets the language for text in the application. Relevant only if multiple languages are installed on 
your computer. 

Confirm Deletion Of Unused Files Determines whether an alert appears when you close documents. 

Show Reading Options When Necessary Controls the display of reading options when opening CAD files 
by dragging. Select this option if you want to be able to access the reading options regardless of the 
technique used to open files. 

Drag & Drop: Reset Import/Open Dialog Box Cancels options previously selected when opening a file by 
dragging the file icon. (Available only if Always Do The Same is selected in the Drag And Drop To 
Open/Import Files dialog box.) 

Highlight Entity When Mouse Pointer Is On It Highlights selectable entities as the pointer hovers over 
those entities. The Highlight Selection option on the Selection Filter toolbar must be selected. 

Highlight Tree Item When Select Entity Expands the Model Tree structure to the entities selected in the 
document pane and highlights those entities. When deselected, the Model Tree structure doesn’t expand 
or collapse, and highlights the collapsed elements that contain the selected entities. 

Set Working Unit To Overrides the CAD file units of measurement for new documents, replacing the 
original units with the selected units. 

Precision Number of digits displayed to the right of the decimal. Applies to values in Physical Properties 
and for dimensions. 

2D preferences 
This tab contains parameters dedicated to native 2D drawings display. 

Default Background Color Opens a color picker for the background color. 

Simplify Text Size Sets the threshold size for greeking text that is too small to read at the current zoom 
level. Greeking replaces text with non-letterforms that act as placeholders in the document display. 

3D preferences 
This tab contains several areas, related to display and rendering parameters. 
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Rendering options 
Rendering buttons Set the default display mode: Solid, Wireframe, Illustration, or Perspective. Solid and 
Wireframe can be selected together or separately. Perspective can apply to any of the other three 
selections. 

Transparency Enables display of reduced transparency levels specified in the native CAD files and in 
Properties for selected parts. Deselecting Transparency is recommended for systems without graphic 
boards that support transparency. 

Material color  Enables display of reflective shine on the surfaces of parts. 

Default definition options 
You can apply customized 3D default preferences at your choice of levels: at the current document level 
and at the application level. The selected level determines whether the changes apply to the currently 
active document or to future documents. 

Default When selected, the changes to the 3D preference options become the default settings at the 
application level. These settings apply to future documents but don’t affect the current document. The 
Preview shows an example of how the settings affect the 3D image of a part. 

Note: The Apply button is available after you change one or more options. Clicking Apply while Default is 
selected doesn’t change the current document. Clicking Apply does save the changed application-level 
default settings so that you can continue working in the Preferences. 

Current Document When selected, changes in the 3D preference options apply to the active document 
but don’t affect future documents. When you switch from Default to Current Document, the preview 
images show the 3D options currently applied to the active document. 

Restore Default Reapplies default settings according to which level is selected: 

• When Default is selected, restores the application-level default settings installed with Tetra4D 
Reviewer. 

• When Current Document is selected, restores the currently saved application-level defaults as the 
default settings for the active document. 

Save As Default (Available only when Current Document is selected) Sets the currently selected options 
as the application-level defaults. 
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Light settings 
Lights menu Specifies the light source to which changes apply. 

Note: You can change the position of the lights by dragging them in the Preview display. If Current 
Document is selected, clicking Apply updates the display in the document pane. 

Enable Turns off or turns on the light selected in the Lights menu. 

Local Activates options in the Attenuation area for the selected light. 

Attenuation slider Increases or decreases the intensity of the selected light according to the selected 
method: 

Constant Changes the intensity by a constant factor. 

Linear Changes the intensity in proportion to the distance between the screen and the part. 

Quadratic Changes the intensity in proportion to the square of the distance between the screen and the 
part. 

Note: Results appear in the Preview as you change methods and drag the slider. 
 

Colors slider Increases or decreases the qualities of the selected light: 

Ambient Changes the level of the overall light in the scene. 

Diffuse Changes the level of focused light, like a spotlight. 

Specular Changes the degree of reflecting shine off the part. (Applies only when Material Colors is 
selected in the Rendering area.) 

Background options 
Scaled Background option and slider Displays the background color as a vertical gradient using different 
values of the selected color. Dragging the slider to the left lightens the upper end of the gradient. 
Dragging the slider to the right darkens the upper end of the gradient. 

Color picker Sets the background color. 

Note: The background color can vary between the configurations inside one document. 

Advanced dialog box 
Provides information about the graphic board of the computer and options for parameters linked to 
OpenGL capabilities of the graphic board. The available options and information depend on the type of 
graphics board in use. 

Use Hardware Acceleration   Activates hardware acceleration for display. 

Use Hardware Antialiasing  Enables high-quality rendering for images and text. 

Force Redraw  Disables management of display refreshes by the graphic board. 

Enable Double-sided Rendering  When deselected, improves performance by not rendering back 
triangles. 

Reverse Face Rendering Inverts the display of parts. 

Clipping Plane Position (For Perspective display mode) Controls the separation displayed between the 
clipping plane (OpenGl) and from the camera. 

  



99  Using Tetra4D Reviewer™ 
 Preferences 

 

 

Fly Through preferences 

Keyboard 
The list of keyboard shortcuts that apply only when Fly mode is active. You can edit the list, substituting 
keys that are easy for you to remember. 

Front Moves the camera forward, toward the target position. Back Moves the camera backward, away 
from the target position. Left Moves the target position to the left. 

Right Moves the target position to the right. 

Up Moves the target position up. Down Moves the target position down. Roll Left Tilts the camera to the 
left. 

Roll Right Tilts the camera to the right. 

Stop Pauses the movement. 

Speed Up Increases the movement speed. 

Speed Down Slows down the movement speed. 

Wheel Back Inverts the movement without changing the speed. 

Other options 
Mouse Drag the slider to the right to increase the sensitivity of the mouse or to the left to decrease 
sensitivity. 

Speed Drag the slider to the right to increase the Fly mode speed or to the left to decrease speed. 

Height Sets the value and units for the altitude of the camera above the reference plane. 

Units Lists available printers’, metric, and English units of length. 

Display Plane When selected, shows the reference plane as a transparent plane. 

Target Displays cross hairs indicating the direction in which the camera travels. 

Indicators Displays a speed indicator bar at the bottom of the document pane and a horizon indicator on 
the right side of the document pane. 

Restore Default Keys Replaces any custom-defined keys for Fly mode with the default control keys for 
Tetra4D Reviewer. 

Graphics preferences 
Level Of Detail Sets the precision for the screen display. Options range from Extra Low to Extra High. The 
Advanced option makes the Advanced button available. 

Default Applies the current settings as defaults for new documents and loaded parts. 

Current Document Applies the current settings to only the active document. 

Advanced (Available when Advanced is selected for Level Of Detail) Opens the Advanced dialog box for 
setting user- defined precision levels. See “Advanced options for Physical Properties calculations” . 

Edges color options Sets the color of wireframe edges. 

Set To Default Color When deselected, edges appear in the same color as the faces to which they belong. 
When selected, the color picker is available. 

Color Specifies the color in which edges appear. 
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Section color picker Sets the highlight color for the edges created by the cutting plane for a section. 

Items color picker Sets the color for parts or faces of parts that have no defined color. 

Framerate Threshold slider Sets the number of frames per second maintained during dynamic 
manipulations. When the complexity of the model causes the frame rate to fall below the specified value, 
the model is optimized during the manipulation. Optimization temporarily removes faces in the display 
while the model is in motion. 

View Uses smooth transitioning when you apply a different view, such as a different configuration or a 
default view. 

Zoom/Fit Uses smooth transitioning for changes in zoom level, including Fit Visible. 

Temporary Hide shortcuts Options that set the keyboard shortcuts for temporarily hiding and showing 
selected entities. 

Display Thickness Shows lines with a thickness for entities in wireframe display mode. 

Grid preferences 
Main Color Color picker for the major lines in the grid. Select Automatic to enable Tetra4D Reviewer to 
adapt the grid color according to the background color for each configuration. Select a specific color to 
prevent the line color from  adapting  to  different  backgroundcolors. 

Sub Color Color picker for the finer lines in the grid. Select Automatic to adapt to different background 
colors. Select a specific color to prevent the line color from adapting to different background colors. 

Style Graphic menu of line styles, such as a solid line, dotted line, and so forth. 

Note: The final option on the menu is blank. When selected, the grid lines are transparent but numbers 
for reference numbers along the sides of the document pane remain visible. 

Text Color picker Sets the color of the text that indicates reference numbers along the sides of the 
document pane. 

When Automatic is selected, Tetra4D Reviewer selects and updates the text color according to changes in 
background color. 

Font Designates the font family for grid reference numbers. When Automatic is selected, Tetra4D 
Reviewer manages font characteristics. 

Size Sets the font size for grid reference numbers. (Not available if Automatic is selected.) 

Select Opens the Font dialog box for setting more font options. (Not available if Automatic is selected.) 

Position options Selects the edges of the document pane where the grid reference numbers appear: Left, 
Right, Top, and Bottom. You can select any or all of these options. When none are selected, the reference 
numbers don’t  appear. 

Lock Rotation After selected and applied, disables the Rotation and Spin tools in future activations of Grid 
view. When you hide the grid, rotating and spinning are available again. When Lock Rotation is 
deselected, rotating and spinning are always available. 

Note: If the grid is shown when you select and apply Lock Rotation, rotating and spinning remain 
available. Rotating movements are locked after you hide the grid and then show it again. 
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Markups preferences 
Always Pre-select Default Font For session markups, applies the selected font preference settings to new 
3D markups, dimensions, and balloons. When deselected, applies the most recently used markup or 
dimension font properties to new markups, dimensions, and balloons. 

Font options Specify the default characteristics for markup text. You can select the font family, size, and 
style. 

Note: The Frame style option displays the markup text within a wireframe box. 

Color pickers Designates  colors  used  for markups: 

Text Applies the selected color to the text 

Attach Applies the selected color to the lines between the markup and the part. The same color applies to 
the wireframe box around the text that appears when Frame is selected in the Style area. 

Marker Applies to the dot at the markup end of a connector line. 

Always Substitute Always uses the Substitution Font selection to replace markup fonts for CAD markups 
read from the CAD files. 

Substitution Font Designates the font family used to substitute for CAD markup fonts. 

Preferred 3D PMI Rendering Mode  Defines how PMIs are processed. The selected setting affects all 
displayed PMIs. 

Use Content’s Setting PMIs behave as defined in native CAD files: either buffered or always in front. 

Always Render 3D PMI In Front Of Model PMIs always appear superimposed on visible parts so that 
PMIs are always visible. 

Always Render 3D PMI In Using Z-Buffer PMIs appear according to buffer-defined positions. When 
selected, a PMI or part can block other PMIs or parts in some views. 

Preferred 3D PMI Text Orientation Defines how the CAD-defined initial orientations of PMIs behave in 
the display. (Applies only to PMIs created with a flip attribute in the CAD application. 

Use Content’s Setting PMIs behave as defined in native CAD files: either always flipped or never flipped. 

Always Flip PMIs PMI text is always readable, regardless of changes in the orientation of parts. 

Never Flip PMIs PMI text always appears with the same orientation to the related parts. For example, 
when you turn the part upside down, the text is also upside down. If you rotate the part vertically, the 
text rotates, too, so at 180 degrees the text appears as the mirror image or the unrotated view. 

Printer Setup preferences 
All text appearing in the Header and Footer text boxes is included when you print. When Header is 
selected, Footer is unavailable, but it is not disabled. If you want to remove a header or footer, select that 
option and delete the text. 

Headers and footers characteristics are set separately. 

Header Activates the Header box where you type text that you want to appear across the top of printed 
pages. When selected, all other options apply only to headers. 

Footer Activates the Footer box where you type text that you want to appear across the bottom of 
printed pages. When selected, all other options apply only to footers. 

Align options Aligns the header or footer text: Left, Center, or Right, along the top or bottom of printed 
pages. 
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Add Option Automatically appends the designated item into the header or footer text. For example, if 
you typed “Project A,” in Header and then selected Printing Date (&t), the Header shows “Project A (&t).” 
When you print, the current date replaces the “(&t)” symbol. You can add multiple Add Option selections 
to a header or footer. 

Name Designates the font family for the header or footer text. 

Size Designates the font size for the header or footer text. 

Select Opens the Font dialog box, which has additional options for fonts. 

Style Specifies the selected typeface styles for the header or footer text. 

Options button Opens the Options dialog box for setting scaling, grid, and views options. 

Options dialog box 
Scale Enables options for scaling, grid, and views options. When deselected, prints raster images. When 
selected, prints vector images against a white background. 

Scale Coefficient  Sets the scaling coefficient for the printed image. 

Automatic Adjusts the scaling to fit the printed image on the currently selected paper size. 

Black And White Printed lines are converted to black during Printing. Available only when Scale is 
selected. 

White Background Changes the background to white for printing raster images. Available only when Scale 
is not selected. 

Main Frame  Draws a frame around the page, taking into account the format and the margins. 

Border Draws lines in the corners, indicating the limits of the printed page size. 

Step On X Designates the spacing of grid lines along the x-axis. If deselected, the x-axis lines are not 
printed. Step On Y Designates the spacing of grid lines along the y-axis. If deselected, the y-axis lines are 
not printed. Step On Z Designates the spacing of grid lines along the z-axis. If deselected, the z-axis lines 
are not printed. 

Extend To View Prints the grid for the entire background. If deselected, prints the grid only in areas 
where parts appear. 

Frame Around Views Draws a frame around each printed view. 

Views menu For printing a document with multiple views in different panes of a split window. Specifies 
which views are printed: 

• All Views Prints all currently displayed views on one sheet of paper. If the document pane is 
split unequally among the views, the relative proportions of the panes also appear on the 
printed page. 

• One View Per Sheet Prints each displayed view on a separate page. 

• Active View Only Prints the currently active view. 
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Reading Mode preferences 
B-rep (Solid) Boundary representation, by which solids are read as solids with topology. B-rep reads all 
exact geometry available in the CAD files and includes that geometry in the session. 

Tessellation (Faceted) Reads a representation of the solids but not to the standard of exact geometry. 
The tessellation can be read from any tessellation data in the CAD file. Or, the tessellation can be 
calculated from the exact geometry in the CAD file. 

Note: After a file is opened in B-rep reading mode, you can alternate between working in tessellated and 
exact-geometry representations of the file. If the file is read in Tessellation reading mode, exact 
geometry is not available. 

Enable Disk Cache An optimization mechanism used for reading large data files in B-rep reading mode. 
The cache stores some geometry and tessellation information on the local hard drive. The cache reduces 
the amount of data stored in the session. The result is that Tetra4D Reviewer can load a larger amount of 
data. 

Note: Caching is not recommended as long as the amount of data is compatible with the physical 
memory of the computer. As an alternative, consider incremental loading. 

More Opens the Enable Cache dialog box. The On Item With More Than option determines the minimum 
number of faces an entity must have before caching applies. 

Browse   Sets the location of the folder in which the cache is placed. 

Collapsed When selected, builds only a simplified version of the Model Tree. (It is not built when the data 
are read). Only one icon appears in the geometry folder, representing the read file (the one that was 
selected for the reading operation). 

Component The Model Tree structure builds only to the component part level. 

Expanded (Default) The tree is fully built during the reading operation, including the item parts under the 
component level. 

When caching files in a specific format, deselect Hidden Objects on the Read/Write CAD preferences for that format. 
See “Read/Write CAD preferences” . 

Read/Write CAD preferences 
File Formats Lists the CAD and standard formats that Tetra4D Reviewer is currently set up to read or 
write. You can add and remove formats. 

The options under Read Options and Write Options are format specific. Some formats have no associated 
option, including 3D Studio, HP-GL, Collada, KMZ, and WaveFront. Because options vary according to 
format, the order in which they appear also varies. 

Read options 
The Read Options area includes options that filter the types of information that are read when CAD files 
open in Tetra4D Reviewer. Options are format specific, so the available options change when you select 
different formats in  the File Formats list. Some formats have no reading options. 

Note: Options influence the reading time. Depending on the nature and the organization of the read 
files, the final number of read entities can vary substantially. 
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Filtering options 

3D PMI (Text, Notes, GD&T) Reads PMI markups and notes. 

Active Filter Reads only data stored in the active filter or on layers corresponding to the active filter. 

Attributes Reads non-geometric information linked to entities and files. 

Note: Attributes linked to solids and entities, such as Material and Density, are always read, even if 
Attributes is deselected. 

Construction & References  Includes construction entities, such as planes and axes. 

Filtering of entities (reading of Wireframe, Surfaces, Solid entities) If unchecked, the corresponding 
entities are ignored during reading. 

Hidden Objects Reading includes any objects that are present but currently hidden in the CAD file. 

Solids Reads solid parts. 

Surfaces  Reads surfaces of parts as entities. 

Wireframes  Reads all wireframe entities in the CAD file. 

Format options 

3D/Drawing Sets whether data is read to create a 3D model or a 2D drawing. 

Datum Includes construction entities, such as planes and axes, for Pro/ENGINEER format. Relates to the 
Display Visible Datum option. 

Default Units Reads the CAD units as the default for the imported document. 

Display Visible Datum (Relates to category-level show/hide options in Pro/ENGINEER files). Reads or 
ignores items that are visible in the original CAD file. 

Geometry Reads available geometry data in JT format files. 

Note: JT is a visualization format. By default, Tetra4D Reviewer reads JT files as tessellated data and 
ignores the Reading Mode setting in the Reading Mode preferences. 

Note Texts With Symbol Specifies how note text from IDEAS files appears. When selected, any symbols in 
the text appear in the read PMI notes. When deselected, definitions substitute for symbols in the text. 

Read Embedded PRW Reads any Tetra4D Reviewer documents that are embedded in the PDF. When 
selected, any session information from the PRW file is read. 

Tessellation With Setup Criteria (For PDF files with B-rep information) Specifies whether tessellation 
uses the current settings in Tetra4D Reviewer or the settings used to create the PDF. When selected, the 
Tetra4D Reviewer settingsare used. 

Write options 
Create Log File Generates a log of the exporting process. 

Write Hidden Objects Includes any hidden entities in the exported file. 

Version (For AutoCAD DXF format) Specifies which format version of DXF is written. 

Write In For AutoCAD DXF format 

Paperspace Writes entities to a 2D environment. 

Modelspace Writes entities to a 3D environment. 
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Save Solid To Specifies how solids are written: 

• Surface Solids are written as independent faces. 

• Solid Solid topology is kept. 

Save Faceted To Entities are faceted or exported as wireframes. 

Save Analytics To Determines the format for saving analytic surfaces, such as cylinders, cones, planes, 
and so forth. NURBS converts all analytics to NURBS surfaces. Analytics keeps analytics as analytics. 

Black And White  Ignores color characteristics when exporting to PostScript®. 

Automatic Conversion To PDF  (For PostScript) Automatically writes an PDF from the exported PostScript 
file. 

Use Short Names Shortens entity names to reduce the file size. 

STEP Standard  For STEP exports, determines whether files are AP203 or AP214. 

Level Of Detail (For STL) Applies when B-rep sessions are written to STL. Determines the quality used to 
generate the STL mesh: Extra Low, Low, Medium, High, Extra High, Advanced. (See “Read/Write Image 
preferences” on page 94.) 

Binary File (For STL) When selected, compresses the STL file to reduce file size. 

Formats (For Universal 3D exports) Sets the exported file format for U3D ECMA 1 (Reader 7.0 
Compatible) or U3D ECMA 3. 

Mesh Quality and Mesh Quality Value (For Universal 3D with U3D ECMA 3 selected) Determines the 
quality used to generate the Universal 3D mesh. 

Attributes Includes non-geometric information linked to entities and files. 

Assembly dialog box 
For some formats, an Assembly button appears in the Read Options area. Options in the Assembly dialog 
box identify the locations that Tetra4D Reviewer searches to load subassemblies and parts for the 
assembly document. 

Note: Options vary according to the selected file format. 

Recursive Search  Extends the search recursively. 

Use Root File Directory Searches subparts in the same directory as the head of the assembly. If not 
found, they are searched for in the additional search directories. The Browse button opens a dialog 
box with additional options: 

Additional Search Directories  Specifies other areas for the search. Buttons add New 
directories, Delete  selected directories, and move directories Up  or Down  the search 
order. 

Path Definition Files Specifies the location of text files that define additional paths. Buttons add 
New  files, Delete selected files from the list, and move the order in which files are 
listed Up or Down . 

Load Product Structure Only Loads only the Assembly structure (not the parts). Used for incremental 
loading. See “Loading CAD files in increments” . 

Cache Activation (CATIA 5) Enables caching and activates the path and Browse button for setting the 
location of the caching folder. 
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Allow Search In Other DDNAME (CATIA V4) Uses the options set by clicking the Browse button and 
setting the DDNAME. 

Preferred Reference Sets (Unigraphics format only.) Determines how references sets are determines and 
in what priority. 

Apply To All Levels (Unigraphics format only.) 

Syntax for a path-definition file 
When you set Assembly option preferences, use the following syntax to create an entry in the Path 
Definition Files list. 

syntax: "path name", [recursive = ] 1/0 
The keyword “recursive” can be omitted.  Values: 1 for recursive mode, 0 for nonrecursive. 

Example of a path definition file: “c:\data\project\”, recursive=1 
"f:\parts",recursive=0 "d:\special ",1 
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Read/Write Image preferences 
Preferences on the Read/Write Image tab apply to two-dimensional raster snapshots. 
 

Note: Changes you make to Write options apply only to the selected format and only after you click 
Apply. If you change several formats before clicking Apply, only the changes to the currently selected 
format are saved. 

File Formats Lists the formats that Tetra4D Reviewer can read and write. When highlighted, any options 
for that format appear under Write Options. Check boxes determine which formats appear in the Files Of 
Type menu in the Open dialog box. 

Quality slider (Appears for JPEG only) Sets the quality for writing JPEG images: Extra Low, Low, Medium, 
High, Extra High. 

Extension Editable menu of the extensions for available formats. You can select an extension from the 
menu or type a new extension in the box and click Add. 

Add  Adds an extension that you typed into the extension box. 

Remove  Deletes the currently shown extension from the extension menu. 

White Background Removes any background color in snapshot images. (This option doesn’t affect the 
actual background in the document pane view.) 

Display Trihedron   Includes the coordinates trihedron in the snapshot. 

Resolution Opens the Resolution dialog box, which contains additional options for raster images. 

Note: Generating high-resolution images takes time. It can also require large amounts of memory and 
storage space. For best results, use the minimum resolution that matches the quality requirements for 
your project. 

Window Matches the size of the Tetra4D Reviewer document pane window. 

Desktop Matches the resolution of the desktop on your local computer. 

Menu Lists various preset resolution settings, including the desktop resolution. 

Custom Makes the remaining options available. These options are useful for creating high-quality images 
at custom resolutions. See “Set Snapshot resolution” on page 72 and “Advanced resolution options” on 
page 72. 

Width (In Pixels) and Height (In Pixels) Determine the resolution of the image output. 

DPI (Dots per inch) When selected, makes the Width (mm), Height (mm), and DPI value box available. The 
value sets the resolution for the printed image. Changes to the DPI value remain in effect after you 
deselect the DPI option. 

Width (In mm) and Height (In mm) Dimensions of the print size, calculated according to the selected DPI 
and the pixel settings for width and height. 

Pixel dimensions, millimeter dimensions, and the DPI values are interrelated. Changes you make to one 
value cause recalculations of the other values. The affected values update when you press Tab or click to 
shift the focus to another option. 

Changes to DPI also change the pixel dimensions. 

Changes to a millimeter dimension also change the corresponding pixel dimension. 

Changes to a pixel dimension also change the corresponding millimeter dimension. These updates occur 
even when DPI is not selected. 
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The DPI value is specified by the user, and is never updated when other values are changed. Changes in 
dimension values don’t affect the DPI value. 

Views Management preferences 
Split Window options 

Split Window buttons Selecting a button activates the view and grid options for the corresponding split 
panes. 

Single Window Activates menu and grid options for only the first pane of a window split. 

2-Way Horizontal Sets the default behavior to create two panes, one above the other. The upper pane is 
the active view. When selected, view and grid preferences options are available for those two panes. 

2-Way Vertical Sets the default behavior to create two side-by-side panes. The left pane is the active 
view. When selected, view and grid preferences options are available for those two panes. 

4-Way Split Sets the default behavior to split the document pane horizontally and vertically, creating four 
panes. The upper-left pane becomes the active view. When selected, view and grid preferences options 
are available for all four panes. 

Select View Type menus Sets the default views for each pane in a split. The menu includes the default 
views and an eye icon  , which represents the view in the document pane at the time of the split. 

Grid buttons When selected, displays the grid in the selected pane. 

Restore All Resets the view menu and grid settings for all four panes. By default, grids are hidden. The 
upper-left pane shows ZX view (Front). The upper-right pane shows XZ view (Left). The lower-left pane 
shows YX view (Top). The lower-right pane shows the current view in the document pane at the time of 
the split. 

Standard Views options 

These options define the orientations used by the Default View commands. 

Select Iso View menu Designates which axis is vertical in isometric view. Choose: OZ, OX, or OY. The 
vertical axis is used as the main axis for isometric view. 

View Orientation Sets the orientation for Iso View. The menu choices appear as graphical representations 
of the relative positions of the x, y, and z axes for the selected Iso View. 

Note: The Select Iso View options affect the six default views listed in the lower area of the Views 
Management preferences. The View Orientation setting affects only isometric view. 

View Name Assigns a custom name to the Iso view (optional). The custom name appears as a tool tip for 
the Iso button in the Default Views toolbar. If the text field is blank, the default tool tip appears. 

V Axis value (Available only when the two-axes option is selected in View Orientation) Sets the angle 
between Iso View and the vertical axis. 

H Axis value (Available only when the two-axes option is selected in View Orientation) Sets the angle 
between Iso View and the horizontal axis. 

Individual View Orientation menus Define the axis orientation for each set of axes: YX, XY, ZY, ZX, XZ, and 
YZ axes. Any of these individual views keeps its viewing direction, but the view can be rotated around the 
perpendicular axis. 

Individual View Name options Define custom names for the individual view orientations. The custom 
names appear as a tool tips for the Default Views toolbar buttons. If left blank, the default tool tip 
appears for that view. 
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Chapter 8: Shortcuts 
Keyboard shortcuts are combinations that you type to apply various commands. Many shortcuts appear 
on the main menus, opposite the commands to which they apply. 

Shortcuts for Tetra4D ReviewerTM 
 

Result Shortcut 

New Ctrl+N 

Open Ctrl+O 

Import Ctrl+I 

Save Ctrl+S 

Save As Shift+Ctrl+S 

Export Ctrl+E 

Close window Ctrl+W 

Close all 
window
s 

Shift+Ctrl+W 

Print Ctrl+P 

Print Setup Shift+Ctrl+P 

Exit Ctrl+Q 

Copy selected 
items 

Ctrl+C 

Paste copied 
items 

Ctrl+V 

Delete Del 

Select All Ctrl+A 

Deselect All Shift+Ctrl+A 

Toggle selection Ctrl+T 

Find Ctrl+F 

Preferences Ctrl+K 

Show or hide the 
grid 

Ctrl+U 

Activatepreviou
s configuration 

F2 

Activate next 
configuratio
n 

F3 

Quick Snap F8 
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Show or hide the 
Model Tree 

F4 

Restore default 
toolbars 

Alt+F8 

Full Screen Ctrl+L 

Cascade 
window
s 

Shift+Ctrl+J 

Tile windows 
horizontally 

Shift+Ctrl+K 

Tile windows 
vertically 

Shift+Ctrl+L 

Focus on 
selected item 

F5 

Fit Visible F6 

Set camera from 
selection 

F7 

Flip Shift+F7 

Undo View 
operation 

Alt+Z 

Redo View 
operation 

Alt+Y 

 

Shortcuts for Fly mode 
For Fly mode, you can use the default shortcuts or define custom key combinations for the same items. 
 

Result Default shortcut 

Front R 

Back F 

Left Q 

Right D 

Up Z 

Down S 

Roll left A 

Roll right E 

Stop spacebar 

Speed up Num + [plus, on numeric keypad] 

Speed down Num - [minus, on numeric keypad] 

Wheel back Ctrl 
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See also 

“Viewing in Fly mode” on page 41 

 
Assign custom shortcuts for Fly mode 
1 Choose Edit > Preferences, and select the Fly Through tab. 

2 Type to replace a keyboard shortcuts with a different key. 

Note: When the new key is pressed, its value is directly assigned to the active field. Each key assignment is unique. 
If a key is already used for another function, no change occurs. 

 

Restore default keyboard shortcuts for Fly mode 
❖ On the Fly Through preferences tab, click Restore Default Keys. 

 

Shortcuts for Help 
 

Result Shortcut 

Open Help 
window 

F1 

Close Help 
window 

Ctrl+W 

Move back to 
previously 
opened topic 

Alt+Left Arrow 

Move forward 
to next topic 

Alt+Right Arrow 

Move to next 
pane 

Ctrl+Tab 

Move toprevious 
pane 

Shift+Ctrl+Tab 

Move focus to 
next link within a 
pane 

Tab 

Move focus to 
previous link 
within a pane 

Shift+Tab 

Activate 
highlighted link 

Enter 

Print Help topic Ctrl+P 
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